Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Community Lounge > Reviews, Rants & Things That Make You Scream
FedoraForum Search

Forgot Password? Join Us!

Reviews, Rants & Things That Make You Scream The place for you to submit reviews of all those applications you use with Fedora. The Devs probably aren't listening, but some times you've just GOT to blow off steam or sing its praises.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 16th December 2010, 12:55 AM
gatlin Offline
Registered User
 
Join Date: Dec 2009
Posts: 76
linuxfedorafirefox
Xilinx 12.3 on Fedora 14 (x86_64)

Xilinx does support GNU/Linux, but not in the rpm/deb/etc. way. I have managed to install Xilinx on my Fedora 14 system in a way with which I am happy.

Xilinx needs OpenMotif and PortMap on GNU/Linux. PortMap is pre-installed. OpenMotif is in Fedora's repositories (http://www.xilinx.com/support/answers/20944.htm).

I downloaded the very large file and extracted it. I extracted the tarball. I ran the xsetup sh file with super user privileges. I accepted the two license agreement parts, then clicked the radio-button for "ISE WebPack" because that is the free version. I checked the two checkable check boxes in the Installation menu(acquire or manage license key, and the cable drivers). For my selected installation directory, I chose /opt/Xilinx/12.3/ and the importing of old preferences didn't matter because I didn't have a previous version installed.

I created two files to make using Xilinx more acceptable on Linux. One is an executable and one is a menu entry.
/usr/local/bin/xilinx
/usr/share/applications/xilinx.desktop
##/usr/local/bin/xilinx
This file needs to be executable (sudo chmod +x /usr/local/bin/xilinx).
This is a copy of the settings64.sh file with two lines concatenated to it.
"export DISPLAY:=0"
"exec /opt/Xilinx/12.3/ISE_DS/ISE/bin/lin64/ise"

##/usr/share/applications/xilinx.desktop
This can be made with the application Main Menu (alacarte) or as a text file in /usr/share/applications with a .desktop extension.
I used the Application's Category as Electronics, but Programming is good too.
The Command is the executable /usr/local/bin/xilinx.
The Icon for the Menu entry is /opt/Xilinx/12.3/ISE_DS/ISE/data/images/pn-ise.png.
I named it "Xilinx 12.3".
My Comment was something along the lines of a Verilog and V.H.D.L. editor.
The Type is of course an "Application" since it is a G.U.I. and not a terminal based application.
Reply With Quote
  #2  
Old 16th December 2010, 06:32 PM
jp102235 Offline
Registered User
 
Join Date: Dec 2010
Posts: 8
macoschrome
Re: Xilinx 12.3 on Fedora 14 (x86_64)

Exactly what I was looking for - THANKS!!
I'll give it a shot right now. Let's see if it works in vm (fingers crossed)


john

---------- Post added at 12:32 PM ---------- Previous post was at 12:11 PM ----------

nope,
didn't work for me - are you running in a vm or on hardware?
perhaps I should start with a clean install, but even after disabling SELinux and rpm installing the openmotif stuff (from rpmfind.net ), the ./bin/lin64/xsetup executable did nothing , just immediately returned the command prompt.

should I strace it?

john

Last edited by jp102235; 16th December 2010 at 06:39 PM.
Reply With Quote
  #3  
Old 16th December 2010, 09:25 PM
gatlin Offline
Registered User
 
Join Date: Dec 2009
Posts: 76
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

I would not recommend using rpmfind.net when Fedora's repositories have the latest version of OpenMotif. I would always recommend Fedora's repositories over any other for installation on Fedora. I am running on hardware. I would suggest trying to install the development files as well. I am not sure if the Xilinx installer compiles anything or not, but development files might help.
Reply With Quote
  #4  
Old 16th December 2010, 09:33 PM
jp102235 Offline
Registered User
 
Join Date: Dec 2010
Posts: 8
macossafari
Re: Xilinx 12.3 on Fedora 14 (x86_64)

ok,
this is gonna seem like a silly question: how do I access the fedora repositories for OpenMotif? I was assuming I would have to yum or rpm to get OpenMotif. Are you saying I should get the latest from the fedora cvs/svn and compile?

I ask because I didn't find OpenMotif in the package manager gui, nor from the cli for yum.

-john-
Reply With Quote
  #5  
Old 16th December 2010, 10:06 PM
gatlin Offline
Registered User
 
Join Date: Dec 2009
Posts: 76
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

I always have "rpmfusion-nonfree" as a part of my list of repositories. I haven't tried rpmfind's, and I never have used rpmfind. I am weary of it because I don't think that it compiles the rpm for each O.S. and platform.
"sudo yum search openmotif"
then the results should be somethings like "openmotif"
I installed all of them. I would recommend installing the following: openmotif.x86_64 openmotif-devel.x86_64 openmotif-debuginfo.x86_64
"sudo yum install openmotif openmotif-devel openmotif-debuginfo"
Reply With Quote
  #6  
Old 16th December 2010, 10:45 PM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,878
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

That "export DISPLAY:=0" doesn't make sense. It will fail if the X display
is not 0. On my system (depending on whether I'm the only user or not)
the login display is :0.0, or even :48.0 (just checked). If you try to use
this as the alternate user then you will get a failure.
Reply With Quote
  #7  
Old 16th December 2010, 10:50 PM
gatlin Offline
Registered User
 
Join Date: Dec 2009
Posts: 76
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

I believe that Xilinx bundles A LOT of software within its release; such as perl, and I believe it carries an old version other components. I got this display setting from many places, but here is one source. http://lug.wsu.edu/node/383
Reply With Quote
  #8  
Old 18th December 2010, 05:15 PM
jp102235 Offline
Registered User
 
Join Date: Dec 2010
Posts: 8
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

Gatlin,
ok I loaded the openmotif packages, and best I can tell, Xilinx doesn't like me attempting to install the 64 bit version.
I force the 32 bit install (./bin/lin/xsetup) and it complains:
[root@fedpor Xilinx_ISE_DS_12]# ./bin/lin/xsetup
bash: ./bin/lin/xsetup: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

did I need to install some other library to get this to work?

john
Reply With Quote
  #9  
Old 18th December 2010, 10:35 PM
gatlin Offline
Registered User
 
Join Date: Dec 2009
Posts: 76
linuxopera
Re: Xilinx 12.3 on Fedora 14 (x86_64)

"Bad ELF interpreter" is when one has a 32 bit version trying to use a 64 bit version or vice versa. If you want to attempt the 32 bit installation you will probably have to have all of the 32 bit library dependencies. As for the failure to install as a 64 bit installation, hmm...
I am guessing that the G.U.I. installation window is not rendered. I, also, assume that since Xilinx requires the download manager gave you the full download. Is there any terminal output before the script fails? I would try using the xsetup file in the topmost folder, it establishes the path and such for the installation (if you wish to pursue the 32 bit installation then just gut the script from the conditional if statements to just the uppermost stuff and the execution of the 32 bit installation script). Do you have Qt installed? I believe that Xilinx on GNU/Linux uses Qt to display the G.U.I. (Are you using Gnome? I am using Fedora 14 with Gnome but I assume that it will install fine on K.D.E. too, since K.D.E. and Qt are close companions).
Reply With Quote
  #10  
Old 19th December 2010, 12:58 AM
jp102235 Offline
Registered User
 
Join Date: Dec 2010
Posts: 8
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

ok,
as far as the installation I am trying now: a fresh fedora 14 (64 bit) install on a vm.
I add the openmotif packages, and disable the selinux.

still nothing but a command prompt afer call ./xsetup.

I tried using su instead of sudo - same results.

strace:
stat("/usr/lib64/tls/x86_64", 0x7fffa9646870) = -1 ENOENT (No such file or directory)
open("/usr/lib64/tls/libPort_ExecLoader.so", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/tls", {st_mode=S_IFDIR|0555, st_size=4096, ...}) = 0
open("/usr/lib64/x86_64/libPort_ExecLoader.so", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/x86_64", 0x7fffa9646870) = -1 ENOENT (No such file or directory)
open("/usr/lib64/libPort_ExecLoader.so", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64", {st_mode=S_IFDIR|0555, st_size=69632, ...}) = 0
munmap(0x7f8a59301000, 62629) = 0
exit_group(0) = ?

I am not sure which Qt packages I got loaded - there were a few Qt packages in the gui - just wasn't sure which one would do the trick.

thanks so much on this

j
Reply With Quote
  #11  
Old 19th December 2010, 01:25 AM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,878
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

That is an strace of what exactly?
Reply With Quote
  #12  
Old 19th December 2010, 01:29 AM
gatlin Offline
Registered User
 
Join Date: Dec 2009
Posts: 76
linuxopera
Re: Xilinx 12.3 on Fedora 14 (x86_64)

qt.x86_64 is probably all that is needed.

I ran an strace on 12.3's xsetup (just in normal user mode, but that shoudln't matter). Results of the first few lines follow:
execve("./xsetup", ["./xsetup"], [/* 80 vars */]) = 0
brk(0) = 0xac5000
mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x7f9b10865000
access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
open("/usr/lib64/alliance/lib/tls/x86_64/libtinfo.so.5", O_RDONLY) = -1 ENOENT (No such file or directory)
...


I ran "sudo yum provides libtinfo.so.5" to get the following:
ncurses-libs-5.7-8.20100703.fc14.i686 : Ncurses libraries
Repo : fedora
Matched from:
Other : libtinfo.so.5



ncurses-libs-5.7-8.20100703.fc14.i686 : Ncurses libraries
Repo : installed
Matched from:
Other : Provides-match: libtinfo.so.5

---------- Post added at 06:29 PM ---------- Previous post was at 06:27 PM ----------

I suggest installing that, and trying to go from there on your system traces in a similar fashion. If you desire, I can post my whole system's trace while running the installer (in super user's mode too). I hope that that package resolves your problem.
Reply With Quote
  #13  
Old 19th December 2010, 01:55 AM
jpollard Offline
Registered User
 
Join Date: Aug 2009
Location: Waldorf, Maryland
Posts: 6,878
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

Wrong library.

You have the i686 library, but the program is asking for the x86-64 library
based on the missing "/usr/lib64...".

You can get the same info from a "ldd" command, plus it will tell you
what other libraries you may be missing.

Your problem is being caused by mixing a 64 bit application with
32 bit libraries on a 64 bit based system.

What I don't understand is how you got it that way - the dependancy
lists should have prevented this.
Reply With Quote
  #14  
Old 19th December 2010, 04:34 AM
gatlin Offline
Registered User
 
Join Date: Dec 2009
Posts: 76
linuxopera
Re: Xilinx 12.3 on Fedora 14 (x86_64)

You are right. In the sytem's trace it was x86_64. When I enter "yum provides libtinfo.so.5" it gave output with the i686 ncurses. I don't know why. I did check, just in case, with "yum info ncurses.x86_64" and it was installed. I really don't know why the only output to the provides was i686 libraries. I also don't think that Fedora comes without ncurses of the proper type. I just didn't see it in his system's trace and it was the first library on mine.

Last edited by gatlin; 19th December 2010 at 07:30 AM.
Reply With Quote
  #15  
Old 20th December 2010, 06:08 AM
jp102235 Offline
Registered User
 
Join Date: Dec 2010
Posts: 8
linuxfedorafirefox
Re: Xilinx 12.3 on Fedora 14 (x86_64)

ok,
it seems like xsetup is looking for libraries that are associated with gnu lib c.
Libdl.so2,libpthread.so.0,libstdc++.so.6,libm.so.6 ,libgcc_s.so.1,libPort_ExecLoader.so

with a ldd return of:
[jporche@fedpor Xilinx_ISE_DS_12]$ sudo ldd ./bin/lin64/xsetup
linux-vdso.so.1 => (0x00007ffff3f1b000)
libdl.so.2 => /lib64/libdl.so.2 (0x0000003fba200000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003fb9e00000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x0000003fc5600000)
libm.so.6 => /lib64/libm.so.6 (0x0000003fbaa00000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003fbba00000)
libc.so.6 => /lib64/libc.so.6 (0x0000003fb9a00000)
/lib64/ld-linux-x86-64.so.2 (0x0000003fb9600000)

I am sure that I have those libraries installed (the x86_64 versions) - so I am confounded as why this setup file is exiting early.

any other suggestions?

john

---------- Post added at 12:24 PM ---------- Previous post was at 11:15 AM ----------

Gatlin, et al,
here is what I have found this am:
the setup exec (./bin/lin64/setup) is searching for libraries on the installation media and can't find them.
The filenames called for by the executable are case sensitive, but the install media have the libraries in a all-lower-case format.

to test: I cp'd the libPort_ExecLoader.so from the media (its libport_execloader.so at that location) and corrected for the case it was looking for. The strace seems to indicate that the search for the library completed, and now it started searching for libPortability.so (another install media library)

The other libraries I posted were "file not found" errors that occurred during the search for the library, but eventually were found.

Is there a slick way of getting the executable to provide case insensitive searches for the libraries it is looking for? perhaps I can force the libraries to link directly?
thoughts?

john

---------- Post added 2010-12-20 at 12:08 AM ---------- Previous post was 2010-12-19 at 12:24 PM ----------

further update:
It seems my ISO of the xilinx install files corrupted the case of the filenames in the library (forcing all the filenames' upper/lower case names to be converted to lowercase) - so re-downloading the tar file fixed the library problem, and xilinx is running the install correctly -
strange problem - thanks for the help!

john

Last edited by jp102235; 19th December 2010 at 11:28 PM.
Reply With Quote
Reply

Tags
installation, xilinx

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 12 x86_64 stops booting on the fedora logo before log screen checoimg Hardware & Laptops 18 16th January 2011 07:58 PM
launching Xilinx Webpack ISE ask4nutz Using Fedora 4 16th December 2010 09:02 PM
Xilinx Installation error bkazour Using Fedora 2 15th December 2010 11:49 PM
Xilinx printer issue jimblah Using Fedora 2 4th November 2006 09:53 PM
Installing latest kernel-smp-2.6.15-1.1830_FC4.x86_64.rpm on FC3 x86_64 kmkale EOL (End Of Life) Versions 0 4th February 2006 09:56 AM


Current GMT-time: 00:56 (Saturday, 29-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
I Fresh Market - Xi'an Xianyang International Airport Travel Photos on Instagram