Fedora Linux Support Community & Resources Center
  #1  
Old 21st February 2012, 08:49 PM
dteague71 Offline
Registered User
 
Join Date: May 2011
Posts: 14
linuxfirefox
Remmina 1.0 install issues

I am trying to compile and install the latest release of remmina to fix some issues and I am getting this error when I run make

/usr/bin/ld: CMakeFiles/remmina.dir/src/remmina_public.c.o: undefined reference to symbol 'XFree'
/usr/bin/ld: note: 'XFree' is defined in DSO /usr/lib64/libX11.so.6 so try adding it to the linker command line
/usr/lib64/libX11.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[2]: *** [remmina/remmina] Error 1
make[1]: *** [remmina/CMakeFiles/remmina.dir/all] Error 2
make: *** [all] Error 2

I found some other suggestions but they did not seem to work. Any Help would be appreciated.


Thanks
David Teague
Reply With Quote
  #2  
Old 26th February 2012, 10:10 AM
Etecos Offline
Registered User
 
Join Date: Dec 2008
Posts: 2
macossafari
Re: Remmina 1.0 install issues

I have the same issue at the moment and did not yet found a solution
What suggestions did you find? Google showed me only some results about the DSO linking style, but this did not help me at all 8[
Reply With Quote
  #3  
Old 26th February 2012, 06:04 PM
piotrl Offline
Registered User
 
Join Date: Feb 2010
Posts: 2
linuxfirefox
Re: Remmina 1.0 install issues

Hi,

It's a known error in linking (issue #9 in github)
https://github.com/FreeRDP/Remmina/issues/9

You have to add "-lX11 -lpthread -lgdk_pixbuf-2.0 -lgio-2.0 -lgobject-2.0 -lgmodule-2.0 -lavahi-client -lavahi-common -lgthread-2.0" to the gcc command in CMakeFiles/remmina.dir/link.txt
Reply With Quote
  #4  
Old 26th February 2012, 06:56 PM
Etecos Offline
Registered User
 
Join Date: Dec 2008
Posts: 2
macossafari
Re: Remmina 1.0 install issues

This did the trick for me, thanks!
Somehow, I did not see the issue on github
Reply With Quote
  #5  
Old 26th February 2012, 11:39 PM
dteague71 Offline
Registered User
 
Join Date: May 2011
Posts: 14
macossafari
Re: Remmina 1.0 install issues

I loaded the new beta 1.47 and it fixed the issue. I had not done the fix above.
Reply With Quote
Reply

Tags
install, issues, remmina

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Remmina VNC authentication to Mac broken in F15 mcgd Using Fedora 0 23rd January 2012 04:09 AM
Remmina is terrible! rdesktop is worse! frantaylor Using Fedora 7 1st July 2011 04:18 PM
Install Issues: CD and DVD not working; USB install: "error loading operating system" jakeg Installation, Upgrades and Live Media 2 5th June 2007 06:20 PM
FC 5 install issues overtud1 Installation, Upgrades and Live Media 1 20th July 2006 01:31 PM
KDE 3.2.1 Install Issues daywalker Using Fedora 6 7th April 2004 05:18 PM


Current GMT-time: 16:05 (Sunday, 21-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat