Fedora Linux Support Community & Resources Center
  #1  
Old 31st May 2012, 08:56 PM
cottrellnc Offline
Registered User
 
Join Date: May 2012
Location: Winston-Salem, NC
Posts: 6
linuxfirefox
Radeon HD 6450 with fedora 17

Just updated to fedora 17 (x86 64-bit) via an install DVD plus the latest online updates. I'm suffering from stange video problems that weren't there in fedora 16. The box is a Dell XPS 8300 with Radeon HD 6450 (CAICOS) graphics, driving an HP L1906 flat-screen monitor at 1280 by 1024. Gnome tells me the driver in use is Gallium 0.4. Xorg.0.log shows ati_drv, radeon_drv, vesa_drv and fbdev_drv modules loaded.

So what's happening? On cold boot I'm getting one or other of the following effects:

1) Worst: a black screen with a tiny flickering margin at the top. No way to do anything with the system, power-down required.

2) Bad: full-screen video but pale and severely flickering. Possible to interact with the system (log on) at risk to eyesight!

Here's the strange part: if I manage to log on, I can then suspend and resume, and the video comes out clear as a bell (as it was all the time with fedora 16).
Reply With Quote
  #2  
Old 1st June 2012, 02:08 PM
cottrellnc Offline
Registered User
 
Join Date: May 2012
Location: Winston-Salem, NC
Posts: 6
linuxfirefox
Re: Radeon HD 6450 with fedora 17

Things seem to be have stabilized on effect 2) above: pale and flickering video on boot. The initial grub screen is fine, but graphics bad. Suspend/resume seems to work reliably to get the graphics to come right. Any thoughts?
Reply With Quote
  #3  
Old 1st June 2012, 04:08 PM
tashirosgt Offline
Registered User
 
Join Date: Aug 2004
Posts: 3,964
linuxfirefox
Re: Radeon HD 6450 with fedora 17

Quote:
Originally Posted by cottrellnc View Post

So what's happening?
Start by determining how your video hardware is detected. http://forums.fedoraforum.org/showthread.php?t=280420

I tried that on FC 17 this morning and noticed the output no longer distinguishes between "module" and "driver". It just says "Kernel driver in use".
__________________
"Never let the task you are trying to accomplish distract you from the study of computers."
Reply With Quote
  #4  
Old 1st June 2012, 07:44 PM
cottrellnc Offline
Registered User
 
Join Date: May 2012
Location: Winston-Salem, NC
Posts: 6
linuxfirefox
Re: Radeon HD 6450 with fedora 17

Thanks for replying. I think there is no problem with detection of the hardware. lspci shows me:

Code:
01:00.0 VGA compatible controller: ATI Technologies Inc NI Caicos \
[AMD RADEON HD 6450] (prog-if 00 [VGA controller])
...
Kernel driver in use: radeon
Let me describe what I'm seeing a bit more precisely.

1) No problem with the grub menu screen.
2) As soon as the graphical boot sequence starts (the animated logo thingy),
a fast, regular flickering or flashing starts.
3) This continues into the login screen, and continues once I'm logged on and
seeing my desktop. I'm able to access the menu that gives the suspend
option, but it's VERY hard on the eyes.
4) The flickering/flashing goes away totally after a suspend/resume.

I surmise that while the right drivers are being loaded for the video hardware, there's something wrong with the mode in which they're running at first (if that makes any sense). As I mentioned before, with FC 16 on the same box the video was fine from the start.
Reply With Quote
  #5  
Old 2nd June 2012, 02:29 AM
Spuck Offline
Registered User
 
Join Date: Jun 2012
Location: California, USA
Posts: 1
macosmidori
Re: Radeon HD 6450 with fedora 17

Hey, I'm having this exact same problem also! It was really suprising when I accidently clicked suspend and then it fixed the blinking.

I've got the same video card (AMD Radeon HD 6450). It worked fine on fedora 16.

I'm a linux newbie... so I'd love a solution or suggestions if anyone can figure this out. It's just annoying to have to suspend the computer every time I boot up to get rid of the violently flashing screen. Thanks.
Reply With Quote
  #6  
Old 3rd June 2012, 10:07 PM
cottrellnc Offline
Registered User
 
Join Date: May 2012
Location: Winston-Salem, NC
Posts: 6
linuxfirefox
Re: Radeon HD 6450 with fedora 17

Nice to know I'm not alone ;-)

I've now filed a bug on this; see https://bugzilla.redhat.com/show_bug.cgi?id=827895
Reply With Quote
  #7  
Old 7th June 2012, 01:53 AM
jovcek Offline
Registered User
 
Join Date: Jul 2010
Location: Shtip, Macedonia
Posts: 13
linuxfirefox
Re: Radeon HD 6450 with fedora 17

Hi, does this help?

http://forums.fedoraforum.org/showthread.php?t=280277
Reply With Quote
  #8  
Old 7th June 2012, 02:27 AM
cottrellnc Offline
Registered User
 
Join Date: May 2012
Location: Winston-Salem, NC
Posts: 6
linuxfirefox
Re: Radeon HD 6450 with fedora 17

Thanks, but it seems the problem I have is different. The resolution is OK; the issue
is probably that the vesafb driver (built into the fedora 17 kernel) is being engaged
when the radeon kernel module should be used. There's more on this at the bug URL
I posted earlier (#6).
Reply With Quote
  #9  
Old 7th March 2013, 04:30 AM
Screamy Offline
Registered User
 
Join Date: Nov 2008
Posts: 2
windows_7firefox
Re: Radeon HD 6450 with fedora 17

Yeah, this is a pretty old thread, but I thought this info might save someone a little hair pulling:

I had the exact same problem recently (black screen/tiny flickering margin at top, full-screen video but pale and severely flickering) on Fedora 18, while using a Radeon 6450 PCI-E video card.

I fixed it thusly:

Code:
yum install akmod-catalyst
reboot the system, then as root, rebuild initramfs (backing up the old img first):

Code:
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-radeon.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)
Reply With Quote
Reply

Tags
6450, fedora, radeon, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please could some1 provide a one-liner for Radeon 6450 install on FC15 gattler Installation, Upgrades and Live Media 0 28th May 2011 03:54 AM
[SOLVED] Replacing Radeon 9550 with Radeon X1300/X1550, low FPS... muadib25 Hardware & Laptops 1 5th April 2010 06:09 PM
Fedora Core and Dell PowerEdge 6450 Justin00 Servers & Networking 6 30th May 2007 11:05 PM
nother dual head: Radeon 9200 + Radeon 7500 ZeuS572 Hardware & Laptops 2 15th June 2005 05:03 PM
ATI 3.12.0 driver issuesATI Radeon Mobility U1, aka ATI Radeon IGP 320M drivers? jroysdon Hardware & Laptops 1 12th September 2004 08:31 AM


Current GMT-time: 04:23 (Sunday, 26-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Misrikh - Bugarama Photos - Bitola Travel Photos