Fedora Linux Support Community & Resources Center
  #1  
Old 18th December 2006, 12:01 AM
Diskonekted Offline
Registered User
 
Join Date: Dec 2006
Posts: 2
Exclamation How to fix "INPUT NOT SUPPORTED"

After looking for quite some time and piecing together parts from different forums, I finally fixed my problem of having "Input not supported" displayed when booting Fedora Core 6.

Although the install went fine and the boot loader looked alright, during the boot, this error message was displayed. I was using a Acer LCD 19" and an ATI X1600Pro video card. Some posts that I saw were regarding the screen refresh rate, however when hooking up my CRT, I got another error saying that the frequencies were out of range. If you had either of these error messages, this post might be able to help you.

I'm quite a newbie to Linux so if I make a mistake, please forgive me.

1. Create a Rescue Disc
2. Boot to the disc and press ENTER (Enter Rescue Mode)
3. Either choose to enable networking or not, but select "Mout system image" (this is the installation of Fedora)
4. If you try to log-in straight away, you won't get far as your trying to log into the CD not your installtion of Linux.
5. Type: chroot /mnt/sysimage (this will allow you to log into Fedora, not the Rescue Disc)
6. type: login
7. enter in your account and password
8. Then type: nano /etc/X11/xorg.conf (this is your screen setup file, the X, MUST be upper case and the "nano" part is the text editor, you can use "gedit" or a few others, but this is the only one that worked for me)
9. You'll see something like this(this is my xorg before editing):

Section "SeverLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

10. In the Screen Sub Section, if there is no heading called "Modes", then add it in underneath "Depth" (these will be the resolution modes that Fedora will recognise, if there isn't anything there, then Fedora will not display anything)
11. After editing, this is what my xorg.conf looked like:

Section "SeverLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1024x768" "800x600"
EndSubSection
EndSection

NOTE: It won't matter if the text moves onto the next line.

12.To exit out of Nano editor, press [CTRL]+[X] and select to save the changes.
13. type: exit (to reboot the computer from the Shell, remember to remove the Resuce Disc)
14. Boot as usual and enjoy graphical use of Fedora Core 6!!
Reply With Quote
  #2  
Old 18th December 2006, 12:14 AM
Dies Offline
Registered User
 
Join Date: Oct 2006
Posts: 4,754
Nice you could probably replace steps 1-6 with:

1. Press any key when you see grub come up. If you use a password - press p and enter your pass.
2. Hit "a".
3. Leave a space and enter the number 3. Hit enter.

Also sometimes you just need to change the driver because the one selected even though it matches for your card just doesn't work, like you get the "nv" or "radeon" one and you have to switch it to "vesa" or "vga" till you get the right drivers or sometimes you need to input the correct refresh for your monitor, like:

HorizSync 55.0 - 65.0
VertRefresh 55.0 - 65.0

in your Monitor Section.

But nice job, and hopefully it gets stickied.
Reply With Quote
  #3  
Old 18th December 2006, 12:50 AM
leigh123linux
Guest
 
Posts: n/a
Hi noticed your graphics card model heres a copy of my xorg.conf
Attached Files
File Type: conf xorg.conf (2.6 KB, 177 views)
Reply With Quote
  #4  
Old 18th December 2006, 01:01 AM
Diskonekted Offline
Registered User
 
Join Date: Dec 2006
Posts: 2
Hey Dies,

Yeh I knew there was a way to change it through GRUB, but I couldn't remember how to do it. I also know that you can change your refresh with the commands:

hsync=xx
or
vsync=xx

Hope this helps someone out, thanks for replies too.
Reply With Quote
Reply

Tags
fix, input not supported

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
noob with "input not supported" problem marsjoseph Hardware & Laptops 2 11th June 2008 12:42 PM
FC7 - fresh install - "Input Not Supported" superjacent Installation, Upgrades and Live Media 1 27th October 2007 05:19 PM
acer LCD monitor "Input Not Supported" in login screen jake95159 Hardware & Laptops 1 22nd May 2006 03:48 AM
Samba Server (Win XP Home) FC5 Client... "Input/output error" naxfen Servers & Networking 3 8th May 2006 06:57 PM
Error:visibility arg must be one of "default", "hidden", "protected" or "internal" wangfeng Using Fedora 0 23rd May 2005 04:59 AM


Current GMT-time: 05:22 (Thursday, 28-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat