Fedora Linux Support Community & Resources Center
  #1  
Old 29th May 2008, 02:08 PM
PaulClarke Offline
Registered User
 
Join Date: May 2005
Location: Canberra Australia
Age: 58
Posts: 205
New Video Driver for Nvidia+F9

Hello,

I upgraded from F8 to 9 and then tried to upgrade to the new nvidia driver but am having problems. According to my Grub I have two option when booting they are
1. Fedora (2.6.25-14.fc9.i686) and
2. Fedora-base (2.6.25.3-18.fc9.i686.

After attempting to install the new driver I seem to have it install on the second option but not on the first. When I select the first the boot up process get to the kmod part and says the module cannot be found and the driver is disabled.

I tired to reinstall the driver but this failed

What is going on here?

Paul
Reply With Quote
  #2  
Old 29th May 2008, 03:05 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by PaulClarke
Hello,

I upgraded from F8 to 9 and then tried to upgrade to the new nvidia driver but am having problems. According to my Grub I have two option when booting they are
1. Fedora (2.6.25-14.fc9.i686) and
2. Fedora-base (2.6.25.3-18.fc9.i686.

After attempting to install the new driver I seem to have it install on the second option but not on the first. When I select the first the boot up process get to the kmod part and says the module cannot be found and the driver is disabled.

I tired to reinstall the driver but this failed

What is going on here?

Paul

Quote:
What is going on here?
There is no kmod for the release kernel !

Remove the Livna kmod-nvidia driver and try the Livna akmod-nvidia driver instead !

You will need both matching kernel-devels as akmod builds the needed kmods for the kernel .


Code:
su -
yum erase kmod-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia
yum install akmods akmod-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia
rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/releases/9/Fedora/i386/os/Packages/kernel-2.6.25-14.fc9.i686.rpm
akmods --kernel 2.6.25-14.fc9.i686
akmods --kernel 2.6.25.3-18.fc9.i686
Code:
[leigh@localhost ~]$ rpm -qa |grep nvidia
akmod-nvidia-173.14.05-2.lvn9.x86_64
kmod-nvidia-2.6.25.4-30.fc9.x86_64-173.14.05-2.fc9.x86_64
kmod-nvidia-2.6.25.4-38.fc9.x86_64-173.14.05-2.fc9.x86_64
xorg-x11-drv-nvidia-libs-173.14.05-1.lvn9.x86_64
xorg-x11-drv-nvidia-173.14.05-1.lvn9.x86_64
xorg-x11-drv-nvidia-libs-173.14.05-1.lvn9.i386
[leigh@localhost ~]

Last edited by leigh123linux; 29th May 2008 at 03:08 PM.
Reply With Quote
  #3  
Old 29th May 2008, 03:38 PM
Melio Offline
Registered User
 
Join Date: Feb 2004
Location: South Carolina, USA
Age: 38
Posts: 469
what is an "AKMOD"
__________________
os[Linux F9 Fedora 9 release i386 ]
cpu[Dual Intel(R) Pentium(R) Dual CPU E2200 @ 2.20GHz 2194.569 MHz (Bogomips: 8779.42)]
mem[2GB ]
video[ MSI NX8600GT Twin Turbo GeForce 8600GT 256MB 128-bit GDDR3 PCI Express x16 SLI Supported Video Card (Dual Optiquest Q20WB LCD wide Screen Monitors ]
Linux Registered User #391755
Smolt Profile
Reply With Quote
  #4  
Old 29th May 2008, 03:48 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by Melio
what is an "AKMOD"
http://forums.fedoraforum.org/showth...41#post1021241

Code:
[leigh@localhost ~]$ yum info akmods
Loaded plugins: changelog, refresh-packagekit
Installed Packages
Name       : akmods
Arch       : noarch
Version    : 0.3.1
Release    : 1.lvn9
Size       : 26 k
Repo       : installed
Summary    : Automatic kmods build and install tool
URL        : http://rpmfusion.org/Packaging/KernelModules/Akmods
License    : MIT
Description: Akmods startup script will rebuild akmod packages during system
           : boot while its background daemon will build them for kernels right
           : after they were installed.

[leigh@localhost ~]$

Last edited by leigh123linux; 29th May 2008 at 03:55 PM.
Reply With Quote
  #5  
Old 29th May 2008, 04:35 PM
awesomo Offline
Registered User
 
Join Date: Sep 2007
Location: Glasgow, Scotland, United Kingdom
Posts: 60
Hi Leigh123,

I have a GForce 4 mx card and in F7 and F8 I followed firewing1's instructions here www.firewing1.com/content/view/88/52/. This neant using the Livna repo and installing kmod-nvidia-96xx and xorg-x11-drv-nvidia-96xx. Could you please tell me what has changed for F9? Do I install a different driver or do I have to wait for a new kmod-nvidia-96xx and xorg-x11-drv-nvidia-96xx?

I'd be grateful for any advice.
Reply With Quote
  #6  
Old 29th May 2008, 05:02 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by awesomo
Hi Leigh123,

I have a GForce 4 mx card and in F7 and F8 I followed firewing1's instructions here www.firewing1.com/content/view/88/52/. This neant using the Livna repo and installing kmod-nvidia-96xx and xorg-x11-drv-nvidia-96xx. Could you please tell me what has changed for F9? Do I install a different driver or do I have to wait for a new kmod-nvidia-96xx and xorg-x11-drv-nvidia-96xx?

I'd be grateful for any advice.
At present all Nvidia legacy cards are unsupported in F9 due to the xorg server version used in F9 !
Reply With Quote
  #7  
Old 30th May 2008, 01:39 PM
PaulClarke Offline
Registered User
 
Join Date: May 2005
Location: Canberra Australia
Age: 58
Posts: 205
Hello,

I have tired your solution and I get the following outcomes

Installed: akmod-nvidia.i686 0:173.14.05-2.lvn9 xorg-x11-drv-nvidia.i386 0:173.14.05-1.lvn9 xorg-x11-drv-nvidia-libs.i386 0:173.14.05-1.lvn9
Complete!
[root@localhost paul]# rpm -ivh http://fedora.tu-chemnitz.de/pub/lin...4.fc9.i686.rpm
Retrieving http://fedora.tu-chemnitz.de/pub/lin...4.fc9.i686.rpm
Preparing... ########################################### [100%]
package kernel-2.6.25.3-18.fc9.i686 (which is newer than kernel-2.6.25-14.fc9.i686) is already installed
package kernel-2.6.25-14.fc9.i686 is already installed
[root@localhost paul]# akmods --kernel 2.6.25-14.fc9.i686
bash: akmods: command not found
[root@localhost paul]# akmods --kernel 2.6.25.3-18.fc9.i686
bash: akmods: command not found
[root@localhost paul]#
[root@localhost paul]#
End

What am I doing incorrect?

Thank you for your support

Paul
Reply With Quote
  #8  
Old 30th May 2008, 01:45 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by PaulClarke
Hello,

I have tired your solution and I get the following outcomes

Installed: akmod-nvidia.i686 0:173.14.05-2.lvn9 xorg-x11-drv-nvidia.i386 0:173.14.05-1.lvn9 xorg-x11-drv-nvidia-libs.i386 0:173.14.05-1.lvn9
Complete!
[root@localhost paul]# rpm -ivh http://fedora.tu-chemnitz.de/pub/lin...4.fc9.i686.rpm
Retrieving http://fedora.tu-chemnitz.de/pub/lin...4.fc9.i686.rpm
Preparing... ########################################### [100%]
package kernel-2.6.25.3-18.fc9.i686 (which is newer than kernel-2.6.25-14.fc9.i686) is already installed
package kernel-2.6.25-14.fc9.i686 is already installed
[root@localhost paul]# akmods --kernel 2.6.25-14.fc9.i686
bash: akmods: command not found
[root@localhost paul]# akmods --kernel 2.6.25.3-18.fc9.i686
bash: akmods: command not found
[root@localhost paul]#
[root@localhost paul]#
End

What am I doing incorrect?

Thank you for your support

Paul

You need the dash on su ( you have to be full root i.e su - )


Code:
su -

Code:
su -
rpm -ivh --oldpackage http://koji.fedoraproject.org/packages/kernel/2.6.25/14.fc9/i686/kernel-devel-2.6.25-14.fc9.i686.rpm
akmods --kernel 2.6.25-14.fc9.i686
akmods --kernel 2.6.25.3-18.fc9.i686

Last edited by leigh123linux; 30th May 2008 at 01:49 PM.
Reply With Quote
  #9  
Old 30th May 2008, 01:50 PM
leigh123linux
Guest
 
Posts: n/a
I have correct the package in the previous post ( you need the devel )

Code:
rpm -ivh http://koji.fedoraproject.org/packages/kernel/2.6.25/14.fc9/i686/kernel-devel-2.6.25-14.fc9.i686.rpm
Reply With Quote
  #10  
Old 30th May 2008, 01:59 PM
PaulClarke Offline
Registered User
 
Join Date: May 2005
Location: Canberra Australia
Age: 58
Posts: 205
Still no luck

[root@localhost ~]# rpm -ivh http://koji.fedoraproject.org/packag...4.fc9.i686.rpm
Retrieving http://koji.fedoraproject.org/packag...4.fc9.i686.rpm
error: skipping http://koji.fedoraproject.org/packag...4.fc9.i686.rpm - transfer failed - Unknown or unexpected error
[root@localhost ~]#
Reply With Quote
  #11  
Old 30th May 2008, 02:10 PM
leigh123linux
Guest
 
Posts: n/a
Quote:
Originally Posted by PaulClarke
Still no luck

[root@localhost ~]# rpm -ivh http://koji.fedoraproject.org/packag...4.fc9.i686.rpm
Retrieving http://koji.fedoraproject.org/packag...4.fc9.i686.rpm
error: skipping http://koji.fedoraproject.org/packag...4.fc9.i686.rpm - transfer failed - Unknown or unexpected error
[root@localhost ~]#
Try
Code:
su -
wget http://koji.fedoraproject.org/packages/kernel/2.6.25/14.fc9/i686/kernel-devel-2.6.25-14.fc9.i686.rpm
rpm -ivh kernel-devel-2.6.25-14.fc9.i686.rpm
akmods --kernel 2.6.25-14.fc9.i686
akmods --kernel 2.6.25.3-18.fc9.i686


Or
Code:
su -
rpm -ivh http://kojipkgs.fedoraproject.org/packages/kernel/2.6.25/14.fc9/i686/kernel-devel-2.6.25-14.fc9.i686.rpm
akmods --kernel 2.6.25-14.fc9.i686
akmods --kernel 2.6.25.3-18.fc9.i686
Reply With Quote
  #12  
Old 30th May 2008, 11:06 PM
PaulClarke Offline
Registered User
 
Join Date: May 2005
Location: Canberra Australia
Age: 58
Posts: 205
Hello,

Sorry after the last one I went to bed. It has not changed the 25.3-18 works and the 25-14 does not. All the command lines seem to work fine.

Tell what is the difference between the two boot options? Is the 25-3 functionally OK to use?

Paul
Reply With Quote
  #13  
Old 6th June 2008, 06:32 PM
DteK Offline
Registered User
 
Join Date: Jun 2008
Posts: 9
Hello leigh123
I registered to say that you instructions worked for me after I spent hours trying to get kmod-nvidia to work.

couple of questions:
as I understand it akmod build the drivers for your system at boot time depending on the kernel you have, is that correct?

does that mean that there will be no need to kmod-* from here out?

does that mean that issues with upgrading the kernel and not having the matching nvidia drivers should be resolved as they are now built dynamically.

Thanks again for the info you have provided.

D
Reply With Quote
  #14  
Old 19th September 2008, 01:27 PM
dhimes Offline
Registered User
 
Join Date: Jan 2008
Location: Marblehead MA USA
Posts: 296
DTek,

Excellent questions I was wondering myself. I also was wondering how we are supposed to find out about this stuff? For instance, in leigh123's howto link for f9 it's not mentioned.
Reply With Quote
  #15  
Old 19th September 2008, 03:59 PM
arnott Offline
Registered User
 
Join Date: Aug 2006
Posts: 33
Quote:
Originally Posted by leigh123@linux
There is no kmod for the release kernel !

Remove the Livna kmod-nvidia driver and try the Livna akmod-nvidia driver instead !

You will need both matching kernel-devels as akmod builds the needed kmods for the kernel .


Code:
su -
yum erase kmod-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia
yum install akmods akmod-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia
rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/releases/9/Fedora/i386/os/Packages/kernel-2.6.25-14.fc9.i686.rpm
akmods --kernel 2.6.25-14.fc9.i686
akmods --kernel 2.6.25.3-18.fc9.i686
Code:
[leigh@localhost ~]$ rpm -qa |grep nvidia
akmod-nvidia-173.14.05-2.lvn9.x86_64
kmod-nvidia-2.6.25.4-30.fc9.x86_64-173.14.05-2.fc9.x86_64
kmod-nvidia-2.6.25.4-38.fc9.x86_64-173.14.05-2.fc9.x86_64
xorg-x11-drv-nvidia-libs-173.14.05-1.lvn9.x86_64
xorg-x11-drv-nvidia-173.14.05-1.lvn9.x86_64
xorg-x11-drv-nvidia-libs-173.14.05-1.lvn9.i386
[leigh@localhost ~]

My graphics card is GeForce4 FX5200XT and am running F9, do I need to uninstall kmod-nvidia and install akmod-nvidia ?

Thanks
arnott
Reply With Quote
Reply

Tags
driver, nvidia, video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cedega 7.3, fedora 11, and 9800M nvidia video driver xaltednet Using Fedora 6 10th October 2009 01:56 PM
Just a rant: NVIDIA video driver xxxxxme Using Fedora 9 22nd September 2006 12:37 AM
Nvidia video driver installation help bigbrotherrebec Installation, Upgrades and Live Media 17 5th September 2006 04:09 AM


Current GMT-time: 05:56 (Saturday, 01-11-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat
Maassluis Photos on Instagram - Hangal - Pathardih