Fedora Linux Support Community & Resources Center
  #1  
Old 8th June 2008, 01:13 PM
winston154 Offline
Registered User
 
Join Date: Dec 2006
Posts: 37
F9 Nvidia driver Problem: blank screen with blue line on top

After installing livna's kmod-nvidia package and restarting X, my screen is blank except for a thin blue line on top of the screen. I have a GEforce 6100 graphics card ( an onboard card) and a Acer monitor.

I know another person had this same problem and he updated his video card with a new nvidia 8400 GPU. I dont want to do that if I dont have to.
Reply With Quote
  #2  
Old 8th June 2008, 01:52 PM
dan.btown Offline
Registered User
 
Join Date: Apr 2008
Location: Berlin (Germany)
Posts: 125
Question

Hi winston154,

pls. open a terminal (or rather, switch to a terminal) and enter the following commands in turn:
  1. This collects issues related to the X server:
    Code:
    cat /var/log/Xorg.0.log | grep '^(!!)\|^(WW)\|^(EE)\|^(NI)\|^(??)' > /home/YOUR-ACCOUNT/02.x.txt
  2. This collects issues related to the setup procedure of the X server:
    Code:
    cat /var/log/Xorg.setup.log | grep '^(!!)\|^(WW)\|^(EE)\|^(NI)\|^(??)' > /home/YOUR-ACCOUNT/03.x-setup.txt

Pls. come back here and post the contents of the 2 resulting files, each wrapped in CODE-tags, using the number sign button ("#") atop the text field of the forum software.

If you manage to solve your issues yourself, pls. come back anyway and tell us how you managed to fix them, so other users can learn from your experience.

Cheers,

-- Dan
Reply With Quote
  #3  
Old 8th June 2008, 02:51 PM
winston154 Offline
Registered User
 
Join Date: Dec 2006
Posts: 37
output for cat /var/log/Xorg.0.log | grep '^(!!)\|^(WW)\|^(EE)\|^(NI)\|^(??)' > /home/cbh/02.x.txt:
(WW) NV(0): Unable to estimate virtual size
(WW) <default pointer>: No Device specified, looking for one...

output for cat /var/log/Xorg.setup.log | grep '^(!!)\|^(WW)\|^(EE)\|^(NI)\|^(??)' > /home/cbh/03.x-setup.txt:
cat: /var/log/Xorg.setup.log: No such file or directory
I do have an Xorg.0.log.

I should also say that when I logged in this time after install the kmod-nvidia files I could see the startup but when I got to the login screen I could only see a black screen with a small blue line at the top.
I logged in under the previous kernal to be able to post this.
Reply With Quote
  #4  
Old 8th June 2008, 11:14 PM
wintersm Offline
Registered User
 
Join Date: Jul 2006
Posts: 293
I have the same setup as winston, onboard 6100, acer monitor, using x86_64 and exactly the same problem, cant post the result of the above commands until maybe tonight, had to go back to useing neauvau (or however its spelt)..
Reply With Quote
  #5  
Old 11th June 2008, 02:08 AM
dan.btown Offline
Registered User
 
Join Date: Apr 2008
Location: Berlin (Germany)
Posts: 125
Hi winston154 and wintersm,

unfortunatly, I've no idea of the Livna X drivers for Nvidia cards, so I'm afraid I can't really help you out. However, a forum search should reveal relevant information for you both.

The lines returned by the 1st command I asked you to issue don't report anything upsetting, that's why the X system marked them as warnings only (WW).


Just in case you can't even access a terminal screen because your system startup "hangs" while starting the graphics mode:

Start into rescue mode (using an install media); when asked if your system partition should be mounted to /mnt/sysimage, say yes. At the shell, say chroot /mnt/sysimage and issue the command
Code:
nano /etc/inittab
Nano is a simple text editor which is, well, nano, and mostly self-explaining. The upward arrows ("^") before the characters at the bottom of the screen mean: Press <CTRL> with the respective character.

In the file opened (/etc/inittab), look for a line containing the text id:5:initdefault: and change it to id:3:initdefault: , then restart as usual.

The change will avoid the Graphical User Interface to be started automatically and will instead bring you to a text login screen, from where you can do the necessary things (like installing and updating driver packages). One of the first things you may want to install if you haven't already is the Midnight Commander (to be started with the command mc), which offers convenient ways around your machine and the file system.

After installing drivers for the X system and checking they work, you can undo the above change (that is, 3 -> 5 again).

Aloha,

-- Dan
Reply With Quote
  #6  
Old 11th June 2008, 02:18 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,292
Quote:
Originally Posted by winston154
output for cat /var/log/Xorg.0.log | grep '^(!!)\|^(WW)\|^(EE)\|^(NI)\|^(??)' > /home/cbh/02.x.txt:
(WW) NV(0): Unable to estimate virtual size
(WW) <default pointer>: No Device specified, looking for one...

output for cat /var/log/Xorg.setup.log | grep '^(!!)\|^(WW)\|^(EE)\|^(NI)\|^(??)' > /home/cbh/03.x-setup.txt:
cat: /var/log/Xorg.setup.log: No such file or directory
I do have an Xorg.0.log.

I should also say that when I logged in this time after install the kmod-nvidia files I could see the startup but when I got to the login screen I could only see a black screen with a small blue line at the top.
I logged in under the previous kernal to be able to post this.
You may have installed the nvidia proprietary driver, but your logfile says that your machine is still using the open-source 'nv' driver that comes with Fedora - and probably will continue to do so unless and until you tell it to knock it off and use the nvidia driver.

Try:
Run: akmods --kernels `uname -r`
start the nvidia service daemon
Run: livna-config-display
Restart

V
Reply With Quote
  #7  
Old 23rd July 2008, 10:57 PM
wintersm Offline
Registered User
 
Join Date: Jul 2006
Posts: 293
I have done some investigating - actually having some time to do it, it appears that the 6100 and driver combination is not getting the edids properly from the monitor, i have tried this with a acer al1714 and a lg monitor with the same result.

I managed to get some display, but at only 1024x768 sofar by adding
Option "UseEdid" "False"
to the screen section of xorg.conf

i have not yet figured out a mode line that will work yet. (so back to using nouveau)
Reply With Quote
  #8  
Old 23rd July 2008, 11:44 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,292
Hello wintersm:

What version of nvidia driver are you using? I thought that NV Corp. fixed that regression in REV. 173.14.09. And you are on F9, correct?

Might be some other tricks to play yet... basically, blanket the config file with all known options and let it try to sort out the cruft.

V
Reply With Quote
  #9  
Old 23rd July 2008, 11:51 PM
wintersm Offline
Registered User
 
Join Date: Jul 2006
Posts: 293
yep fc9 and appears to be the same version

nvidia-settings-1.0-2.lvn9.x86_64
xorg-x11-drv-nvidia-173.14.09-1.lvn9.x86_64
xorg-x11-drv-nvidia-libs-173.14.09-1.lvn9.x86_64
kmod-nvidia-173.14.09-4.lvn9.x86_64
kmod-nvidia-2.6.25.10-86.fc9.x86_64-173.14.09-4.lvn9.x86_64
Reply With Quote
  #10  
Old 24th July 2008, 12:28 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,292
OK, it would help to guess the values if I had seen your xorg.conf and Xorg.0.log files first, but try these (no guarantee that these won't cause GUI failure, but I suggest that some risk is needed, and it is very small and easily fixed):

Give it absurdly huge hsync and vrefresh ranges to work within (these are straight out of my xorg.cong for GeForce 6150 LE on-board), and let it figure out the details:
Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Unknown"
        ModelName    "COMPAQ FS7600"
        HorizSync    30.0 - 70.0
        VertRefresh  50.0 - 160.0
        Option      "DPMS"
EndSection
While your at it, let it chew on this modeline, it should toss out ("illegal") values that it doesn't like:
Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Depth     24
                Modes    "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1152x768" "1024x768" "800x600" "640x480"
        EndSubSection
EndSection
That ought to get some reaction... and just in case that reaction is ugly, BACK UP your existing xorg.conf first so you can revert to it as quickly and easily as possible if necessary. If that does work, you can try more (higher) modes later. If that does not work, you can try to use nvidia-settings utility to read the EDID straight from the monitor, but that's more complex to implement.

Of course, you must also change the "Driver" line to read "nvidia", and re-start the X-server. Also assuming that the nvidia kernel module for the running kernel has been previously generated as noted above. EDIT: never mind, I see that you have a pre-fab kmod from Livna.

V
Reply With Quote
  #11  
Old 26th July 2008, 02:53 PM
Ray Ward Offline
Registered User
 
Join Date: Jul 2008
Posts: 31
I have the same problem as winston154.
How ever I can get round it by doing this.
1) Ctrl + Alt +1 login as root and change the xorg.conf driver to vesa.
2) Change back to the X console and do Ctrl+ Alt + bkspace giving me a login that I can see.
3) Go back to the command line and change the driver back to nvidia
4) Change back to the X console and Ctrl + Alt + bkspace this time the nvidia driver kicks in correctly.
Tedious I know I,v been doing this for some time.

It almost seems like X is not able to detect the monitor correctly at boot time.
I do have a Horiz and vertical Sync line in my config file but it made no diffeence.

Regards
Ray
Reply With Quote
  #12  
Old 26th July 2008, 03:21 PM
Ray Ward Offline
Registered User
 
Join Date: Jul 2008
Posts: 31
Adding Modes xorg.conf changed the problem.
I can now do Ctrl + Alt + "+ or -" which changes the resolution which puts the display right.
Reply With Quote
  #13  
Old 27th July 2008, 08:06 AM
wintersm Offline
Registered User
 
Join Date: Jul 2006
Posts: 293
I have had no luck with the nvidia driver, it will show 1024x768 and some other modes, but not the native 1280x1024 my monitor uses.. (I tried an hp monitor with the same resolution which doesnt work either). I have tried using the modeline that is logged in xorg.0.log when using the nouveau driver which puts a monitor and screen section of..
Code:
Section "Monitor"
	Identifier   "Monitor0"
	ModelName    "Acer AL1714"
	HorizSync    30.0 - 82.0
	VertRefresh  50.0 - 75.0
	Option	    "dpms"
        Modeline "1280x1024_60.00"  108.00  1280 1328 1440 1688  1024 1025 1028 1066  +HSync +Vsync
#	Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync

EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	Option	    "UseEdid" "False"
	SubSection "Display"

		Depth     24
    Modes    "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

i have also tried Modes "1280x1024_60" (or something like that)..

I am reluctant to go and buy a new video card (i prefer nvidia over ati) as it still might not work. (I dont really need the capabilities of a new card).
Reply With Quote
  #14  
Old 27th July 2008, 08:08 AM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,292
Perhaps if you attached a copy of your Xorg.0.log, we could see why the driver is not using that resolution....

V
Reply With Quote
  #15  
Old 27th July 2008, 12:41 PM
Ray Ward Offline
Registered User
 
Join Date: Jul 2008
Posts: 31
My monitor section is simpler.
Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

This works after a fashion using the + - key strokes to get the resolution. I am getting 1280 X 960 on a Proview PX 772N monitor.

I don't think you need a new video card my own adapter was working fine on fedora 8 it was only after an upgrade this became a problem.
Reply With Quote
Reply

Tags
blank, blue, driver, line, nvidia, problem, screen

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Blue-Line-On-Top Update Boricua Using Fedora 2 12th December 2008 03:19 AM
What file or script triggers the blue blank screen after bootup in fc5? sougata123 Using Fedora 0 27th December 2007 07:58 AM
Blank Blue Screen theuedimaster Installation, Upgrades and Live Media 3 18th May 2007 06:07 PM
Nvidia GEForce FX 5200 Black screen with X or Blue Screen and nothin frusconi Installation, Upgrades and Live Media 15 17th January 2007 01:05 AM
Fedora1:GUI off, switch to command line with blank screen?? like_gobeawan Using Fedora 2 22nd July 2005 10:44 AM


Current GMT-time: 02:21 (Thursday, 21-08-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat