Fedora Linux Support Community & Resources Center
  #1  
Old 13th July 2008, 03:44 AM
swartzism Offline
Registered User
 
Join Date: Oct 2007
Posts: 56
Wireless Problem

I cannot seem to get my wireless working.
Under the "General" tab the boxes that are checked are "Activate device when computer starts," "Automatically obtain IP address settings with: dhcp," and "Automatically obtain DNS information from provider".
The hardware device is called b43, it is the wireless, it's name is wlan0, and the status is "system". I have that enabled under the "Hardware device" tab and it is binded to a MAC address.
Under the "Wireless Settings" tab the mode is "Auto" and the Network name (SSID) is specified to my wireless network.
When I try to activate it, I get this error message:

Quote:
Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0...SIOCSIFFLAGS: No such file or directory
SIOCSIFFLAGS: No such file or directory
Any help?
Reply With Quote
  #2  
Old 13th July 2008, 03:47 AM
Wayne
Guest
 
Posts: n/a
I don't know anything about wireless but i know I've seen this kind of post before. Try putting

SIOCSIFFLAGS

into the forum search box...

Wayne
Reply With Quote
  #3  
Old 13th July 2008, 04:48 AM
dodbdts Offline
Registered User
 
Join Date: Mar 2008
Posts: 42
Are you using NDISWrapper or just the generic wireless driver in fedora?

I know when initially trying to setup my wireless card on my laptop to work with NDISWrapper I was constently getting this message. If you are using NDISWrapper make sure and blacklist the b43 and affiliated drivers..those will definitely cause you problems. I'm not sure exactly which ones they are...but if you search "blacklist b43" along those lines you'll more then likely find the solution. If you're not trying to use NDISWrapper and had already had your card successfully working....then your guess is as good as mine.
Reply With Quote
  #4  
Old 13th July 2008, 10:17 AM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,359
Hello swartzism

I'm going to assume that you are running Fedora 9 here though you don't say, although the following applies with some modifications to Fedora 8.

The way you are trying to use to control your wireless card is not the recommended method. The default for F9 and at least some of F8 is to use NetworkManager which lives on the top Gnome Panel just to the left of the clock.

That is usually running and if it is then it will actively interfere with any other way of controlling the card.

As you are using the b43 driver to try and control your card, have you ascertained that yours is one of those that b43 is capable of controlling. It doesn't work with all broadcoms.

For that question, if you'd like to run:

Code:
/sbin/lspci
in a terminal window and post back the parts relating to "network" and "ethernet" we can work that out.

You also haven't indicated if you have "cut the firmware" for your card with the b43-fwcutter program - assuming the card is supported. Fedora doesn't include the firmware with the distribution.

Post back and we'll talk about it some more.
Reply With Quote
  #5  
Old 13th July 2008, 11:04 AM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
Quote:
Originally Posted by swartzism
I cannot seem to get my wireless working.
Under the "General" tab the boxes that are checked are "Activate device when computer starts," "Automatically obtain IP address settings with: dhcp," and "Automatically obtain DNS information from provider".
The hardware device is called b43, it is the wireless, it's name is wlan0, and the status is "system". I have that enabled under the "Hardware device" tab and it is binded to a MAC address.
Under the "Wireless Settings" tab the mode is "Auto" and the Network name (SSID) is specified to my wireless network.
When I try to activate it, I get this error message:



Any help?

This is a non fatal error. A little more info on your network configuration is needed. You have the device set to "activate on boot", this is not needed when using NetworkManager. You don't mention whether any form of wireless encryption is being used. When using NM uncheck the box for "activate on boot" as NM will start/stop the device as needed. Open a terminal window and change to root with su -, the hyphen is needed and type

system-config-network

Highlight your device and click the edit tab. Put check marks in the "controlled by NM", "allow users to enable/disable device" and depending on the config of your network whether DHCP or DNS info is needed..
Reply With Quote
  #6  
Old 13th July 2008, 02:20 PM
swartzism Offline
Registered User
 
Join Date: Oct 2007
Posts: 56
Unhappy

Code:
[root@new-host MJSwartz]# /sbin/lspci
00:00.0 Host bridge: ATI Technologies Inc RS480 Host Bridge (rev 01)
00:01.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:05.0 PCI bridge: ATI Technologies Inc RS480 PCI Bridge
00:13.0 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.1 USB Controller: ATI Technologies Inc IXP SB400 USB Host Controller
00:13.2 USB Controller: ATI Technologies Inc IXP SB400 USB2 Host Controller
00:14.0 SMBus: ATI Technologies Inc IXP SB400 SMBus Controller (rev 11)
00:14.1 IDE interface: ATI Technologies Inc IXP SB400 IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc IXP SB400 PCI-ISA Bridge
00:14.4 PCI bridge: ATI Technologies Inc IXP SB400 PCI-PCI Bridge
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP SB400 AC'97 Audio Controller (rev 02)
00:14.6 Modem: ATI Technologies Inc SB400 AC'97 Modem Controller (rev 02)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon XPRESS 200M 5955 (PCIE)
06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
06:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Someone mentioned that there is supposed to be a network manager icon next to the clock, but the only two icons for me are the battery and tomboy notes. I am using F9 and I have not done most of the intricate things with the b43 device you guys are talking about, I am fairly new to all of this.
Reply With Quote
  #7  
Old 13th July 2008, 02:22 PM
swartzism Offline
Registered User
 
Join Date: Oct 2007
Posts: 56
This also came up when I tried "system-config-network":

Code:
[root@new-host MJSwartz]# system-config-network
No protocol specified
ERROR: Unable to initialize graphical environment. Most likely cause of failure is that the tool was not run using a graphical environment. Please either start your graphical user interface or set your DISPLAY variable.
Reply With Quote
  #8  
Old 13th July 2008, 02:43 PM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,359
Hello swartzism

I'm surprised that NetworkManager is not showing on your Gnome Panel.

Can I assume that you have a wired connection to this machine we are talking about?

If you have then you do need to do something called cutting the firmware for the card and you need to obtain that firmware off the internet.

The instructions look a bit daunting but are fairly straightforward one step at a time.

If you follow then through and NetworkManager doesn't turn up on that top panel, don't try controlling the card by any other means, post back and we'll lok into that as a separate item.

Quote:
With that card then you should only need to download the firmware, cut it and configure the card with NetworkManager.

Download this file and put it into a directory somewhere:

http://mirror2.openwrt.org/sources/b...0.10.5.tar.bz2

Acquire full root rights over your machine with this command in a terminal window:

Code:
su -
That's a space and a minus sign after the su. It gives you full root rights over your machine rather than just root rights over your ordinary users environment without it.

Use the cd command to navigate into the directory where you downloaded the above file. Issue the command:

Code:
tar xjf broadcom-wl-4.150.10.5.tar.bz2
That unpacks the file archive you downloaded and will create you a new directory where you are working called 'broadcom-wl-4.150.10.5'.

cd into that and then the 'driver' directory within that and use the command:

Code:
b43-fwcutter -w /lib/firmware wl_apsta_mimo.o
That cuts the required firmware for your card from the downloaded file and places it in the correct place for the b43 driver to find it.

Check and see if you have NetworkManager showing on the top Gnome Panel to the right in the notification area. If you have ignore the next part.

Go to the "Gnome System Menu - Administration - Services", tick NetworkManager and NetworkMangerDispatcher, make sure they are started and the settings are saved so they start at next boot.

{The above paragraph is only necessary for Fedora 8 definitely not for Fedora 9}

Restart the machine and left clicking on the NetworkManager icon should bring up a list of wireless access points to connect to.
Incidentally, I have a broadcom 4318 in my laptop and that is working by this method so we should be fairly sure of success.

If you have any questions or problems post back
Reply With Quote
  #9  
Old 13th July 2008, 02:50 PM
soggyoreo Offline
Registered User
 
Join Date: Sep 2007
Posts: 19
Crap, I just had this problem that a friend of mine helped me figure out. I was having the same issue. I forgot what we did.

Can you do this to see what you come back with?

Code:
env | grep DISPLAY
Reply With Quote
  #10  
Old 13th July 2008, 03:43 PM
swartzism Offline
Registered User
 
Join Date: Oct 2007
Posts: 56
bbfuller - I am on F9. I followed all of your instructions and I still do not have the network manager in on the bar.

soggyoreo - this is what it came up with:

Code:
[root@new-host ~]# env | grep DISPLAY
DISPLAY=:0.0
Reply With Quote
  #11  
Old 13th July 2008, 03:46 PM
swartzism Offline
Registered User
 
Join Date: Oct 2007
Posts: 56
I think the problem might be my inability to update via yum. Take a look at my other post and see what you think:
http://forums.fedoraforum.org/showth...00#post1046100
Every time I start this laptop up an update box comes up and one of the updates at the bottom is "system-config-network" so that might have to do with this. Any help there would be awesome.
Reply With Quote
  #12  
Old 13th July 2008, 04:20 PM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,359
Hello swartzism

Let's take this one step at a time.

I'm assuming that after you have booted your machine you get to a login screen that allows you to select the user to login as. After doing that and giving the password you should be take to a graphical user environment like the one in tha attachment.

If you were in text only it would be just a black screen with white writing.

Which do you see?

Last edited by bbfuller; 26th June 2009 at 10:50 PM.
Reply With Quote
  #13  
Old 13th July 2008, 05:34 PM
gizmo4321 Offline
Registered User
 
Join Date: Aug 2007
Posts: 29
bbfuller, I've got an Asus WL-103b which uses the Broadcom BCM4303 chipset. lspci shows b43legacy running, and when I run system-config-network, it shows up in the hardware tab. However, I've got the same problem as swartzism; when I config the network adapter, I get the SIOCSIFFLAGS error. I am running Fedora 9.

Can you give me some pointers here? I've seen several different suggestions on things to do, some of which look like they might conflict, so I'm more than a bit confused. Is there a HOW-TO that can take me through all of this?

Output from lspci

lspci | grep Ethernet
01:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VM (MOB) Ethernet Controller (rev 83)

lspci | grep Network
02:00.0 Network controller: Broadcom Corporation BCM4303 802.11b Wireless LAN controller (rev 02)

I've got the Network Manager icon in my system bar, and my wired ethernet is running. I've removed the wireless configuration that I had in system-config-network and added it to Network Manager, but it won't let me activate the wireless network.
Reply With Quote
  #14  
Old 13th July 2008, 05:56 PM
bbfuller Offline
Registered User
 
Join Date: Jun 2005
Location: UK
Posts: 4,359
Hello gizmo4321

Like anyone else using the b43 or b43-legacy driver you will need to cut some firmware for your card.

As your card is using the legacy driver it's different firmware to all of the other people I've advised, however the b43 site does say that your card is supported.

Post back if you haven't cut the firmware and I'll adjust my notes to suit your card.
Reply With Quote
  #15  
Old 13th July 2008, 06:09 PM
gizmo4321 Offline
Registered User
 
Join Date: Aug 2007
Posts: 29
I have not yet cut the firmware.
Reply With Quote
Reply

Tags
problem, wireless

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless problem darkskye Servers & Networking 8 30th January 2008 05:29 AM
Another wireless problem gw342 Servers & Networking 0 9th August 2006 05:02 AM
Encryption Problem with Intel Corporation PRO/Wireless 2200BG wireless card lakefront Hardware & Laptops 1 11th April 2006 03:04 AM


Current GMT-time: 02:25 (Friday, 25-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat