Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora Resources > Guides & Solutions (Not For Questions)
FedoraForum Search

Forgot Password? Join Us!

Guides & Solutions (Not For Questions) Post your guides here (No links to Blogs accepted). You can also append your comments/questions to a guide, but don't start a new thread to ask a question. Use another forum for that.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 20th September 2008, 05:17 PM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
Latest update break your USB mouse (or keyboard)? Get them back.

Hey there! If you're reading this, then I bet you, like me, use an external USB mouse. (In my case it's the Microsoft wireless USB mouse with receiver, but, ah, details.) At any rate, after the latest Fedora system update (Xorg went up from 1.4.99 to 1.5.0.1), you may notice that your USB mice no longer tend to work.

What happened? Well, it turns out, they keep tweaking the default settings for auto-detection in xorg.conf. (I have a previous thread on here about fixing touchpad autodetection with the synaptics driver -- same league of stuff, but this time it's USB mice that are having the problem.)

In the modern Xorg world, HAL should autodetect your mice for you. Any Xorg.conf specification should be overkill. That's why the default Fedora xorg.conf mentions as little as possible, and theoretically should work even without an xorg.conf file. But guess what? In Xorg 1.5.0.1, somehow, a default Xorg setting was changed -- it disabled automatic detection of what Xorg calls the "CorePointer" device.

(I'm summarizing, this could be a horribly juvenile understanding of it. But bear with me a bit longer.)

You have two options.


1. We can fix this in /etc/X11/xorg.conf (log in as root, and use a text editor) with one line (or three). Add the following lines to your xorg.conf file (you may need to create a new Section, as follows):
Code:
Section "ServerFlags"
Option "AllowEmptyInput" "off"
EndSection
This option right here means that Xorg and HAL will automatically find your mouse for you if you didn't specify one in Xorg.conf -- in other words, Xorg won't allow you to have no input device -- empty input is not allowed. That's a great option. Why isn't it turned on by default?

Good question! It _was_, in Xorg 1.4.99. That's why rolling back your system to 1.4.99 fixes that problem.


2. The second option: install Xorg 1.5.0.2 from updates-testing, or from here: https://admin.fedoraproject.org/upda...er-1.5.0-2.fc9

Version 1.5.0.2 adds the correct AllowEmptyInput setting (off) by default -- restoring the previous behavior.



For those of you who don't want to install experimental updates, option #1 should fix everything up and make sure this problem doesn't happen again -- and it's simple, too.

Here are some links for more information:
Xorg fails to detect keyboard input in 1.5.0.1
This guy on the Fedora Mailing List figured it out.

As always, I might not completely understand how HAL and Xorg work together -- but I believe my explanation here is mostly correct, and my USB wireless mouse is now working again. Try option #1 or #2 and see what happens.

Last edited by twilightomni; 23rd September 2008 at 01:36 AM.
Reply With Quote
  #2  
Old 20th September 2008, 05:23 PM
Evil_Bert Offline
Retired Again - Administrator
 
Join Date: Nov 2007
Location: .
Posts: 3,404
Actually, I don't have that problem, but that's a good write-up. Just thought I'd say so.
__________________
Marching to the beat of his own conundrum.
Reply With Quote
  #3  
Old 20th September 2008, 06:02 PM
Hlingler Offline
Administrator
 
Join Date: Sep 2006
Location: Connellsville, PA, USA
Posts: 11,305
Nice info for those who need to know.

Moved to "Guides and How-Tos". If you (twilightomni) disagree with that move, send me a PM and I'll move it back.

V
Reply With Quote
  #4  
Old 20th September 2008, 09:21 PM
cwebster Offline
Registered User
 
Join Date: May 2005
Location: NC
Age: 62
Posts: 104
Thank you twilightomni. That was exactly what was needed. I too was disappointed to find that my mouse stopped working after updating. I'd just finished using "preupgrade" from F7 to F9 and was ironing out some other issues. I thought everything was running pretty smooth until the mouse stopped. Thanks for spotting it and providing a simple fix.

Cal
__________________
./Cal
Reply With Quote
  #5  
Old 20th September 2008, 09:32 PM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
Well now, the people in the mailing lists and bugzilla's came up with the solution. I just paraphrased.
Reply With Quote
  #6  
Old 21st September 2008, 04:17 AM
Victoriab Offline
Registered User
 
Join Date: Sep 2008
Posts: 1
Thank you!

I have been searching for the last few hours to find a solution!

I tried to downloaded xorg-x11-server-1.5.0-2.fc9... and xorg-x11-server-common-1.5.0-2.fc9..., and rpm - U them... BUT that failed to change my xorg.conf... and I couldn't get yum to like my 'install name' SO glad you have a solution posted. (lol, thank goodness for lynx and wget. )
Reply With Quote
  #7  
Old 21st September 2008, 12:46 PM
psorhb1973 Offline
Registered User
 
Join Date: Jan 2008
Location: Washington
Posts: 17
I tried this method of editing the xorg.conf file. As i did so, the X11 wouldn't start up. I ended up having to edit the conf file with vi to remove those lines. It definitely doesn't like the new coding there. Or I'm not putting this in the right place in the /etc/X11/xorg.conf file. Thanks for the help though, kinda sucks, but I'll manage.
__________________
A human is window dressing of death.
Reply With Quote
  #8  
Old 21st September 2008, 01:34 PM
Danvitt Offline
Registered User
 
Join Date: Sep 2008
Posts: 1
Thank you very much, Now that I have taken a crash course in getting around without a mouse I am ready to move on. Worked like a charm. for those noobs like myself i simply added Option "AllowEmptyInput" "off" right underneath ServerFlags since that part was already there and of course EndSection was already there too. make sure to pay attention to caps , maybe I'm wrong but I have a hunch it just may keep it from working.
Reply With Quote
  #9  
Old 22nd September 2008, 01:37 AM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
psorhb1973, what kind of xorg.conf do you have? Are there a ton of entries in it, or is relatively empty? Maybe it already has a ServerFlags section.
Reply With Quote
  #10  
Old 22nd September 2008, 04:58 PM
leedm777 Offline
Registered User
 
Join Date: Sep 2008
Posts: 1
Talking Thank you!

Quote:
Originally Posted by twilightomni
Well now, the people in the mailing lists and bugzilla's came up with the solution. I just paraphrased.
I'm glad you did. You certainly made my day better. Thanks!!!
Reply With Quote
  #11  
Old 22nd September 2008, 07:02 PM
neophytal Offline
Registered User
 
Join Date: May 2008
Posts: 3
thanks, VMware shut my pc off due to a problem and the mouse broke..... now I know why, updates from a bit ago *sigH*
Reply With Quote
  #12  
Old 22nd September 2008, 08:51 PM
PascalGR Offline
Registered User
 
Join Date: Apr 2006
Location: Athens, Greece
Age: 38
Posts: 8
Thanks man! That was exactly what I was looking for!

I was stucked to this problem and didn't use my laptop at all for few days. Only some basic things from console...

Thanks again and again!!
__________________
gawk, date, finger, wait, unzip, touch, nice, suck, strip, mount, fsck, umount, make clean, sleep: Who needs sex when you have /usr/bin?
Reply With Quote
  #13  
Old 23rd September 2008, 01:30 AM
psorhb1973 Offline
Registered User
 
Join Date: Jan 2008
Location: Washington
Posts: 17
Quote:
Originally Posted by twilightomni
psorhb1973, what kind of xorg.conf do you have? Are there a ton of entries in it, or is relatively empty? Maybe it already has a ServerFlags section.

Usually in this case the obvious choice to edit this problem is in /etc/X11/xorg.conf file. ServerFlag aside, I'm not sure where this line should go, because I edited it at the end of the file, verbatium. Otherwise, I'm using a wired mouse for the time being. Anything with wireless mice in general doesn't work. After the updated, I was getting a message at startup saying USB error on port 4.

I'm at a loss at to what to do next.
__________________
A human is window dressing of death.
Reply With Quote
  #14  
Old 23rd September 2008, 01:48 AM
twilightomni Offline
Registered User
 
Join Date: Apr 2008
Posts: 70
No, I mean, not _where_ is it, but describe it. I suppose maybe just copying it would have been easier. :-\

Do you have a line called Section "ServerFlags" ? If so, you should add the AllowEmptyInput line from the first post right after that. If you don't have a ServerFlags line, then you should add all three to the end of the file, in that order.


Heroic measures: if you really want to make sure it's a problem with USB, and _not_ with your Xorg...then do this.

1. Rename xorg.conf to xorg.conf.bak.
2. Make a new xorg.conf, and add only the three lines above.

Yes, this removes all your previous Xorg.conf settings, but the good news is, it's really getting good at autodetecting that stuff. It shouldn't break your system at all, though your mileage may vary. You may suffer the following problems...

--Wrong screen resolution
--Multimedia keys on keyboard don't work
--Mouse wheel might not work correctly

But if that gets your wireless mouse to work again, then it was just the Xorg problem. If that doesn't work, you may have a deeper problem with USB devices. And in that case I'm afraid I don't know how to help you.

You know how to login with text mode (in case X actually does break), right? After Fedora boots, but your mouse & keys don't work, you can press Ctrl+Alt+F1 to go to a text prompt. From there, you can login as root and go put back the old Xorg.conf.
Reply With Quote
  #15  
Old 23rd September 2008, 04:35 AM
psorhb1973 Offline
Registered User
 
Join Date: Jan 2008
Location: Washington
Posts: 17
# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


I put the new stuff at the end of the bottom subsection, saved it, rebooted, all I got was text, commanline login prompt. I'm running on i386 version. I've looked at all the xorg setups so its basically there, I'm not sure where those lines should go though, considering they won't work at the end of the script/code.
__________________
A human is window dressing of death.
Reply With Quote
Reply

Tags
break, latest, mice, update, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
latest updates break software jsnark Using Fedora 7 23rd September 2009 02:50 PM
Heads up: Fedora 8 latest security update kernel break nvidia due to missing kmod qo_ Hardware & Laptops 11 16th May 2008 11:16 PM
Latest rawhide update seems to break wpa_supplicant scottro Servers & Networking 2 23rd February 2008 01:34 PM
Kernel update break ATI driver leonard Hardware & Laptops 1 8th December 2007 11:09 AM
Will yum update break the nvidia kernel module? erinspice Hardware & Laptops 4 23rd February 2007 06:32 PM


Current GMT-time: 00:02 (Saturday, 24-06-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat