Fedora Linux Support Community & Resources Center
  #1  
Old 9th July 2009, 09:01 PM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 177
akmod can not build kmod-nvidia-96xx

I have not had this problem on this machine since the days of fedora 1. The problem is that there is not kmod-nvidia driver for the current kernel in the rpmfusion repo, nor akmod can build one at boot up. Looking at the log files, akmods spits this error message:
Quote:
09 Jul 14:54:26 akmodsbuild: + make -j2 SYSSRC=/usr/src/kernels/2.6.29.5-191.fc11.i586 module
09 Jul 14:54:26 akmodsbuild:
09 Jul 14:54:26 akmodsbuild: The C compiler 'cc' does not appear to be able to
09 Jul 14:54:26 akmodsbuild: create executables. Please make sure you have
09 Jul 14:54:26 akmodsbuild: your Linux distribution's gcc and libc development
09 Jul 14:54:26 akmodsbuild: packages installed.
09 Jul 14:54:26 akmodsbuild:
09 Jul 14:54:26 akmodsbuild: *** Failed CC sanity check. Bailing out! ***
09 Jul 14:54:26 akmodsbuild:
09 Jul 14:54:26 akmodsbuild: make: *** [select_makefile] Error 1
09 Jul 14:54:26 akmodsbuild: error: Bad exit status from /var/tmp/rpm-tmp.Gj1NTz (%build)
Here is what is installed in my system:
Quote:
$ uname -r
2.6.29.5-191.fc11.i586

$ rpm -qa "akmod*" "kmod*"
kmodtool-1-18.fc11.noarch
akmod-nvidia-96xx-96.43.11-2.fc11.10.i586
kmod-nvidia-96xx-96.43.11-2.fc11.10.i586
akmods-0.3.6-2.fc11.noarch

$ rpm -qa "kernel*"
kernel-devel-2.6.29.5-191.fc11.i586
kernel-firmware-2.6.29.5-191.fc11.noarch
kernel-2.6.29.5-191.fc11.i586
kernel-headers-2.6.29.5-191.fc11.i586
I am truly clueless how to get this fixed. any help is appreciated.
Reply With Quote
  #2  
Old 9th July 2009, 09:10 PM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 46
Posts: 3,921
i take it that Gcc is installed .
yum groupinstall "Development Tools" "Development Libraries" "System Tools"
__________________
OpenSUSE 12.3-64bit & Scientific Linux 6.4-64bit ( fedora 4 to 11) and 19 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #3  
Old 9th July 2009, 09:17 PM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 177
Actually GCC is installed and I did build other packages. when I did the yum group install command you provided only these packages yum wanted to install:
Quote:
================================================== ================================================== ================================================== ============================
Package Arch Version Repository Size
================================================== ================================================== ================================================== ============================
Installing:
BackupPC noarch 3.1.0-5.fc11 fedora 602 k
NetworkManager-openconnect i586 0.7.0.99-5.fc11 updates 47 k
NetworkManager-openvpn i586 1:0.7.0.99-1.fc11 fedora 138 k
NetworkManager-vpnc i586 1:0.7.0.99-1.fc11 fedora 115 k
bonnie++ i586 1.03c-2.fc11 fedora 45 k
dbus-cxx-devel i586 0.4.0-1.fc11 updates 51 k
dbus-cxx-doc i586 0.4.0-1.fc11 updates 25 M
dbus-cxx-tools i586 0.4.0-1.fc11 updates 62 k
ipsec-tools i586 0.7.2-1.fc11 updates 416 k
jigdo i586 0.7.3-8.fc11 fedora 428 k
lha i586 1.14i-23.fc11 rpmfusion-nonfree 47 k
openconnect i586 2.01-1.fc11 updates 77 k
openldap-clients i586 2.4.15-3.fc11 fedora 298 k
openvpn i586 2.1-0.32.rc15.fc11 fedora 368 k
screen i586 4.0.3-13.fc11 fedora 575 k
systemtap i586 0.9.8-1.fc11 updates 1.5 M
tigervnc i586 0.0.91-0.11.fc11 updates 284 k
unrar i586 3.7.8-4.fc11 rpmfusion-nonfree 111 k
vpnc i586 0.5.3-3.fc11 fedora 88 k
xdelta i586 1.1.4-5.fc11 fedora 113 k
zisofs-tools i586 1.0.8-4.fc11 fedora 25 k
zsh i586 4.3.9-4.fc11 fedora 2.2 M
Installing for dependencies:
apr-util-ldap i586 1.3.7-1.fc11 updates 15 k
dbus-cxx i586 0.4.0-1.fc11 updates 166 k
devhelp i586 0.23-6.fc11 fedora 230 k
httpd i586 2.2.11-8 fedora 1.1 M
httpd-tools i586 2.2.11-8 fedora 71 k
libsigc++20-devel i586 2.2.2-3.fc11 fedora 4.4 M
perl-Archive-Zip noarch 1.23-2.fc11 fedora 115 k
perl-Class-Singleton noarch 1.4-4.fc11 fedora 17 k
perl-DateTime i586 1:0.4501-2.fc11 fedora 2.3 M
perl-DateTime-Format-Mail noarch 0.3001-4.fc11 fedora 174 k
perl-DateTime-Format-W3CDTF noarch 0.04-6.fc11 fedora 18 k
perl-File-RsyncP i586 0.68-5.fc11 fedora 119 k
perl-List-MoreUtils i586 0.22-8.fc11 fedora 67 k
perl-Params-Validate i586 0.91-2.fc11 fedora 85 k
perl-Time-modules noarch 2006.0814-4.fc11 fedora 40 k
perl-XML-RSS noarch 1.44-1.fc11 updates 62 k
perl-suidperl i586 4:5.10.0-69.fc11 updates 49 k
Reply With Quote
  #4  
Old 9th July 2009, 11:17 PM
JohnVV Offline
Registered User
 
Join Date: Aug 2005
Location: Ann Arbor
Age: 46
Posts: 3,921
then it might be a bug with the current kernel .That is stopping the akmod from building a kmod.rpm

i use NVIDIA-Linux-x86-96.43.13-pkg1.run so i am not sure if it is a bug or not .
__________________
OpenSUSE 12.3-64bit & Scientific Linux 6.4-64bit ( fedora 4 to 11) and 19 on KVM
My Celestia Downloads

h t t p ://celestiamotherlode.net/catalog/show_creator_details.php?creator_id=10
Reply With Quote
  #5  
Old 20th July 2009, 10:20 PM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 177
Sorry for the bump up guys. I just wanted to expose this to more readers if any. I tried to file a bug in the rpmfusion site but for some reason I am not able to. It must have been not a problem in my part, because by looking at the available drivers from rpmfusion repo, the kmod-nvidia-96xx-`kernel version` is not available.
Quote:
$ yum list "kmod-nvidia*"
Loaded plugins: refresh-packagekit
adobe-linux-i386 | 951 B 00:00
rpmfusion-free-updates | 3.8 kB 00:00
rpmfusion-nonfree-updates | 3.8 kB 00:00
updates/metalink | 6.2 kB 00:00
updates | 4.4 kB 00:00
Available Packages
kmod-nvidia.i586 185.18.14-1.fc11.1 rpmfusion-nonfree-updates
kmod-nvidia-173xx.i586 173.14.18-2.fc11.10 rpmfusion-nonfree-updates
kmod-nvidia-173xx-2.6.29.4-167.fc11.i586.i586 173.14.18-2.fc11.9 rpmfusion-nonfree-updates
kmod-nvidia-173xx-2.6.29.4-167.fc11.i686.PAE.i686 173.14.18-2.fc11.9 rpmfusion-nonfree-updates
kmod-nvidia-173xx-2.6.29.5-191.fc11.i586.i586 173.14.18-2.fc11.10 rpmfusion-nonfree-updates
kmod-nvidia-173xx-2.6.29.5-191.fc11.i686.PAE.i686 173.14.18-2.fc11.10 rpmfusion-nonfree-updates
kmod-nvidia-173xx-PAE.i686 173.14.18-2.fc11.10 rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.4-167.fc11.i586.i586 185.18.14-1.fc11 rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.4-167.fc11.i686.PAE.i686 185.18.14-1.fc11 rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.5-191.fc11.i586.i586 185.18.14-1.fc11.1 rpmfusion-nonfree-updates
kmod-nvidia-2.6.29.5-191.fc11.i686.PAE.i686 185.18.14-1.fc11.1 rpmfusion-nonfree-updates
kmod-nvidia-96xx.i586 96.43.11-2.fc11.10 rpmfusion-nonfree-updates
kmod-nvidia-96xx.i686 96.43.11-2.fc11.10 rpmfusion-nonfree-updates
kmod-nvidia-PAE.i686 185.18.14-1.fc11.1 rpmfusion-nonfree-updates
Reply With Quote
  #6  
Old 26th July 2009, 09:26 AM
saqer Offline
Registered User
 
Join Date: Oct 2006
Posts: 177
[SOLVED}
Today I have came across the same error trying to build another package. When I looked up online for the error it was a missing package "glibc-headers". I am very sure I have had this installed before because I did build previous versions of the packages that did not change the source or any config file. So, I might have uninstalled it at one time without noticing.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
kmod-nvidia vs akmod-nvidia dth4h Using Fedora 35 4th September 2009 03:02 AM
are akmod-nvidia and kmod-nvidia exclusive? marko Using Fedora 2 23rd February 2009 02:26 AM
Can't build nvidia akmod drivers pavelthesecond Using Fedora 9 2nd October 2008 10:23 PM
kmod-nvidia-96xx Fedora 8 warning bob Using Fedora 9 29th September 2008 12:04 AM
kmod-nvidia-96xx for fedora 9? kmarien Hardware & Laptops 3 9th June 2008 12:11 AM


Current GMT-time: 12:19 (Saturday, 19-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat