Fedora Linux Support Community & Resources Center

Go Back   FedoraForum.org > Fedora 19/20 > Using Fedora
FedoraForum Search

Forgot Password? Join Us!

Using Fedora General support for current versions. Ask questions about Fedora and it's software that do not belong in any other forum.

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 9th September 2009, 03:40 PM
gthaker Offline
Registered User
 
Join Date: Sep 2009
Posts: 2
linuxfedorafirefox
symbol lookup error: /lib/libgio-2.0.so.0: undefined symbol: g_thread_gettime

I am running a fully updated Fedora 11 Linux.

> uname -a
Linux zadapi-L 2.6.30.5-43.fc11.i686.PAE #1 SMP Thu Aug 27 21:34:36 EDT 2009 i686 athlon i386 GNU/Linux


All of a sudden I have started to get the msg:

> /usr/bin/emacs
/usr/bin/emacs: symbol lookup error: /lib/libgio-2.0.so.0: undefined symbol: g_thread_gettime

since it appears that this library/symbol is needed by many programs I can't use the system for my normal work. (Firefox, thunderbird, etc. continue to run fine.)

Any hints welcome. Thanks.

Gautam
Reply With Quote
  #2  
Old 9th September 2009, 04:10 PM
stevea Offline
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,553
linuxfedorafirefox
The symbol does appear in the package ... glib2-2.20.4-1.fc11.i586 which is the current glib2 package an supplies /lib/libgio-2.0.so.0.
__________________
None are more hopelessly enslaved than those who falsely believe they are free.
Johann Wolfgang von Goethe
Reply With Quote
  #3  
Old 9th September 2009, 05:05 PM
gthaker Offline
Registered User
 
Join Date: Sep 2009
Posts: 2
linuxfedorafirefox
Thanks. That hint was most helpful, I had another glib in my LD_LIBRARY_PATH that was causing this issue.
Reply With Quote
Reply

Tags
error, gthreadgettime, lookup, or lib or libgio20so0, symbol, undefined

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get:symbol lookup error rgazali Using Fedora 11 22nd March 2009 09:34 AM
NetworkManager symbol lookup error mholden Servers & Networking 2 7th February 2008 12:35 PM
dvdbackup - symbol lookup error tardis_junkie Using Fedora 2 6th January 2006 02:50 AM
gmplayer: symbol lookup error nudicles Using Fedora 4 28th March 2005 03:11 AM


Current GMT-time: 04:21 (Saturday, 19-04-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat