Fedora Linux Support Community & Resources Center
  #1  
Old 7th June 2012, 02:04 AM
greno Offline
Registered User
 
Join Date: Oct 2005
Location: U.S.A.
Posts: 266
linuxchrome
F17: xend will not start

Is there some special voodoo to get xend to run in F17?

Code:
# yum list installed 'xen*'
Installed Packages
xen.x86_64                                                      4.1.2-17.fc17                                           @updates
xen-hypervisor.x86_64                                           4.1.2-17.fc17                                           @updates
xen-libs.x86_64                                                 4.1.2-17.fc17                                           @updates
xen-licenses.x86_64                                             4.1.2-17.fc17                                           @updates
xen-runtime.x86_64                                              4.1.2-17.fc17                                           @updates

Been here:

Code:
# systemctl disable xend.service
rm '/etc/systemd/system/multi-user.target.wants/xend.service'
# systemctl stop xend.service
# systemctl enable xend.service
ln -s '/usr/lib/systemd/system/xend.service' '/etc/systemd/system/multi-user.target.wants/xend.service'
# systemctl start xend.service
Job failed. See system journal and 'systemctl status' for details.

# systemctl status xend.service
xend.service - Xend - interface between hypervisor and some applications
	  Loaded: loaded (/usr/lib/systemd/system/xend.service; enabled)
	  Active: failed (Result: exit-code) since Wed, 06 Jun 2012 21:46:43 -0400; 4min 12s ago
	 Process: 2134 ExecStart=/usr/sbin/xend (code=exited, status=1/FAILURE)
	 Process: 2131 ExecStartPre=/bin/grep -q control_d /proc/xen/capabilities (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/xend.service

Jun 06 21:46:43 renog13-lin01.localdomain xend[2134]: Traceback (most recent call last):
Jun 06 21:46:43 renog13-lin01.localdomain xend[2134]: File "/usr/lib64/python2.7/site.py", line 567, in <module>
Jun 06 21:46:43 renog13-lin01.localdomain xend[2134]: main()
Jun 06 21:46:43 renog13-lin01.localdomain xend[2134]: File "/usr/lib64/python2.7/site.py", line 549, in main
Jun 06 21:46:43 renog13-lin01.localdomain xend[2134]: known_paths = addusersitepackages(known_paths)

Code:
Jun  6 21:46:43 renog13-lin01 xend[2134]: Traceback (most recent call last):
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/site.py", line 567, in <module>
Jun  6 21:46:43 renog13-lin01 xend[2134]: main()
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/site.py", line 549, in main
Jun  6 21:46:43 renog13-lin01 xend[2134]: known_paths = addusersitepackages(known_paths)
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/site.py", line 278, in addusersitepackages
Jun  6 21:46:43 renog13-lin01 xend[2134]: user_site = getusersitepackages()
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/site.py", line 253, in getusersitepackages
Jun  6 21:46:43 renog13-lin01 xend[2134]: user_base = getuserbase() # this will also set USER_BASE
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/site.py", line 243, in getuserbase
Jun  6 21:46:43 renog13-lin01 xend[2134]: USER_BASE = get_config_var('userbase')
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/sysconfig.py", line 521, in get_config_var
Jun  6 21:46:43 renog13-lin01 xend[2134]: return get_config_vars().get(name)
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/sysconfig.py", line 425, in get_config_vars
Jun  6 21:46:43 renog13-lin01 xend[2134]: _CONFIG_VARS['userbase'] = _getuserbase()
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/sysconfig.py", line 183, in _getuserbase
Jun  6 21:46:43 renog13-lin01 xend[2134]: return env_base if env_base else joinuser("~", ".local")
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/sysconfig.py", line 169, in joinuser
Jun  6 21:46:43 renog13-lin01 xend[2134]: return os.path.expanduser(os.path.join(*args))
Jun  6 21:46:43 renog13-lin01 xend[2134]: File "/usr/lib64/python2.7/posixpath.py", line 260, in expanduser
Jun  6 21:46:43 renog13-lin01 xend[2134]: userhome = pwd.getpwuid(os.getuid()).pw_dir
Jun  6 21:46:43 renog13-lin01 xend[2134]: KeyError: 'getpwuid(): uid not found: 0'
Jun  6 21:46:43 renog13-lin01 systemd[1]: xend.service: control process exited, code=exited status=1
Jun  6 21:46:43 renog13-lin01 systemd[1]: Unit xend.service entered failed state.
Jun  6 21:46:44 renog13-lin01 setroubleshoot: SELinux is preventing /usr/bin/python2.7 from read access on the file /etc/passwd. For complete SELinux messages. run sealert -l 9f799338-2204-44b6-a58a-0ec7ef0982c9.

Code:
# ps -ef | grep xen
root        40     2  0 21:44 ?        00:00:00 [xenwatch]
root        41     2  0 21:44 ?        00:00:00 [xenbus]
root       826     1  0 21:45 ?        00:00:00 /usr/sbin/xenstored --pid-file /var/run/xenstored.pid
root       998     1  0 21:45 ?        00:00:00 /usr/bin/python /usr/sbin/xend status
.

Last edited by greno; 7th June 2012 at 02:54 AM.
Reply With Quote
  #2  
Old 7th June 2012, 08:59 AM
george_toolan Offline
Registered User
 
Join Date: Dec 2006
Posts: 2,077
linuxfirefox
Re: F17: xend will not start

Hint: When you're reading error messages start at the bottom:

Quote:
SELinux is preventing /usr/bin/python2.7 from read access on the file /etc/passwd.
The rest of them are just followup errors

Quote:
KeyError: 'getpwuid(): uid not found: 0'
Reply With Quote
  #3  
Old 7th June 2012, 02:36 PM
greno Offline
Registered User
 
Join Date: Oct 2005
Location: U.S.A.
Posts: 266
linuxchrome
Re: F17: xend will not start

This problem was already seen during Fedora 17 Alpha but for some reason they shipped the general release without fixing the problem. It should have been labeled a showstopper.

Here is the bug: https://bugzilla.redhat.com/show_bug.cgi?id=806107

It doesn't even make sense why Xen is messing around with /etc/passwd.

And SELinux is probably correct in preventing access to /etc/passwd from non-authorized context.

.
Reply With Quote
Reply

Tags
f17, start, xend

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xend problem. Seb Spiers Using Fedora 0 3rd February 2010 10:58 AM
FC6: xend hangs greno EOL (End Of Life) Versions 3 27th January 2007 01:47 AM
xend: No such file or directory. Is xend running? Plankton Using Fedora 4 6th June 2006 08:48 PM
xend not starting jonirons Installation, Upgrades and Live Media 2 6th April 2006 01:56 PM
Xend won't start on x86_64 mickeyboy Using Fedora 0 24th March 2006 12:56 AM


Current GMT-time: 05:55 (Saturday, 20-09-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat