Fedora Linux Support Community & Resources Center
  #1  
Old 2nd May 2008, 04:05 AM
Dave55 Offline
Registered User
 
Join Date: May 2008
Posts: 4
Unhappy NetworkManager Applet 0.7.0

Greetings,
I appreciate any help I can get. I have been trying for about the last week to get NM to connect to a wpa encoded network. It is getting to the point where I am about to revert back to XP %!%#. When I was running wep I had no problem connecting to my router. The problem I have now is that NM does not have a drop down menu for wpa. I have tried installing and running wpa_supplicant with neg results. HELP...
Reply With Quote
  #2  
Old 2nd May 2008, 05:40 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,871
Of course it does.
left-click the NM icon. Select "Connect to other wireless network"
In the popup you should see 7 secutiy options in the pulldown menu.

The bottom two are:
WPA & WPA2 Personal
WPA & WPA2 Enterprise
--
You probably want the personal.
Reply With Quote
  #3  
Old 2nd May 2008, 07:16 AM
Dave55 Offline
Registered User
 
Join Date: May 2008
Posts: 4
Stevea,

Thanks for the reply. This is what is making it so frustrating for me. Those selections are supposed to be there, but they are not. The only selection are "connect to other wireless network" and "create new wireless network". When you select ether of those, there is a wireless drop down menu, but all selections there are for WEP. It's driving me nuts...
Reply With Quote
  #4  
Old 2nd May 2008, 02:19 PM
Iron_Mike Offline
Registered User
 
Join Date: Jul 2005
Location: Ft Huachuca, AZ
Posts: 3,772
Could it be that it doesn't recognize your devices? Open a terminal window and type:

/sbin/lspci

and post your Network Devices
Reply With Quote
  #5  
Old 5th May 2008, 07:18 AM
stevea Online
Registered User
 
Join Date: Apr 2006
Location: Ohio, USA
Posts: 8,871
Not at all likely Iron_Mike. If the applet comes up you have an interface.

Dave .. What does "nm-tool" report in the "Wireless Settings" section ?

I'm seeing ...
Wireless Settings
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes
Reply With Quote
  #6  
Old 6th May 2008, 02:47 AM
Dave55 Offline
Registered User
 
Join Date: May 2008
Posts: 4
Steve.. the only setting I see in the wireless settings is:

WEP Encryption: yes

That's it... At this point I am wondering if I shouldn't just wait and upgrade to Fedora 9 Sulphur.

tks,
Dave
Reply With Quote
  #7  
Old 26th May 2008, 07:18 PM
Dave55 Offline
Registered User
 
Join Date: May 2008
Posts: 4
Well... I have upgraded to 9 and am still having the same problem. NO WPA!!!!!! What is particularly irritating is that I can configure a NEW wireless connection for WPA with my key pass, but when I go to connect to my wireless network, network manager asks for a pass code, but only gives me a security choice of WEP NO WPA. If I do a right click on NM and go to edit connections, it adds it's own configuration of my network. If I try to change that configuration to WPA, NM ignores that configuration and puts another of it's own WEP configurations in. This is driving me crazy and I may end up abandoning Linux altogether. If any of you have any ideas on how to correct this, I am all ears...

Last edited by Dave55; 26th May 2008 at 07:37 PM. Reason: Wording
Reply With Quote
  #8  
Old 26th May 2008, 07:42 PM
KKJensen Offline
Registered User
 
Join Date: Sep 2006
Posts: 242
I haven't connected to WPA with my machine but I do recall the NM wasn't really doing it's job until I checked off the "Controlled by NetworkManager" option in the options for the device in the "Network Configuration" menu. Once this option was checked off for each the wireless and the wired devices I was able to connect/disconnect from the different networks. If it acutally is a problem with WPA and F9 then I wait a bit...the problem will surely surface with someone else too.
Reply With Quote
  #9  
Old 27th May 2008, 01:37 AM
nyjetshead Offline
Registered User
 
Join Date: Oct 2007
Posts: 633
If your device supports the wireless extensions (WEXT) then it should work with NM, it probably doesn't support WEXT.
http://live.gnome.org/DarrenAlbers/N...956507a259bc9f
NM uses wpa supplicant for WPA , upgrading to F9 wont fix the problem.
What device are you using (as asked by Iron Mike)?
Also there is a workaround for devices that don't support WEXT.
Try to get it working using wpa supplicant alone if it works then you can attempt the workaround.
Reply With Quote
Reply

Tags
applet, networkmanager

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FC9 NetworkManager applet gone? NoArms Servers & Networking 2 6th July 2008 01:41 AM
How to use NetworkManager applet as a stand alone app? nogradi Servers & Networking 0 2nd December 2007 07:08 AM
NetworkManager Applet ricsto Using Fedora 0 23rd June 2007 10:43 AM
NetworkManager applet in FC4 milosilak Servers & Networking 5 16th July 2005 01:53 AM


Current GMT-time: 18:15 (Wednesday, 01-10-2014)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat