PDA

View Full Version : Missing Trash



widesteps
20th February 2004, 09:33 PM
My trash can has disappeared from my desktop. Does anybody know how to get it back?

cheers

mhelios
21st February 2004, 04:46 AM
Try running nautilus from the desktop (user's Home icon) or if that's not there then run it in a console. That should load the icon.
If that doesn't work, check in Preferences -> More Preferences -> Sessions there are no sessions saved. Delete them if so and logout//login again.

widesteps
21st February 2004, 12:08 PM
Thanks fo rthe reply mhelios,

Unfortunately none of that worked. I still have no desktop trash can..strange!

monkey
23rd February 2004, 01:04 PM
Here is what I have tried. I don't know if it is the correct way.

1. right-click -> Create Launcher
2. Use 'Trash' as name.
3. Make the type as 'Link'
4. In URL, I use 'trash:'
so when I press on the newly created "Trash", I can enter the trash.

Could anyone tell me if I am correct to do in this way. One problem is the icon... How can I get back the "trash" icon?

Ug
23rd February 2004, 01:07 PM
Do you use Gnome or KDE?

widesteps
23rd February 2004, 01:29 PM
I am using Gnome.

I created the desktop link via 'Create Launcher' and yes I can enter my trash. However it sems a bit of a hack it does not have the trash icon (I have tried to change it via properties but there is no trash icon available in /usr/share/pixmaps) and more importantly it does not behave like the old trash app cos there is no 'empty wastebasket' on its menu and you can move the trash to the wastebasket! if you get my drift - basically its not the original trash app it is just a link ti the trash folder.

Thanks for the replies so far - surely there has to be s simple solution this.

Ug
23rd February 2004, 01:32 PM
Have you tried adding an applet to the desktop? That might be what it is.

I'm not on a linux box atm, so I can't help. I'm sitting in a classroom being lectured. :p

widesteps
23rd February 2004, 02:23 PM
..and how would you do that?
Also you would need to know what the applet is called, and a serach on 'rash' reveals no apps or applets.

mhelios
23rd February 2004, 02:31 PM
I may have the solution. Go to System Tools -> More System Tools -> Configuration Editor -> apps -> nautilus -> preferences -> then uncheck "show desktop".

HTH

widesteps
23rd February 2004, 02:55 PM
mhelios, you were close..I thought it strange to uncheck 'show desktop' as this made all my desktop icons disappear, so I left this checked and went to:

System Tools -> More System Tools -> Configuration Editor -> apps -> nautilus -> desktop -> then checked "trash_icon_visible"

Logged out and back in and voila my desktop is restored with my waste basket!

Bit concerned that the Configuration Editor warns that it is not the recommended way of setting desktop preferences. But show me another way and I will gladly use it!

Thanks ug and mheios for your invaluable help

I hope this helps other with the same problem

Ug
23rd February 2004, 03:18 PM
Finally! Like you said, it had to be something simple.

mhelios
23rd February 2004, 04:47 PM
Well, I'm glad I led you to at least the right app. :) The warning is there just to remind you that you have more chance of stuffing things up in here than in using the more friendly tools in the Start Here:/// and similar places.

It's a bit like using the registry in "that other OS". :p

Jman
23rd March 2004, 01:08 AM
Marked as resolved.

And I bet this will help someone else, widesteps.

chiku31
14th December 2004, 08:48 AM
My trash icon also disppeared, and I had followed all the above post to get it back but none help. Is there anything else I can do to get my trash icon back? By the way, I am running gnome 2.8 if that hleps. Thanks!

gsorian
9th March 2005, 05:45 PM
Hi everybody...

I got a similar problem, but not with the Trash Can, I lost some Desktop Icons of folders and files recently created.

Following the instrucions to restore the Trash Can at SystemTools - Configurator Editor - Nautilus... I disable and enable the Preferences - show_desktop option and now I have my lost icons again.

Thanks for your support and I hope that this could help someone else.

abatis
15th October 2005, 06:59 PM
I just wanted to thank all above. The Configuration Editor Nautlus solved my missing Gnome icon issue. I did have to go through a few combinations and logouts before I got back to the way it was before I screwed it up.

phil-fedora-5
9th March 2006, 06:05 PM
same problem here...

right click on desktop>

clean up by name>

yeehaaaaa... we're takin' out the trash

wintervirus
30th March 2006, 11:07 PM
Okay! I've had the same problems a few times and I finally found this little app... I think it was FreshRPMS.net I got it from & it really made it all simple

drforbin
13th April 2006, 05:42 PM
GO HERE:

/usr/share/apps/kdesktop and COPY directory.trash to your desktop. You will again have the proper icon with the ability to "empty trash" and show empty or full status