View Full Version : SCSI drives not available + Vigor 2600 not in /etc/hosts (but works fine)

12th July 2004, 12:27 AM
Hello everybody,

Since I am new here, allow me to introduce myself. I am Jeroen, 26 yrs old from Amsterdam the Netherlands. I have been working on Windows the past 10 years and got more curious about Linux everyday. So now I picked up a copy of Linux for non-geeks ( http://www.oreilly.com/catalog/1593270348/ ) and installed Fedora (core 1) on a PII 266MHz machine with about 512MB memory.

It boots, much to my surprise, under five minutes and looks very slick. Nevertheless it is still getting used to. Since I grew up with Windows I am totally unfamiliair with the way Linux ‘thinks’ and ‘works’. Time to get to the point: I have two problems which seem easy to solve, but I can’t find an answer anywhere. I have searched several forums and of course man’s best friend Google. I guess I use the wrong searchphrase.

Problem 1:

The box is equipped with four hard drives (about 4GB each) connected via SCSI. Everything works fine during the boot proccess. When I take a look in the hardware browser it shows the four drives as sda1, sdb1, sdc 1 and sdd(?).


As soon as I want to install the 153 updates that are available (through the updateagent with the red ball and the big exclamation mark) I get the error message of insufficient disk space. My questions on this are probably quiet simple:

-1- Fedore does see all my disks, correct? how can I use them? Must I mount them? If so, how? Does anyone have a link to a newbieguide on how Fedora handles SCSI drives and/or disks in general? Unfortunately SCSI-drives are not non-geek according to the book…

-2- I have tried to use Disk Druid or Anaconda (partition managers, correct?) Both aren’t installed on my machine as far as I can tell. I can’t find a download location for Disk Druid, only one section on the RedHat website telling me how useful it is. I did find a rpm-package for Anaconda, but it was labelled i386. What am I missing here? I start to get the feeling this is not seperately downloadable and that I am overlooking things. Can someone enlighten me on this? Any help would be very much appreciated.

Problem 2:

Both my P4 Win XP box and my P2 Fedora box connect to the internet via a Draytek Router/Modem Vigor 2600 Plus. The internet connections work great on both machines. Funny thing is though, when I log in on the Fedora box I get this error:

Could not look up internet address for Vigor12. This will prevent GNOME from operating correctly. It may be possible to correct the problem by adding Vigor12 to the file /etc/hosts.

Then I can Try Again or Login Anyway. I pick the latter option and everything works fine. Probably another very simple question:

-1- How can I add this Vigor to ‘etc/hosts/’?

-2- What is the problem here?

These problems are probably very easy to solve, but I have no idea how Linux thinks, so I hope your answers will help me understand more of my new OS.

Besides this I must say I am very positively surprised by Fedora. The more I understand the more tempting it gets to rebuild my P4 to a Fedorasystem as well.

Well, thank you for reading and very much thanks in advance for your time and trouble!
Kind regards,


12th July 2004, 06:44 AM
For your first question, it looks like when you setup Fedora on your system, you left a lot of free space. Each drive that says free space (sda, sdc, sdd) is unused space you aren't using. You are going to have to create file systems on the free spaces, add the necessary entries in /etc/fstab and then mount the partitions.

I am not too strong in creating partitions using the command line since I usually have my partitions automatically setup by the installer, but I will try to help you out. Your are going to have to be root to do this. Type /sbin/mkfs.ext3 /dev/sdXY. X is the disk letter (a, c, d) and Y is the partition (1, 2, etc). This will create an ext3 partition on that drive. I would next test the partition to see if any errors are generated. Tyep mount /dev/sdXY /mnt/<directory> where <directory> is an unmounted directory such as floppy. If no errors are reported, edit /etc/fstab and enter the information such as /dev/sda2 /mnt/newfolder ext3 defaults 1 2. This will mount partition /dev/sda2 as /mnt/newfolder everytime you boot your system. After everything is done, type /sbin/tune2fs -c 0 /dev/sdXY to turn off filesystem checking. Under Linux, partitions are automatically checked after so many mounts, and this will turn it off.

I would personally think about mounting /home on its own partition. Looking at your setup, you might want to consider making /dev/sdd your /home partition. This will free up space from /dev/sdb which I am assuming is your / partition.

For your second question, I would run neat (you need to be root or you will be asked for root's password). Next, click on the tab titled Hosts. Under this tab, you can add aliases for different computers. Click on the new button, add in the necessary information, and save your configuration. You might be asked to reboot your system or restart your network connection since you made changes. I would open up a console, su to root, and type /sbin/service network restart to restart your networking without rebooting. Next time you log into gnome, that warning message should go away.

Hope this helps out.


12th July 2004, 08:34 AM
Er, don't run mkfs first - you have to define the partition before you can put a filesystem (which is what mkfs does) on it. The command-line tool (which must be run as the root user) is fdisk. This is very similar to the old DOS "fdisk" command, but must be run against each disk device specifically.

WARNING The following guidelines may trash your system. No guarantees, as I'm guessing on a couple of points about your system. However, I have done this particular sequence several times and haven't totally destroyed everthing - close, but not quite. This is quite long...

First, make a new partition on your first drive (the X's and Y's are for cylindar numbers that I can't know about from your description):

# fdisk /dev/sda
Command (m for help): n
Command action
e extended
p primary partition (1-4)
Partition number (1-4): 2
First cylinder (xxx-yyy, default xxx): xxx
Last cylinder or +size or +sizeM or +sizeK (xxx-yyy, default yyy): yyy
Command (m for help): p

Disk /dev/sda:
<your partitiion table is shown here>

Command (m for help): w
<writes and exits>

Now you run mkfs.ext3 /dev/sda2 to make the filesystem and you're ready to mount it. If you look in the file /etc/fstab, you'll probably see two entries like this:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2

So let's assume you want to make your new partition your "/home" - you can do this by executing

e2label /dev/sda2 /home

This puts a label of "/home" on that partition - you don't then have to remember all the driver partitions/devices.

Of course, you have one slight problem - you already have a "/home" directory - and it's probably got a bunch of stuff that you don't want to lose. So this is what I recommend (you shouldn't be logged in as your normal user at this point):

# cd /root
# mkdir temp
# mount /dev/sda2 /root/temp
# cp -a /home/* /root/temp
# umount /root/temp
# mv /home /home.bak
# mkdir /home

Edit /etc/fstab and put the following line in there:

LABEL=/home /home ext3 defaults 1 2

Issue the command mount /home and you shouldn't see any messages. If you can log in as your "normal" user and everything's operating as if you hadn't done anything special, you have successfully moved your /home! You can now delete the "/home.bak" directory (rm -rf /home.bak) and you now have some more space on your / partition (root).

This probably isn't enough room to free up for the updates, so you might want to go through the same exercise with the /usr directory. This gets a bit more hairy as you'll probably need to edit the /etc/fstab file before the move/mount - and if you happen to mess it up, it will render your system unusable (you'll have to use a rescue disk, probably, to move the "/usr.bak" back to "/usr"). I've done this one a couple of systems and I've held my breath every time I've done it. /usr will typically be one of the largest partitions, as it holds all of the user-space programs, like X, so freeing that from the root partition should give you enough room to run the update (the RPM's are downloaded to /var/cache/yum - which is on the root partition (/), so with that many it's not surprising that you've not enough disk space to hold them.

Additional information on the above commands can be found by using man command - the "manpages" are the on-line manual included in every Linux installation.

12th July 2004, 04:39 PM
Hey, crackers! That looks pretty good. You should post it either:

(1) As a HOWTO in the HOWTO forum.
(2) Submit it to the Articles section

or (3) (the coolest) Submit it to FedoraNews -- it's really pretty a good thing to know how to do. fdisk is so cryptic, and partitioning is so tough.

I think maybe I'll add a note about qtparted to the FAQ at some point or another, to make all this easier.


12th July 2004, 09:56 PM
Hello everybody,

Thanks you so much for your answers. I will try them as soon as I get the chance (and will let you know the outcome). I am not worried about trahing the system or losing data: it is a testbox after all. Which brings me to this: is it recommended to do yet another new install instead of above mentioned option? Or doesn't it make a difference?
Thanks again!


P.S. I start to understand the way Linux thinks/acts: thank you so much!

12th July 2004, 11:37 PM
Personally if I were you I'd try Crackers suggestion first just to gain the experience. But generally speaking, you'd have been better off having the installation/partitioning routine use ALL of your free space upon initial install.

13th July 2004, 05:12 PM
Harry's got some good advice - especially since you don't mind trashing it. Go for it - then reinstall and apply what you've learned about partitions!

Avatraxiom: Hadn't thought about a HOWTO at FedoraNews - I've already got one there and it's looking a bit moribund. Maybe this'll give it a bit of shot in the arm...