View Full Version : FC2!!! Now I need Suspend

18th May 2004, 06:03 AM
So I used bit torrent to download FC2 and I must say that is is quite nice so far. It installed better than the test releases. I am not having the display problems that I had with the Savage driver that I had before. So far so good.

Now I could really use the suspend feature on my laptop it would save me a ton of time having to shut-down and reboot all the time.

If any body has any suggestions I am all ears. I am sitll learning how to tewak the config files, I suspect my answer is there. If anybody can give me some direction I would be ever gratefull.


18th May 2004, 03:43 PM
I had suspend working once upon a time in FC1 with kernel 2.6.4 I believe. I never got it working on a regular basis in FC2T3 with 2.6.5 though. I gave up for the time being...I was wasting too much time on it. At any rate, software suspend is disabled by default in FC2:

[jrblevin@syd boot]$ cat config-2.6.5-1.358 | grep SUSPEND

So if you want to get it going, you first need to compile a custom kernel. Then, there are suspend scripts available at http://swsusp.sf.net that you might want to use. I really wish they could get the suspend mess in order, it does save a lot time (and power) to be able to resume.

20th May 2004, 07:26 PM
If I do this:

apm -s

my ThinkPad 600E will go into suspend. However it seems that when it wakes back up it will sometimes not work well (erratic mouse, etc)

21st May 2004, 02:00 AM
I tried the apm -s command and it acts like it is going to suspend, the drive spins down most of the lights go out, the monitor goes blank but not quite all the way off. A seccond or two later and it hops back to life and the console says

apm: Input/output error

Any sugestions? As far as configuring a new kernel I still am a little clueless on how to do that. Any suggestions on where to start learning about that would be much help

26th May 2004, 11:41 AM
I read the following from another thread:

Originally posted by charlie
David: there are 2 types of power management: apm and acpi. APM is older, acpi is newer. I'll bet your laptop is acpi only and that battery applet is trying to run apm.

I would try to find out what type of power management your laptop supports and if it is acpi (which is still not 100% supported in Linux) then you'll want to do some searching on this forum and elsewhere for help with acpi (which I know nothing about since my older dell works with apm).

Good luck.

I'm working through this at the moment and my plan is to:
1) Determine which power management utility my notebook (Dell Inspiron 3800) supports (acpi or apmd or both)
2) Set up the appropriate power management utility (and deactivate the other in "System Settings" -> "Server Settings" -> "Services". Only one should be running at a time)
3) Find suitable suspend scripts (if they don't come with acpi or apmd)
4) Customise suspend scripts to deactivate / activate resources (e.g. pcmcia, network)

I'd recommend you go through the same steps.

Please post any progress.

26th May 2004, 05:15 PM
I just posted this in another thread but I thought it might be helpful here.

Here's what I had to do to get my suspend key working on my Dell Inspiron 4100. First, I want to say that ACPI sucks right now. I'm sure it will get better but right now APM is the way to go. The process I had to go through requires recompiling the 2.6 kernel in FC2. This is not a hard process. It does require patience.
The first thing I did was in the menu do "System Setting" -> "Server Settings" -> "Services". It should prompt for root password. The Service Configuration windows should come up. You should be running and editing Runlevel 5. If you are using a different Runlevel, click Edit Runlevel to switch. Uncheck acpid and check apmd. Click on acpid and click "Stop". Close the Service Configuration Windows.
Next step: The kernel! Don't run away screaming! It's not hard and I'm detailing all my steps. Open a terminal. Change to root (do "su -" at the command line). Change directory to /usr/src/linux-2.6.5-1.358/ (do "cd /usr/src/linux-2.6.5-1.358/"). Okay, next do "make menuconfig". This command will take us into a text-based menu configuration utility for the kernel. Alternatively, you can do "make xconfig" for a GUI config utility, but for this will stick to the text-based one. I have found out that you can't have ACPI and APM running at the same time. It just doesn't work. Don't know why, and I'm not a programmer, I'm a user, I just want my stuff to work! Use the arrow keys to navigate the menus. Arrow down to "Power Management Options (ACPI, APM) --->" and hit Enter. I have "Power management" selected and "Software Suspend" marked. If you don't have these marked, arrow down to them and hit Space Bar or "Y". I don't know why I didn't need "Suspend-to-disk support" but I do not have it selected. Arrow down to "ACPI Support". In this menu, if you have "ACPI Support" selected, hit Space Bar or "N" to unselect it. Hit "Esc" to go back to the previous menu. Arrow down to "APM BIOS Support" and hit Enter. Of couse, I have the top listing,"APM BIOS Support" selected allong with <*> APM (Advanced Power Management) BIOS support "Enable PM at boot time","Make CPU Idle calls when idle", "Enable console blanking using APM","RTC stores time in GMT","Allow interrupts during APM BIOS calls", and "Use real mode APM BIOS call to power off". The only one I DON'T have selected is "Ignore USER SUSPEND". The help on this option sugests that unless you have a NEC Versa M series notebooks, you shouldn't use it. Hit "Esc" to go back to the previous menu. Under "CPU Frequency Scaling", I didn't change anything, I think I would probably be best that you do the same. Hit "Esc" "Esc" and you will be asked if you want to save your kernel configuration, which you do so hit Enter on Yes. This will take you back out to a command prompt where you should do "make all modules_install install". It will take SEVERAL minutes, depening on the speed of your computer, of course. After it is done, "reboot". If you are running GRUB, when the Boot loader screen comes up, you will have to select the Custom kernel, you'll see. That's how I got my suspend hot key working on my Dell Inspiron 4100. You can try it if you like. Let me know if it works! Oh, and visit my website, http://www.zerovertex.com. Later! Good Luck!

30th May 2004, 07:20 PM
Many thanks to ZeroVerteX for your detailed instructions. I was able to do my first kernal compiling and as of this boot can now use APM suspend on my Dell 4150. :)

A note to others who may try it- The Fn+Suspend key combination may lock up the machine. I set up a launcher to run "sudo apm -s" and all is right with the world.

2nd June 2004, 11:22 PM
First, I want to say that ACPI sucks right now. I'm sure it will get better but right now APM is the way to go.
Have anybody tried to compile the 2.6.6 kernel in order to check if there has been any major improvements regarding ACPI ? If you see the annoncement from LinuxToday (http://linuxtoday.com/developer/2004051001026NWKNDV) it seems like Len Brown included a lot of ACPI fixes and this might have improved even more in the coming 2.6.7 kernel.

If anyone have tried this: Please post your experience.

---- Trond

7th June 2004, 06:59 PM
I have recently compiled a 2.6.6 kernel with ACPI support running FC2. The compile went well and I built the ACPI parameters into the kernel (not as modules). I still could not get suspend to RAM to work properly. The laptop would suspend OK when closing the lid, but when the power button was pressed to reinstate the OS, everything came back up except the screen. :( I am not sure what the problem is. Also, despite setting the CPU frequency down to 600 MHz when idle, the fan is on constantly. I will take a stab at this again with APM enabled and no ACPI. Here was the reference I used for compiling the 2.6.6 kernel (http://www.linuxquestions.org/questions/showthread.php?s=&postid=379355#post379355).

I have a Compaq Presario 2585 which, I have found out via Google and other forums, is a pain to install Linux on.

7th June 2004, 07:53 PM
buldir, You may want to try to press Fn-Z (if you have a Dell). That forces the OS to check with the BIOS and it will shut the fan down. Works for me on a Dell 4150.

8th June 2004, 09:36 AM
So, I found out that my laptop (Compaq Presario 2585 w/Intel P4) does not 1) support APM, and 2) support CPU throttling, which sucks. As a result, the CPU temps slowly get hotter over time and the fans kick in on high. It looks as though I will be putting...yes, that's right...Windows back on this thing. Crap.

15th June 2004, 02:39 AM
try "suspend to disk" instead of "suspend to ram".
Suspending takes a bit longer, but it is (almost) hardware independent.

Here are some raw explanations:

Having "Hibernate mode" work.

Since "ssupend to RAM" didn't work, I tried "Suspend to disk", or software suspend, or simply "Hibernate".

Note: Recompiling the kernel consumed more than 1G !
Make sure there is enough disk space before you proceed.
cat /proc/acpi/sleep
Make sure S4 is one of the sleeping mode.
grep swap /etc/fstab
This should give you the partition of the swap (/dev/hda8 in my case)
Make sure that the size of the swap is larger than your RAM.
Add "resume=/dev/hda8" in the appropriate line in /boot/grub/grub.conf

cd /usr/src/linux-2.6.x-x.x
make menuconfig
<choose: Power managment options>
<Select: Software Suspend>
<Exit and Save>
make all modules_insall install

<recomended:>service network stop
echo 4 >> /proc/acpi/sleep
<The computer should go to "hibernate" mode>
<Wake up by pressing the power buttona short press>
service network start

17th June 2004, 02:41 AM
I have recently compiled a 2.6.6 kernel with ACPI support running FC2. The compile went well and I built the ACPI parameters into the kernel (not as modules). I still could not get suspend to RAM to work properly.

Kernel 2.6.7 relased (http://linuxtoday.com/developer/2004061602026NWKNDV) today. Anyone going to try it for this suspend stuff ? (I probably should grow up and start doing these kernel compilation myself these days...)

---- Trond