PDA

View Full Version : Apache problems with FC3



rmenezes
29th September 2004, 02:00 PM
Hi all,

I just installed the httpd package in the Fedora Core 3 test 2 but when I run the:

service httpd start

the program give me this message:

Starting httpd: /usr/sbin/httpd: error while loading shared libraries: libdb-4.2.so: failed to map segment from shared object: Permission denied

Any one could help me?

ewdi
29th September 2004, 02:12 PM
did you run it under root?

rmenezes
29th September 2004, 02:23 PM
Yes,

For a little test, I changed the user and group in the httpd.conf to root but the erros appers again.

ewdi
29th September 2004, 02:31 PM
i mean are you logged in as root?

rmenezes
29th September 2004, 02:33 PM
Nope, I'm running the software with "su".

ewdi
29th September 2004, 02:42 PM
can you try run

httpd -t

let me know what the result are

rmenezes
29th September 2004, 02:51 PM
Nothing happens:

# httpd -t
#

ewdi
29th September 2004, 02:54 PM
that means your config file are good. can you check the file libdb-4.2.so, and see what is the permission and who own the file

rmenezes
29th September 2004, 03:18 PM
# cd /usr/lib/
# ls libdb-4.2.so -la
lrwxrwxrwx 1 root root 22 Set 23 20:04 libdb-4.2.so -> ../../lib/libdb-4.2.so
# ls ../../lib/libdb-4.2.so -la
-rwxr-xr-x 1 root root 843996 Set 21 20:55 ../../lib/libdb-4.2.so
#

Is this ok?

ewdi
29th September 2004, 03:28 PM
all seems fine, i really dont understand why it gives error,, the only thing i suspect is the $path to the lib

rmenezes
29th September 2004, 03:39 PM
It's strange, with FC2 I always use the same procedure, but now with FC3 I get this erros.

dillee1
4th October 2004, 07:05 PM
Same problem here.
That seems to be a glibc library.
may be it is selinux's fault?
any one who have solved this?

Sanya Moriyama
10th October 2004, 04:36 PM
I don't know how to solve perfectly.
But this is just a SELinux problem.
You can see some message in /var/log/messages after /sbin/service httpd restart
After all, easy wat to run httpd is edit /etc/SELinux/config and change enforcing to permissive.
I think it's a transitional consistency problem.
May be someone correct at some time.

[for reference] /etc/selinux/targeted/contexts/files/file_contexts describe files that can be accesible by httpd

Sanya Moriyama
10th October 2004, 04:39 PM
I forget writing enough.
after changing /etc/selinux/config , we need to reboot a machine.

more details will be below.
http://fedora.redhat.com/docs/selinux-faq-fc3test2/