PDA

View Full Version : usb device not detected: error -71



jbruggem
1st January 2005, 11:39 AM
All,

I have an external usb 250 Mb harddisk , which used to work. I recently dedided to upgrade my home network to Fedora core 3, and used it as a backup device.

After the upgrade, I want to restore data, but guess what hapens:

at connecting my drive, I get (in /var/log/messages) :

slocum kernel: usb 2-1: uew full speed USB device using address 5
slocum kernel: usb 2-1: device not accepting address 5, error -71
slocum kernel: usb 2-1: uew full speed USB device using address 6
slocum kernel: usb 2-1: device not accepting address 6, error -71

(the nrs 5 - 6 increment gradually as I try anew, the nr 2-1 refers to the connector where I plug the disk)

no device shows up in /dev, so I cannot mount anything (or even see it in fstab)

the same happens if I previously manually load usb-storage, it happens on 4 different computers, under fc3 and fc1. I cannot see it anymore under knoppix 3.3 (which previously i could !!)

I have tried stripping a computer of all unnecesary hardware to avoid interrupt problems, but no cure.

the drive is still detected by winXP (but not read, as i've formatted it in ext3 )

My camera and usb-serial convertor are still working, so no usb hardware error neither.

any idea's ?

imdeemvp
1st January 2005, 11:48 AM
Since it is a linux partition this may help you mount it: http://www.fedoranews.org/tchung/storage/

jbruggem
2nd January 2005, 07:24 PM
Nope. As I've mentioned in my initial post, there is no entry created in /dev, which means fdisk cannot access it.

imdeemvp
2nd January 2005, 08:24 PM
The tutorial gives you step by step configuration including the fstab entry. Run as root:
/sbin/fdisk -l and see how it is detected and create your fstab.

jbruggem
2nd January 2005, 09:19 PM
As i've said in my initial post, it is not detected. It used to be, i've done what you said previously in my old setup, i've partitioned and formated it in ext3 then, Now it is not visible anymore, even if I try to go back to that old setup (problem is, i don't know what exactly that previous setup was: one does not have a good view on that anymore with tools like yum and up2date ...

the_profiler
8th January 2005, 06:35 AM
i need to know how to mount devices.. my problem is.. my account is like limited.. when i run disk management, it says contact admin.. no idea then how to change the settings of the account in mounting devices.. especially USB.. the good thing is.. yes it does detect the USB.. it can read.. but i think i cannot write into it.. obviously, only when im into root mode, i can access everything.. but how can i change permissions on mounting for normal accounts? :confused:

imdeemvp
8th January 2005, 08:51 AM
Are you in a network or lan? If you the only one you can give you access is the root.

the_profiler
8th January 2005, 09:11 AM
im in a network.. but im the only one running fedora 3,, there are two others.. both Apple Computers :cool: and a linux pda (zaurus). I can be in root mode, but of course it is not recommended for every day usage.. that's why "contact the administrator" would only mean... contacting myself.. heehee.. but still.. im new to fedora.. it is like fedora is stricter than red hat 9 in handling even disk/devices.. well.. so much for its "security enhancemenct" :D

taylor65
10th January 2005, 07:10 PM
I had the same problem, I had to disable acpid. System Settings -> Server Settings -> Services. Also, I put acpid=off at the end of the kernel line in /etc/grub/grub.conf.

jbruggem
10th January 2005, 09:19 PM
Have tried this in various forms. No help. Any kernel params that can improve this behaviour ?

jarifed
11th January 2005, 09:29 PM
Maybe this helps

http://www.spinics.net/lists/usb/msg02643.html

read the follow up of the message and it explains the reason.

Mine USB 250 Gb disks works OK but I only have an USB 1.1 bus.

jbruggem
11th January 2005, 11:03 PM
At last a tip I didn' know of ! Aparently, fedora core 3 is compiled with usbcore in the kernel, so the trick doesn't work "out of the box".

I've tried it on a Mandrake 10 (which currently sits on my test-HD, the advantage of having swappable HD's !), which does have usbcore compiled as module.
but with both "options usbcore old_scheme_first=y" or "optionsusbcore use_both_schemes=y" in my /etc/modprobe.conf, I get during bootup (in dmesg )

usbcore: Unknown parameter 'old_scheme_first'
or
usbcore: Unknown parameter 'use_both_schemes'

I'm gonna look for to install kernel source on FC3, and recompile the kernel there ...

jbruggem
15th January 2005, 11:25 AM
latest news: I've upgraded FC3 to kernel
Linux version 2.6.10-1.741_FC3

My /etc/modprobe.conf contains:
alias usbcore usbcore
options usbcore old_scheme_first=y
(It gives no errors at starting anymore,)

And I still get in /var/log/messages when attaching the HD:
Jan 15 11:19:44 slocum kernel: usb 3-1: new full speed USB device using uhci_hcd and address 2
Jan 15 11:19:44 slocum kernel: usb 3-1: device descriptor read/64, error -71
Jan 15 11:19:44 slocum kernel: usb 3-1: device descriptor read/64, error -71
Jan 15 11:19:44 slocum kernel: usb 3-1: new full speed USB device using uhci_hcd and address 3
Jan 15 11:19:45 slocum kernel: usb 3-1: device descriptor read/64, error -71

Ideas ?

jfrezende
16th January 2005, 03:35 AM
in order to give options to usbcore it has to be compiled as a module. in fc3, it is not.

regards, rezende


latest news: I've upgraded FC3 to kernel
Linux version 2.6.10-1.741_FC3

My /etc/modprobe.conf contains:
alias usbcore usbcore
options usbcore old_scheme_first=y
(It gives no errors at starting anymore,)

And I still get in /var/log/messages when attaching the HD:
Jan 15 11:19:44 slocum kernel: usb 3-1: new full speed USB device using uhci_hcd and address 2
Jan 15 11:19:44 slocum kernel: usb 3-1: device descriptor read/64, error -71
Jan 15 11:19:44 slocum kernel: usb 3-1: device descriptor read/64, error -71
Jan 15 11:19:44 slocum kernel: usb 3-1: new full speed USB device using uhci_hcd and address 3
Jan 15 11:19:45 slocum kernel: usb 3-1: device descriptor read/64, error -71

Ideas ?

jarifed
21st January 2005, 09:17 PM
I am not sure if you'r problem has been fixed and if you recompiled your kernel
but may be this can help you

enter in a terminal as root
cat /sys/module/usbcore/parameters/old_scheme_first
It should either return Y or N

If N then you can change old_scheme_first to Y as follows

echo Y > /sys/module/usbcore/parameters/old_scheme_first
use cat /sys/module/usbcore/parameters/old_scheme_first and it should return a Y

I have set capital letters as that's what is showing on my FC3 kernel 2.6.10-1.741_FC3

Additionally you can check this also
cat /sys/module/usbcore/parameters/use_both_schemes
in my case it returns N

lirakis
22nd January 2005, 01:05 AM
Try updating your udev package. The core 3 release didnt work well for my usb stuff either. udev is the thing that moved usb hotplug into the user space instead of the kernel and it creates devices on the fly... run up2date and see if udev is available for updating.