PDA

View Full Version : How to install ATHEROS drivers for wireless card.



imdeemvp
20th February 2005, 03:16 AM
I had success installing my airlink101 AWLC4030 Super G™ Wireless Cardbus Adapter (http://www.airlink101.com/products/awlc4030.html). This device uses the atheros drivers which in linux are called the madwifi drivers (http://atrpms.net/dist/fc3/madwifi/) and as you can see you can get these packages from atrpms. (http://atrpms.net/) If you have this repository in your yum.conf you can install via yum and a dependency will be needed to install the drivers. The dependency is installed according to your kernel version. These drives are also available for AMD 64. (http://atrpms.net/dist/fc3/madwifi/)



I would like to let people know that there is a distro that comes with all the browser plug-ins included and it is PCLinuxOS (http://www.pclinuxos.com/) which is a great distro for newbies. It has 2 versions one for ATI and Nvidia drivers allready installed. It also includes limewire, amule, bittorrent and a lot of wireless support. So check it out!!


Go here for Intel ProWireless drivers intallation. (http://www.fedoraforum.org/forum/showthread.php?t=56694)

TIP: If you want to use the latest kernel after a fresh installation open terminal and run:
yum upgrade kernel

1.Please note that everytime you upgrade the kernel reinstallation of dependency is required.

2.To find out if your card uses the atheros drivers go here and do a seach. (http://customerproducts.atheros.com/customerproducts/ResultsPageBasic.asp) Or run: /sbin/lspci to see the chipset.

3. Cards supported by madwifi. (http://madwifi.sourceforge.net/dokuwiki/doku.php?id=compatibility_list)

UPDATE: Let us begin by adding atrmps to your repo data base, if you already have it skip this step . Now open terminal and become root and run this command:
gedit /etc/yum.repos.d/atrpms.repo and add this lines:
[atrpms]
name=ATrpms for Fedora Core $releasever stable
baseurl=http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable
enabled=1
gpgcheck=1 and click on SAVE , also root import the gpg key from the terminal: rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms

This is an example of how I did:

[imdeemvp@myfc3 ~]$ uname -r
2.6.11-1.14_FC3
[imdeemvp@myfc3 ~]$
MAJOR UPDATE: All you have to do NOW is run the yum install madwifi command as root and please note the following dependy will be needed which is according to the kernel version:

madwifi-kmdl-2.6.11-1.14_FC3.i686 0:0.9.4.12-16.rhfc3.at

yum install madwifiand this will be the result:

[root@myfc3 imdeemvp]# yum install madwifi
Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: atrpms-stable
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 797 kB 00:20
MD Read : ################################################## 2623/2623
base : ################################################## 2622/2622
primary.xml.gz 100% |=========================| 351 kB 00:09
MD Read : ################################################## 885/885
updates-re: ################################################## 885/885
primary.xml.gz 100% |=========================| 332 kB 00:08
MD Read : ################################################## 1060/1060
atrpms-sta: ################################################## 1060/1060
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for madwifi to pack into transaction set.
madwifi-0.9.4.12-16.rhfc3 100% |=========================| 1.9 kB 00:00
---> Package madwifi.i386 0:0.9.4.12-16.rhfc3.at set to be installed
--> Running transaction check
--> Processing Dependency: madwifi-kmdl-0.9.4.12-16.rhfc3.at for package: madwifi
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for madwifi-kmdl-2.6.11-1.14_FC3 to pack into transaction set.
madwifi-kmdl-2.6.11-1.14_ 100% |=========================| 4.2 kB 00:00
---> Package madwifi-kmdl-2.6.11-1.14_FC3.i686 0:0.9.4.12-16.rhfc3.at set to be installed
--> Running transaction check

Dependencies Resolved
Transaction Listing:
Install: madwifi.i386 0:0.9.4.12-16.rhfc3.at

Performing the following to resolve dependencies:
Install: madwifi-kmdl-2.6.11-1.14_FC3.i686 0:0.9.4.12-16.rhfc3.at
Is this ok [y/N]: y
Downloading Packages:
madwifi-0.9.4.12-16.rhfc3 100% |=========================| 2.4 kB 00:00
madwifi-kmdl-2.6.11-1.14_ 100% |=========================| 165 kB 00:04
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: madwifi-kmdl-2.6.11-1.14_FC3 100 % done 1/2
Installing: madwifi 100 % done 2/2

Installed: madwifi.i386 0:0.9.4.12-16.rhfc3.at
Dependency Installed: madwifi-kmdl-2.6.11-1.14_FC3.i686 0:0.9.4.12-16.rhfc3.at
Complete!
[root@myfc3 imdeemvp]#

We are not done you have to go to system tools >internet configuration wizard and setup the wireless connection. You may also run into some issues like I did. My wireless was SLOW so I asked for help and this was the SOLUTION! (http://www.fedoraforum.org/forum/showthread.php?t=42924)

You may also need some extra tools to monitor your wireless connection and in this tutorial (http://www.fedoranews.org/contributors/jim_lawrence/network_manager/) you can learn how to do it. I personally use gkrellm (http://www.fedoraforum.org/forum/showthread.php?p=97228) to monitor my wireless connection (=ath0). I am posting my wireless configuration:
[imdeemvp@myfc3 ~]$ cat /etc/sysconfig/network-scripts/ifcfg-ath0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=yes
USERCTL=yes
PEERDNS=no
GATEWAY=
TYPE=Wireless
DEVICE=ath0
HWADDR=00:0f:ax:xb:xd:ax <<- this was modified before posting
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ESSID=mybelxxx.xxx
CHANNEL=6
MODE=Managed
RATE=auto
[imdeemvp@myfc3 ~]$
PLEASE READ THE TROUBLESHOOTING GUIDE. (http://madwifi.sourceforge.net/dokuwiki/doku.php?id=troubleshooting)

I created this little how to in my laptop as I was wireless connected! I am also posting some screenshot to give you an idea how your setting should look like. ONE quick tip I make the NetworkMangerInfo start during my login by adding it to session >startup program :D

IF YOU HAVE CONNECTION PROBLEMS DO THE FOLLOWING: You can try to download the kernel http://atrpms.net/dist/fc3/kernel/ burn in a cd, copy to hard drive and install it and do same for madwifi drivers and make sure you are VERY careful in the kernel you choose. OR if you have a pen flash drive save it there and transfer it to you fc3 box! Also note the that drivers are supported from kernel 2.6.10-737 and higher. For more repos read this how-to. (http://www.fedoraforum.org/forum/showthread.php?t=27279) superbner thanks for telling me which drivers to use!

If you encounter any issues with AR5212 see it this helps: http://linux.seindal.dk/item23.html

ALSO same concent applies to INTEL PRO wireless (http://atrpms.net/dist/fc3/ipw2200/) as you can see. Which uses the ipw2200 wireless linux drivers.

Atheros.com (http://www.atheros.com/)

raffe
27th February 2005, 11:37 PM
Hi!

I have a D-Link DWL-G650, an athros compatible i think.

I did this:
[root@localhost ~]# uname -r
2.6.10-1.766_FC3

I check for the file name here: http://atrpms.net/dist/fc3/madwifi/

So I try:
[root@localhost ~]# yum install madwifi-kmdl-2.6.10-1.766_FC3-0.9.4.12-15.rhfc3.at.i686.rpm
Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
updates-re: ################################################## 722/722
No Match for argument madwifi-kmdl-2.6.10-1.766_FC3-0.9.4.12-15.rhfc3.at.i686.rpm
Nothing to do

I try:
[root@localhost ~]# yum install madwifi-kmdl-2.6.10-1.766_FC3-0.9.4.12-15.rhfc3.at.i686
Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
updates-re: ################################################## 722/722
No Match for argument madwifi-kmdl-2.6.10-1.766_FC3-0.9.4.12-15.rhfc3.at.i686
Nothing to do

I try:
[root@localhost ~]# yum install madwifi
Setting up Install Process
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: updates-released
http://fedora-mirror.dkuug.dk/linux/core/updates/3/i386/repodata/repomd.xml: [Errno 4] IOError: HTTP Error 404: Not Found
Trying other mirror.
repomd.xml 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
updates-re: ################################################## 722/722
No Match for argument madwifi
Nothing to do

What do I do wrong, have I missed something? :confused:

imdeemvp
27th February 2005, 11:43 PM
Are you using atrmps as a repository? if not just add it to your repos. First open terminal become root and run:
gedit /etc/yum.repos.d/atrpms.repoand add this lines
[atrpms-stable]
name=ATrpms for Fedora Core $releasever stable
baseurl=http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable
enabled=1
gpgcheck=1and import the key: rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms

Or here is another SOLUTION if you dont have repos setup: In your user home directory create folder and name it madwifi and download each package needed and install from terminal. Open terminal, become root and:

[imdeemvp@myfc3 ~]$ cd madwifi/
[imdeemvp@myfc3 madwifi]$ su
Password:
[root@myfc3 madwifi]# rpm -ivh * <<-- this command will install everything at the same time.

raffe
28th February 2005, 10:49 PM
Hi!

I did "gedit /etc/yum.repos.d/atrpms.repo", put in your magic text and imported the key, and after that the yum things worked well. Thanks :)

Now you would think that I'm happy and networking with my wireless card, but don't know how to "start" it. You probably understand by now that I'm new to Linux :rolleyes: , but I really though I could do this. I have tested this (from http://www.fedoraforum.org/forum/showthread.php?t=3452):
4) edit your /etc/modprobe.conf, add the line "alias ath0 ath_pci"
5) create a file named ifcfg-ath0 in /etc/sysconfig/network-scripts
STARTMODE=hotplug
DEVICE=ath0
BOOTPROTO=dhcp
WIRELESS=yes
MODE=Managed
ESSID=any
IPV6INIT=no
onBOOT=yes
USERCTL=no
PEERDNS=no
6) ifconfig ath0 up
atho: unknown interface: No such device
7) ifup ath0
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
ath_pci device ath0 does not seem to be present, delaying initialization.

I also try this:
service network restart
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Shutting down interface eth0: [ OK ]
Shutting down loopback interface: [ OK ]
Setting network parameters: [ OK ]
Bringing up loopback interface: [ OK ]
Bringing up interface eth0: [ OK ]

How do I get ath0 to wake up?

imdeemvp
1st March 2005, 01:09 AM
Go to system tools> internet connection wizard >wireless and set it up...

raffe
1st March 2005, 08:00 AM
When I go to "system tools> internet connection wizard >wireless" I can't find "Atheros" or "Madwifi" in the drivers selection (even if I did I'm not sure what to write in the textboxes).

When I boot the computer it says it have found new hardware. Is that a good way to go?

imdeemvp
1st March 2005, 11:10 AM
Yes, and select that one that says Do Nothing (i believe) but it should be that one that says you will no be prompted at boot anymore. If your drivers were installed properly it should show under the wizard.

raffe
1st March 2005, 09:34 PM
Sorry, here again... Hmm, don't see the athros in the "system tools> internet connection wizard >wireless". I have tried to "ignore", "do nothing" and "configure" at boot. The last give me an eth1 that don't work at all (can't activate).

I looked here: http://madwifiwiki.thewebhost.de/wiki/MadwifiConceptronicC54COnRedHat9 and tested the "tail -f /var/log/messages". When I take out the D-link G650 I get nothing at all. When I put it in I get:
Mar 1 21:13:21 localhost kernel: PCI: Enabling device 0000:0b:00.0 (0000 -> 0002)
Mar 1 21:13:21 localhost kernel: ACPI: PCI interrupt 0000:0b:00.0[A]: no GSI - using IRQ 0
Mar 1 21:13:21 localhost kernel: ath%d: request_irq failed

On the same site I can read "RedHat 8.0 with D-Link DWL-G650 Rev C --2004/02/01 07:54 CET This worked perfectly for my D-Link DWL-G650 Rev C 168c:0013 (rev 01) on RedHat". It's almost the same that I have, but I have H/W Ver.:C2.

So I seem to have two problems:
1. The madwifi drivers don't show up
2. The card can't get a irq

imdeemvp
1st March 2005, 11:27 PM
The last give me an eth1 that don't work at all (can't activate).
I think you are doing something wrong....eth1 is for a regular nic and ath0 should be for your wireless re read the how to and reinstall drivers. Why dont you start a thread....

raffe
2nd March 2005, 08:10 AM
Hi! OK, I will try to reinstall. Some last questions:

1. How do I "uninstall" the automatically detected hardware (eth1 that don't work), so I can try this all from the beginning? By the way, I now remember to write that when It was detected at boot and I selected "configure" it sayd "atheros communications" (or something similar).

2. When I replyed to this howto, I directly thought "ow, I'm so stupid, nowbody will reply me here, I should have started a thread in the normal forums ;) ", so I started a thread in "Laptos" http://www.fedoraforum.org/forum/forumdisplay.php?f=11 There I have no replys at all. You are the only one who have tried to help me. Is there a better sub forum for this?

Sorry for bothering you :p

dvdz
4th May 2005, 12:17 AM
i get the exact same errors on a toshiba satellite a75-s231 laptop. I have a different network card but the madwifi had my chipset browser...ANy way same exact thing, doesnt show up in the internet setup....Any ideas/alternatives?

oshman
4th May 2005, 02:56 AM
No Atheros cards listed in internet setup. What to do?

imdeemvp
4th May 2005, 03:10 AM
No Atheros cards listed in internet setup. What to do?
You need to specify the exact card you are using....atheros is the chipset not the card.

raffe
4th May 2005, 06:58 AM
i get the exact same errors on a toshiba satellite a75-s231 laptop. I have a different network card but the madwifi had my chipset browser...ANy way same exact thing, doesnt show up in the internet setup....Any ideas/alternatives?

Hi dvdz!

I had two problems:
1. ACPI stopped my card from starting up. See here http://www.fedoraforum.org/forum/showthread.php?t=44954 how "I" (others did the real solving ;) ) solved it.

2. The card had conflicts with io-ports and/or io-memory. See here http://forums.fedoraforum.org/showthread.php?t=47596 how "I" solved that one.

/Raffe

imdeemvp
4th May 2005, 07:14 AM
Awesome raffe!.....my installation was hassle free so I did not have to do a lot of research as you did. But great info you have provided for those with a toshiba lopbox.

dvdz
4th May 2005, 10:21 PM
ah raffe thank you very much for the reply...i'll be trying everything now!

oshman
5th May 2005, 12:17 AM
I always assumed I was using a card made by Atheros, but apparently not. How exactly do I find the card maker: I tried this so far and see 2 ethernet controllers.


[root@localhost ~]# /sbin/lspci 00:00.0 Host bridge: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] (re v 02)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:03.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:04.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controlle r Audio Device (rev 02)
00:06.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:0c.0 CardBus bridge: O2 Micro, Inc. OZ711M3 SmartCardBus MultiMediaBay Contro ller
00:0c.1 CardBus bridge: O2 Micro, Inc. OZ711M3 SmartCardBus MultiMediaBay Contro ller
00:0c.2 System peripheral: O2 Micro, Inc. OZ711Mx MultiMediaBay Accelerator
00:0c.3 CardBus bridge: O2 Micro, Inc. OZ711M3 SmartCardBus MultiMediaBay Contro ller
00:0c.4 CardBus bridge: O2 Micro, Inc. OZ711M3 SmartCardBus MultiMediaBay Contro ller
00:0e.0 FireWire (IEEE 1394): NEC Corporation IEEE 1394 Host Controller (rev 01)
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139 C+ (rev 10)
00:12.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC ( rev 01)
00:13.0 USB Controller: NEC Corporation USB (rev 43)
00:13.1 USB Controller: NEC Corporation USB (rev 43)
00:13.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350 M

imdeemvp
5th May 2005, 04:47 AM
According to the madwifi description: "A linux device driver for Atheros chipsets (ar5210, ar5211, ar5212)" your device is supported. This is part of your posting:

00:12.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC ( rev 01)I am wondering you are doing the correct kernel version? :confused:

BTW, did you buy the card or it is intergrated in your lapbox?

oshman
5th May 2005, 07:57 PM
dvdz,

were you able to get to on. I followed the same instructions you did and ran into the same problems. I then ran a complete update from Redhat Network, tried Systems Tool -> Internet Config Wizards, and my card was there. Everythings a go now.

dvdz
5th May 2005, 09:58 PM
NO, still couldnt get it to work....what kernel are you running, cause i'm running something with a 14, but it seems every1 has it with the 10 (i'm too lazy to check the exact name)


Maybe i'm doing something wrong with the booting up, does he mean add acpi=off anywhere in the grub.conf? or is it inline with the kernel? can u show me your grub menu....thanks Oshman

-dvdzzzzz

dvdz
5th May 2005, 10:18 PM
i have the ar5211 so it should be just about the same....

oshman
5th May 2005, 10:44 PM
Yo,

Your whole problem could be stemming from the wrong madwifi drivers. You gotta make sure that the drivers correspond to a) your kernel, and b)your chip set. If you have an Atheros card, like me, you probably have the 5212 chipset.


# /sbin/lspci

On the driver website here (http://atrpms.net/dist/fc3/madwifi/ ) - I found 3 drivers sets which were compatible with my kernel. I have the one of the latest ones, and you can find out with “uname -a”. I used madwifi-kmdl-2.6.11-1.14_FC3-0.9.4.12-16.rhfc3.at.i686.rpm. You can intall it from "yum install"


[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.11-1.14_FC3 #1 Thu Apr 7 19:23:49 EDT 2005 i686 i686 i386 GNU/Linux

Make sure you edit "atrpms.repo", and download the gpg key. its simple with the commands spelled out bu imdeemvp. Thats all I did, and then my card was detected.

I am no linux guru, but I know that knowing your kernel is very important. Check your kernel and then try repeating the process that imdeemvp layed out.

Also, grub.conf is just for the boot up menu, edit it only if you need to alter boot options – such as adding another OS. Don't mess with it for this task.

Again, double check the drivers, follow the steps, and let me know how it goes.

I'll help anyway I can.

Peace

dvdz
5th May 2005, 11:52 PM
no ive triple checked and still no luck....i wanna Try with the acpi thing but idk WHERE to put it in the grub.conf....thanks in advance!


DvDzzzzz

oshman
6th May 2005, 12:19 AM
dvdz,

i just read the messages between raffe and imdeemvp on "acpi-off". it is something i am unfamiliar with. I guess pressing "e" during boot is kinda like usnig safe mode or setting up bios in windows. You got me reading on "acpi" and I seems that it could work. Once you set it to off see if you can configure the card during boot or system tools.

sorry i couldn't be more help

dvdz
6th May 2005, 02:04 AM
ok got acpi=off working...but it still wont work!
This is what i get in the hardware browser...:


Atheros Communications, Inc. AR5212 802.11abg NIC
Manufacturer: Unknown
Driver:ath_pci
Device: /dev/eth1

Apparently its still thinking it should be eth1 even though it should be ath....

This is what i get with iwconfig


Lo no wireless extensions
Eth0 no wireless extensions
Sit0 no wireless extensions

I'm lost!!!!!!!!! SOME1 HELP MEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE EEEEE

imdeemvp
6th May 2005, 04:28 AM
dvdz, what is your kernel version? open terminal and run:
uname -r and post it.

raffe
6th May 2005, 08:10 AM
no ive triple checked and still no luck....i wanna Try with the acpi thing but idk WHERE to put it in the grub.conf....thanks in advance!


DvDzzzzz
Sorry for late answer on this question. Don't know if it helps any more, but I have now answered you here http://www.fedoraforum.org/forum/showthread.php?p=252863#post252863 Sorry I'm so late :)

dvdz
7th May 2005, 05:03 AM
Its ok, i'm starting with a fresh install, i'll post back if it works

imdeemvp
7th May 2005, 07:14 AM
Its ok, i'm starting with a fresh install, i'll post back if it works
I did and installation on second laptop using same card and please note there is an update to parent post. This is what I recommend to do, plug your net cable to your laptop and create a regular connection, open terminal, run:
up2date and update of the latest kernel ONLY. Reboot lapbox and retry the tutorial because it worked great for me. Once you install the drivers reboot pc again and let fedora configure it.

dvdz
7th May 2005, 07:30 PM
I did and installation on second laptop using same card and please note there is an update to parent post. This is what I recommend to do, plug your net cable to your laptop and create a regular connection, open terminal, run:
up2date and update of the latest kernel ONLY. Reboot lapbox and retry the tutorial because it worked great for me. Once you install the drivers reboot pc again and let fedora configure it.


What do u mean update of the latest kernel ONLY....I've reformated, and ran yum to update, now i'm running on the kernel 2.6.11-1.14_FC3smp ........but everything is updated not just the kernel? is that what u meant? or do i have to reformat and do something else?

imdeemvp
7th May 2005, 08:42 PM
running on the kernel 2.6.11-1.14_FC3smp Ok now just run:
yum install madwifiand make sure both packages end with smp because appears you have hyperthreading.

dvdz
7th May 2005, 08:44 PM
Ok now just run:
yum install madwifiand make sure both packages end with smp because appears you have hyperthreading.


Yeah my computer has hyperthreading (pentium 4 3.33 Ghz)

So now i just have to follow your steps from the beginning right?

imdeemvp
7th May 2005, 08:52 PM
Yes....see my post of the results after I ran the command? Do same and when done .....please reboot your pc and let fedora configure your atheros but when prompted to enter dns and gateway just hit BACK and done....then try to setup you wireless from internet configuration tool.

dvdz
7th May 2005, 09:02 PM
like u said, the server is down, so i'll post back when its back up


[root@localhost ~]# rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms
error: http://atrpms.net/RPM-GPG-KEY.atrpms: import read failed.

dvdz
10th May 2005, 04:00 AM
Does this matter, i just found out that its an Atheros® Wireless LAN (802.11b/g) supporting Atheros SuperG™ technology, does this mean it wont work (because i think its for a/b/g?)

dvdz
10th May 2005, 10:11 PM
this has gone bad....


[atrpms-stable]
name=ATrpms for Fedora Core $releasever stable
baseurl=http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable
enabled=1
gpgcheck=1

Now i always get the bad repository file ///etc/yum.repos.d/atrpms.repo Skipping
Setting up Install Process
Segging up Repos

And it wont work......i think i'll just download it from the site?

dvdz
11th May 2005, 04:01 AM
i did it and it still hasn't worked...same problem, always coming up as unknown Wireless card, (and its never in the other things...)even when i edit the boot to acpi=off...I'm totally at a loss, i'm willing for any1 with a lot of experience *cough* imdeemvp *cough* to remotely control my computer just so you can an idea of whats wrong...please help

-DvDzzz

dvdz
12th May 2005, 02:57 AM
any1 ??????????????????????????????????????

imdeemvp
12th May 2005, 08:53 AM
any1 ??????????????????????????????????????
I was out for a couple of days...now open terminal and post your /sbin/lspci

dvdz
12th May 2005, 09:13 PM
Ok here you go, i dont think this matters but i forgot to tell you also that sound doesn't work...but i dont care too much about that, all i really want is for me to have wireless internet...Anyways here you go


[root@localhost ~]# /sbin/lspci
00:00.0 Host bridge: ATI Technologies Inc RS300 Host Bridge (rev 02)
00:01.0 PCI bridge: ATI Technologies Inc Radeon 9100 IGP AGP Bridge
00:13.0 USB Controller: ATI Technologies Inc OHCI USB Controller #1 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc OHCI USB Controller #2 (rev 01)
00:13.2 USB Controller: ATI Technologies Inc EHCI USB Controller (rev 01)
00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
00:14.1 IDE interface: ATI Technologies Inc: Unknown device 4349
00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 434c
00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4342
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
00:14.6 Modem: ATI Technologies Inc IXP AC'97 Modem (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc RS300M AGP [Radeon Mobility 9100IGP]
02:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
02:02.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
02:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:04.0 CardBus bridge: ENE Technology Inc CB-710/2/4 Cardbus Controller
02:04.1 FLASH memory: ENE Technology Inc: Unknown device 0530
02:04.2 Class 0805: ENE Technology Inc: Unknown device 0550
02:04.3 FLASH memory: ENE Technology Inc: Unknown device 0520

imdeemvp
13th May 2005, 09:44 AM
02:02.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)That's your driver my man....now when setting the wireless connection, does it show any atheros device what so ever?

Is this device enabled in your bios? and does it work properly in windows?

BTW, when I compare your devices to oshman's both of you have similiar devices.....so you are missing the one last click to make it work.

dvdz
13th May 2005, 09:11 PM
That's your driver my man....now when setting the wireless connection, does it show any atheros device what so ever?

Is this device enabled in your bios? and does it work properly in windows?

BTW, when I compare your devices to oshman's both of you have similiar devices.....so you are missing the one last click to make it work.

Well when i click new internet connection and choose wireless it comes up as unknown card, then i click next and still no atheros there, also, it works properly on windows (xp home)
, i know it works find because i am dual booting. Anyways, i mean i think its enabled in my bios considering it works flawlessly when i boot into windows.

Also in the hardware browser it says its driver is like eth1, shouldnt it be ath? i think it is still not working?

If u want to remote connect to make sure everything is set up right just pm i'd be very gr8ful

-Dvdzzzz

imdeemvp
14th May 2005, 07:08 PM
Also in the hardware browser it says its driver is like eth1, shouldnt it be ath? i think it is still not working?I THINK I GOT IT.....dont use the wireless connection wizzard use the ethernet conneciton wizzard since your card is integrated so yes it should be eth1 because your regular nic is under eth0. So try setting up your connection using the ethernet settings......instead of wireless connection.

dvdz
14th May 2005, 09:34 PM
I THINK I GOT IT.....dont use the wireless connection wizzard use the ethernet conneciton wizzard since your card is integrated so yes it should be eth1 because your regular nic is under eth0. So try setting up your connection using the ethernet settings......instead of wireless connection.

imdeemvp, ur a F*kin genius, my card finally comes up!, but unfortunitly it wont work, i'm getting this error when i click activate...


Cannot Activate Network Device eth1!
3C501 device eth1 does not seem to be present, delaying initialization

Come on i can taste it, we're so close i can't believe it finally came up

-dvdzzzzz

imdeemvp
15th May 2005, 08:47 AM
Are you using acpi=off in the kernel line? if you remove it and see what happens...

dvdz
15th May 2005, 06:08 PM
no i'm not using it in my kernel line, i've tried with it and still no luck...

imdeemvp
16th May 2005, 06:45 AM
Ok, I did some search and this may help according to the troubleshooting guide:

On RedHat I get 'SIOCGIFFLAGS: No such device'.

A: This entry was sent in by Stuart Higgs.

On Redhat, KUDZU detects the card, and makes it the next available eth (in my case, it was eth1). On network start, eth0 comes up, but you get ‘SIOCGIFFLAGS: No such device’ for the wireless card. The solution I worked out was:

* Edit the /etc/modules.conf file

o Change ''eth1'' to ''ath0'' (for the alias ''eth1 ath_pci'').
* Rename the file ''/etc/sysconfig/network-scripts/ifcfg-eth1'' to ''/etc/sysconfig/network-scripts/ifcfg-ath0''.
* And then execute:
* ''/etc/rc.d/init.d/network restart''
See if the suggestion works for you.

dvdz
16th May 2005, 11:29 PM
according to that, there is no file or directory /etc/modules.conf... do i make one?

imdeemvp
17th May 2005, 03:16 AM
according to that, there is no file or directory /etc/modules.conf... do i make one?
You can use gedit and add those lines and save it as modules.conf

dvdz
17th May 2005, 09:53 PM
ok thanks trying it now...

dvdz
17th May 2005, 11:03 PM
Nope it didnt work...maybe i did it wrong but first off there was nothing in the moduals conf. so all i added was that line, secound, all it did was change the name, not the device and it still said the same thing

hnefatafl
19th May 2005, 06:43 PM
Greetings all. I've been reading this thread and following along, but I'm still having one little stupid problem. I've got the D-Link DWL-A660 on my IBM A20m laptop. I've loaded all the needed software - properly, to the best of my knowledge. I can connect to any open, un-restricted AP and network. When I scan for networks (iwlist ath0 scan) I see my office or my home networks, both of which are secure and require keys. But no matter what I try, I CANNOT connect to either of them. It's driving me nuts. I've set the essid manually, I've set the required key, but so far... nuthin. What am I missing? What should I post here to help any kind, intelligent, helpful person out there help me?

Thanks

icepick
14th June 2005, 06:36 AM
i did the whole yum install with the madwifi sorce and it installed but it doesnt show up on the driver list then i got the rpm from the site and installed that and it didnt show up on the list either. you know the diver list on the internet config page

imdeemvp
14th June 2005, 10:00 AM
i did the whole yum install with the madwifi sorce and it installed but it doesnt show up on the driver list then i got the rpm from the site and installed that and it didnt show up on the list either. you know the diver list on the internet config page
Do you have internal or external card....if external make sure your card is inserted but I recommend you to unplug it before installing drivers. Just like its done in windows.

icepick
14th June 2005, 06:59 PM
i have the mini pci in my toshiba lapy m35x-s114

jjmarro
14th June 2005, 07:17 PM
I'm getting an error about a bad repository file. I followed the information above, and hee's the output:

[jjmarro@localhost ~]$ su -
\Password:
[root@localhost ~]# yum install madwifi-kmdl-2.6.11-1.27_FC3-0.9.4.12-16.rhfc3.at.rpm
Error: Bad repository file ///etc/yum.repos.d/atrpms.repo. Skipping
Setting up Install Process
Setting up Repos
core 100% |=========================| 951 B 00:00
dag 100% |=========================| 1.1 kB 00:00
base 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 951 B 00:00
updates-released 100% |=========================| 951 B 00:00
freshrpms 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
core : ################################################## 2622/2622
dag : ################################################## 2846/2846
base : ################################################## 2622/2622
updates : ################################################## 608/608
updates-re: ################################################## 829/829
freshrpms : ################################################## 291/291
Parsing package install arguments
No Match for argument: madwifi-kmdl-2.6.11-1.27_FC3-0.9.4.12-16.rhfc3.at.rpm
Nothing to do
[root@localhost ~]#

What does this error mean, and how can I repair it?

Thanks!

imdeemvp
15th June 2005, 10:44 PM
Are you using the atrmps repo as I indicate?

dvdz
16th June 2005, 01:02 AM
So any ideas about the internal card, i'm still bummed.....

imdeemvp
16th June 2005, 02:13 AM
So any ideas about the internal card, i'm still bummed.....
I know that you have to edit a file that contains eth0 AND change it to ath0 which wireless and I read the info a few days ago but did not save link. Maybe you should start a thread in how to change the eth0 to ath0. I will myself.

jjmarro
16th June 2005, 07:45 PM
Are you using the atrmps repo as I indicate?

I followed your howto word-for-word (well..copy-n-paste). I get that bad repo now whenever I run yum update. Any ideas?

Thanks!

dvdz
18th June 2005, 09:39 PM
OMG, it works now, since the new kernel it now recognizes my adapter as wireless! But when activating i get the error:


Error for wireless request "Set Mode" (8B06)
SET Failed on device ath0 ; Invalid argument

Determining IP information for ath0...

Then it goes on pinging and stuff and gets "bad packets". But i dont get it, i have a linksys router, i don't know how to connect to it, i also have a WEP key, and i dont know where to put it.

Eroberer
19th June 2005, 12:22 AM
Thanks imdeem, your installation instructions worked WITH ONE MAJOR DIFFERENCE...

After getting the long print out telling me that the "yum install" was "Complete!" I had to reboot. The system didn't automatically pop up with a hardware configuration window like in Windows XP, but when I went to the "Internet Connection Wizard" (under Applications-->System Tools), it shows up with an "Atheros --something something..." card, and setup fine. Before any reboot, following your original instructions, I could open the connection wizard and no Atheros card was shown. Your installation instructions were a helluva lot easier than anything else that I've seen, so THANK YOU! =)

I have:
- Fedora Core 4 (fresh installation, I didn't even download the kernel source like in other instructions for wireless setup that I've seen.
- D-Link DWL-G650

Other instructions that I've seen require you to download some "cvs" program and to get the kernel source and build it from the RPM, but this was much easier. THANKS AGAIN!

EDIT NOTE::
Upon a second look, I modified the file at /etc/sysconfig/network-scripts/ifcfg-ath0
I changed "ONBOOT" to yes, "RATE" to auto, and I changed the CHANNEL to 6 (b/c that's what my wireless router says. I'm not sure how much of this is necessary, but I went ahead and changed it anyway. Right now I'm still curious about when I get back to my University's wireless place, and I assume I'll have to change the ESSID or and the wireless key (which I shouldn't even know, but I do). It doesn't look like any part of Linux allows a second wireless connection.

Now if I can only get Kismet up and running...

imdeemvp
19th June 2005, 01:56 AM
I've installed it few times I dont know why some users have such a hard time......sometimes it does require a reboot. But go figure....

dvdz
20th June 2005, 11:19 PM
OMG, it works now, since the new kernel it now recognizes my adapter as wireless! But when activating i get the error:


Error for wireless request "Set Mode" (8B06)
SET Failed on device ath0 ; Invalid argument

Determining IP information for ath0...

Then it goes on pinging and stuff and gets "bad packets". But i dont get it, i have a linksys router, i don't know how to connect to it, i also have a WEP key, and i dont know where to put it.


Can you answer this?

Jay Wieczorek
11th July 2005, 10:35 PM
Hello, i am new to linux as most are. I dont understand the key thing. do u just put "rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms" into the command line or is more involved?

here are the erros i am having

[root@dhcp-101-155 ~]# madwifi-kmdl-2.6.11-1.35_FC3.i686 0:0.9.4.12-16.rhfc3.at
bash: madwifi-kmdl-2.6.11-1.35_FC3.i686: command not found
[root@dhcp-101-155 ~]# yum install madwifi-kmdl-2.6.11-1.35_FC3.i686 0:0.9.4.12-16.rhfc3.at
Error: Bad repository file ///etc/yum.repos.d/atrpms.repo. Skipping
Setting up Install Process
Setting up Repos
base 100% |=========================| 1.1 kB 00:00
updates-released 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
primary.xml.gz 100% |=========================| 340 kB 00:00
MD Read : ################################################## 879/879
updates-re: ################################################## 879/879
Parsing package install arguments
No Match for argument: madwifi-kmdl-2.6.11-1.35_FC3.i686
No Match for argument: 0:0.9.4.12-16.rhfc3.at
Nothing to do
[root@dhcp-101-155 ~]#

and


[root@dhcp-101-155 ~]# yum install madwifi Error: Bad repository file ///etc/yum.repos.d/atrpms.repo. Skipping
Setting up Install Process
Setting up Repos
base 100% |=========================| 1.1 kB 00:00
updates-released 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
primary.xml.gz 100% |=========================| 341 kB 00:08
MD Read : ################################################## 879/879
updates-re: ################################################## 879/879
Parsing package install arguments
No Match for argument: madwifi
Nothing to do
[root@dhcp-101-155 ~]#


i also think that one of the problems could be coming from a broken link. in the magic text:

http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable

imdeemvp
12th July 2005, 09:40 AM
Open the terminal, become root (type: su + roots pass) and copy the key to the terminal and hit enter and done....

Jay Wieczorek
12th July 2005, 05:51 PM
i am running fc3 2.6.11-1.35_FC3
ok, i got the key to work. bu i am still having bad rpm problems. my card is ath0.

[jay@localhost ~]$ yum install madwifi
Error: Bad repository file ///etc/yum.repos.d/atrpms.repo. Skipping
You need to be root to perform this command.
[jay@localhost ~]$ su root
Password:
[root@localhost jay]# yum install madwifi
Error: Bad repository file ///etc/yum.repos.d/atrpms.repo. Skipping
Setting up Install Process
Setting up Repos
base 100% |=========================| 1.1 kB 00:00
updates-released 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
base : ################################################## 2622/2622
primary.xml.gz 100% |=========================| 342 kB 00:23
MD Read : ################################################## 881/881
updates-re: ################################################## 881/881
Parsing package install arguments
No Match for argument: madwifi
Nothing to do

i check out the url of the repo file and it is a 404. please make sure for me beause i am a noob lol.

thanks

Jay Wieczorek
12th July 2005, 07:33 PM
bloody hell! i got the rpm file to work. it is now installed. the card fails to connect. i have tried dhcp and static. in dhcp it just craps out and says it can't get it. when in static the lights blink together. in windows that means it is connected, but does it mean the same thing in linux? it can't get to the internet and i do not know if it is even on the network. bash does nto reconize iwconfig. HELP ME PLEASE AAAAAAAAAAAAAAAAAA.

thanks for the help

imdeemvp
12th July 2005, 08:22 PM
Did you run the internet connection wizard? and select >wireless connection ....

Jay Wieczorek
12th July 2005, 09:03 PM
yes i did run the internet connection wizard

spiritofcat
22nd July 2005, 02:30 AM
Thanks for the info, it worked! :)

used2
6th September 2005, 12:06 AM
I would have my own lil sweet quick howto for atheros + wpa_supplicant but I am having one problem that I see a bug registered for at redhat https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=154348 kinda


i installed madwifi via yum atrpms and also wpa_supplicant from the same place - its up and running fine - the only problem is when I tried to bring wpa_supplicant down the whole system crashes- completely non-responsive

I haven't needed to bring the supplicant down but was just testing ifup ath0 and ifdown ath0 with no luck

as per the bug wpa_cli terminate works great to bring the interface down but when trying to bring it back up it crashes the server again when using /usr/sbin/wpa_supplicant

I didnt install madwifi or wpa_supplicant manually and maybe I should but so far I dont need to if I can get around this crash problem.

Logs aren't showing anything prior to the crash either. :(

used2
6th September 2005, 12:42 AM
im gonna email atrpms i think the config interface flag wasn't set in their build

im gonna just do it all myself so it will work

ulva
7th September 2005, 01:15 AM
Seems to me I use a similar card as the original poster's, except mine is for stationary pc and is pci :) Card is Airlink101 model AWLH4030 using the Atheros AR5212 chipset, on a FC 4 kernel 2.6.12.1-1447

I got it installed just fine (mostly) and I connect without problems when I start up.

But my problem is, this is a Super-G wireless card, situated about 5 feet from the access point (which is also an Airlink Super-G Accesspoint). In XP it connects with Very Good to Excellent quality and 108mbit transfer rate, in Linux it maxes at 36Mb/sec and I was down to Poor signal quality certain times, looking at the kwifimanager software that came with the drivers.


ath0 IEEE 802.11g ESSID:"xxxxxx" Nickname:"xxxxx"
Mode:Managed Frequency:2.437 GHz Access Point: xx:xx:xx:xx:xx:xx
Bit Rate:36 Mb/s Tx-Power:50 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:xxxxxx Security mode:restricted
Power Management:off
Link Quality=10/94 Signal level=-85 dBm Noise level=-95 dBm
Rx invalid nwid:12964 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
Removed the private/local names etc. with the xxxx's so they are in fact present.


Relevant settings in ifcfg-ath0

ONBOOT=yes
TYPE=Wireless
DEVICE=ath0
BOOTPROTO=dhcp
ESSID=xxxxxx
CHANNEL=6
MODE=Managed
RATE=Auto
WIRELESS_CARD_MODE=3
WIRELESS_TURBO_MODE=0
These last WIRELESS settings are not being complained about at all though, and it was only put there to try and make it work better. The Access point is set to do Super-G no turbo, and it works great in Windows overall, on three different computers. When opening the kwifimanager window, it shows a speed bar with max 108mbit on it, (well shows half way is 54mbit) so it seems it should be able to do 108 just fine, but that could just be a visual thing.

On a sidenote, if I try to restart my network, it will freeze the entire system entirely, to the point where I have to hit reset button uponloading the ath0 device.


[root@mindbender ~]# rpm -qa madwifi*
madwifi-kmdl-2.6.12-1.1447_FC4-0.9.4.12-16.rhfc4.at
madwifi-0.9.4.12-16.rhfc4.at

Was installed along with the upgraded kernel today via yum through atrpm.

I also tried to use NetworkManager with little to no success. It installed just fine but the service was working very weird, by being slow to load, fail to stop and made entire X loading slow in beginning. Not to mention I never was able to make NetworkManagerInfo work, nothing ever showed up on taskbar. Figured that it looked very nice and may be able to make it easier to solve for me but no go on that.

Tried to locate info on how to get 108mbit speed which I found basically nothing, same as problems with NetworkManager.

Anyhow thanks for great guide, made it so much easier to get it installed, and thanks for any possible suggestions with my speed problem :-)

--
-Marthe

imdeemvp
8th September 2005, 08:51 AM
Does it work fine in windoz? I tweaked the router settings to get the best connection possible. I use a belking 125 super G and can be as far as 15 feet away and get a good signal.

slayer548
9th September 2005, 06:54 AM
Awesome guide. I have a DWL-G520, and I've not been able to get ndiswrapper to work. I installed according to the guide and the card showed up in the Network Configurator. I can activate it and see my network on KWiFiManager no problem. However, I can't get internet access through it. When I plug a hardline into my ethernet card it works no problem, but if I deactivate eth0 and leave ath0 up Firefox tells me the connection was refused. Windows and Mac people can get on right next to me with no problem at all, so I don't think it is a router issue. Anybody have any ideas?

imdeemvp
9th September 2005, 08:03 AM
Awesome guide. I have a DWL-G520, and I've not been able to get ndiswrapper to work. I installed according to the guide and the card showed up in the Network Configurator. I can activate it and see my network on KWiFiManager no problem. However, I can't get internet access through it. When I plug a hardline into my ethernet card it works no problem, but if I deactivate eth0 and leave ath0 up Firefox tells me the connection was refused. Windows and Mac people can get on right next to me with no problem at all, so I don't think it is a router issue. Anybody have any ideas?
Check your settings..... cat /etc/sysconfig/network-scripts/ifcfg-ath0 make sure the are semiliar to mine except for the ESSID

ulva
9th September 2005, 06:42 PM
Works great in windows, connects nicely at 108mbit and no obvious noticably speed reduction. It's just in Linux it decides to stop at 36mbit.

Thanks,

--
-Marthe

used2
10th September 2005, 12:08 PM
this thing is a real pain
madwifi with the awlh4030 just will not work with wpa_supplicant
It will connect and work fine until the key timesout then it is dead
I once had it working for about 5 minutes in Ubuntu but that's about it. I have to go ndiswrapper and wpa_supp in FC now.

used2
10th September 2005, 12:10 PM
Works great in windows, connects nicely at 108mbit and no obvious noticably speed reduction. It's just in Linux it decides to stop at 36mbit.

Thanks,

--
-Marthe
did u try setting the rate in your interfaces file? I do that to make sure it stays at 54M otherwise I will get that 36 or worse setting. I don't have a super g AP though so I can't get 108M.

imdeemvp
10th September 2005, 09:10 PM
Works great in windows, connects nicely at 108mbit and no obvious noticably speed reduction. It's just in Linux it decides to stop at 36mbit.

Thanks,

--
-Marthe
Set the RATE to auto.

dannyjr088
11th September 2005, 06:09 AM
i did what you said madwifi downloaded and installed with no errors yet i still dont have a ath0 device

imdeemvp
11th September 2005, 07:25 AM
i did what you said madwifi downloaded and installed with no errors yet i still dont have a ath0 device
Do you have integrated or exteranal device? can you post your /sbin/lspci ?

TxnerT
12th September 2005, 12:05 AM
i have the dlink g650 and ive done all of the above explained for this card
it worked well when intalled then i booted and its not working at all/
whats wrong?
im using vmware for FC4

dannyjr088
12th September 2005, 12:36 AM
its an internal wifi card

[root@localhost ~]# /sbin/lspci
00:00.0 Host bridge: ATI Technologies Inc R200 AGP Bridge [Mobility Radeon 7000 IGP] (rev 05)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:13.0 USB Controller: ATI Technologies Inc OHCI USB Controller #1 (rev 01)
00:13.1 USB Controller: ATI Technologies Inc OHCI USB Controller #2 (rev 01)
00:13.2 USB Controller: ATI Technologies Inc EHCI USB Controller (rev 01)
00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 18)
00:14.1 IDE interface: ATI Technologies Inc ATI Dual Channel Bus Master PCI IDE Controller
00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 434c
00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4342
00:14.5 Multimedia audio controller: ATI Technologies Inc IXP150 AC'97 Audio Controller
00:14.6 Modem: ATI Technologies Inc IXP AC'97 Modem (rev 01)
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility 7000 IGP02:04.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
02:06.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
02:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

imdeemvp
12th September 2005, 07:20 AM
Communications, Inc. AR5212 802.11abg NIC (rev 01)It has been install so use the internet configuration wizard to setup your wireless >selet wireless connection

TxnerT
12th September 2005, 07:22 AM
did you read my post indeemvp?

imdeemvp
12th September 2005, 07:29 AM
did you read my post indeemvp?
Did you tell your settings to connect during boot up? and did you make some changes in regards to your lan settings.....

if it worked before and now it does not it has to be related to the settings....

TxnerT
12th September 2005, 07:32 AM
yes i did tell to connect on reboot
and no changes on lan settings
other thing,, when it connects for a fraction of minutes when i download a big file thru linux my win connection disconnects and comes back up
why is that?

imdeemvp
12th September 2005, 07:41 AM
it could be your routers....i had a similiar issue with an airlink101 router it was cheap but game me problems now i have a belkin 125g router

Eroberer
14th September 2005, 05:32 AM
imdeemvp, once again, for about the 4th time now, your installation has worked flawlessly. Your How To should be in the hall of fame of how-to's!

imdeemvp
14th September 2005, 06:44 AM
imdeemvp, once again, for about the 4th time now, your installation has worked flawlessly. Your How To should be in the hall of fame of how-to's!
Its all about the love for fedora..... :p

hgeng
15th September 2005, 11:23 PM
My situation is similar as dannyjr088: I can see a Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01) when running lspci, but when I used Internet configuration Wizard to connect from the wireless, in the "Select Wireless Device" frame, there is a "Other Wireless Card" listed. And in "Select Ethernet Adapter" frame, the adapter drop-down doesn't have the AtherosNIC listed.

This is before I am going to install the madwifi.

My questuions are:
My current kernel version is 2.6.11-1.1369FC4-i686, do I need to upgrade before install midwifi?
In http://atrpms.net/dist/fc4/madwifi/ which rpm should I choose?
Are there step by step instruction for installing madwifi?

Thanks very much. This is the first time I am installing Fedora OS.

imdeemvp
16th September 2005, 04:21 AM
I would upgrade just the kernel and install the madwifi drivers then update the entire system.


yum upgrade kernelwhen done reboot and install madwifi
yum install madwifi

hgeng
16th September 2005, 04:59 PM
I did the upgrade of kernel and madwifi. After rebooting the card showed up and it works! Thanks a lot!

hsaybasili
14th October 2005, 11:36 AM
Is there anyone who can connect to a secure network with madwifi drivers?

For unsecure networks it works very well, but not for secure networks...

prodigal_son
8th November 2005, 08:42 PM
Thanks for the walk through.. I encountered a problem that seems to be based around toshiba's

Followed your instructions, everything worked flawlessly, I have the intergrated wireless card, it appeared in the wireless section, and i was surfing the net within minutes of following your tutorial.

rebooted a few times, no problem..

I installed ntfs support for my external hard drive and rebooted. However now the wireless adapter is no longer in the list, I still have the driver installed, but when i click on wireless now options come up.. I tried renaming it to eth1, instead of ath0 i think i did that correctly in the config file, however it still says device not available.

I was just wondering if anyone has come across a soloution to this, seen as one or two seem to be having the same problem, If so, sorry for posting in here.. If not, can anyone give me any advice?

and im a n00b, so please be kind ;) thanks

prodigal_son
8th November 2005, 08:46 PM
Is there anyone who can connect to a secure network with madwifi drivers?

For unsecure networks it works very well, but not for secure networks...

it works perfect for secure networks, on the third screen in the wireless config utility, enter your key in the bottom box, if its hex write 0x and then your key.. You will know your key is hex if it is something like this 0ff78fee7

Wthr4d
12th February 2006, 04:22 AM
ImdeemVP- Is there a way to do this without an internet connection? my computer only has wireless connection to the internet. I am running Fedora core4 and trying to install the airlink AWLH4030 PCI card with the 2.6.15-1.1830 Kernel.

Paul

imdeemvp
16th February 2006, 08:24 AM
ImdeemVP- Is there a way to do this without an internet connection? my computer only has wireless connection to the internet. I am running Fedora core4 and trying to install the airlink AWLH4030 PCI card with the 2.6.15-1.1830 Kernel.

Paul
Can you connect an internet cable at all? from router to laptop? if no, try using a friends connection, at work, or school, or library and download the packages needed from atrpms websit. GL.

bigdogg
28th February 2006, 04:43 PM
OK I think it recognized the card :) But I am using WPA and WPA2 with TKIP and PEAP authentication. I know Intel has a nice GUI software that runs on Window$ what kind of software can I install to configure my authentication listed above with Linux :-) Any help would be much appreciated.

Thanks,
BiG

PS

Does anyone use WEP any more?

boyd98
5th March 2006, 10:04 PM
Howdy - followed your install, everything worked fine

FYI, not sure this was ever updated but the copy an paste of the atrpms repo causes the bad repository msg, there is an extra space in the top front line of the file.

Anyway, moving forward, i have been playing for a week to get this thing to work, I need to boost my link quality. Its at 20/94, but windows its a lot stronger.

let me post some config files tell me where you see a problem:


******************
iwconfig shows:
ath0 IEEE 802.11g ESSID:"xb101" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.457 GHz Access Point: xx:xx:xx:xx:xx (x'd out)
Bit Rate:36 Mb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:5555-5555-55 Security mode:restricted
Power Management:off
Link Quality=16/94 Signal level=-79 dBm Noise level=-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:8 Invalid misc:8 Missed beacon:3
*************

[root@localhost network-scripts]# cat ifcfg-ath0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=yes
USERCTL=no
PEERDNS=yes
GATEWAY=192.168.0.1
TYPE=Wireless
DEVICE=ath0
HWADDR=00:0d:88:8b:b7:5d
BOOTPROTO=none
NETMASK=255.255.255.0
DHCP_HOSTNAME=
IPADDR=192.168.0.108
DOMAIN=
ESSID=xb101
CHANNEL=10
MODE=Managed
RATE=Auto
KEY='h:xxxxxxxxx' (NOTE i set this last two parameters per another post)
IWPRIV="authmode 2" (when i manually set this iwpriv ath0 authmode 2 thats when)
(it started working)
**********************

Look how many errors this thing logs in iwconfig

ath0 Link encap:Ethernet HWaddr 00:0D:xx:xx:xx
inet addr:192.168.0.108 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20d:88ff:fe8b:b75d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:60239 errors:29339 dropped:0 overruns:0 frame:29339
TX packets:90 errors:8 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:200
RX bytes:35554731 (33.9 MiB) TX bytes:5708 (5.5 KiB)
Interrupt:10 Memory:f88c0000-f88d0000

**************

this is on fedora 4, and updated kernel to 2.6.15


TIA,

Boyd

any thoughts would be greatly appreciated

imdeemvp
6th March 2006, 04:47 AM
Try changing the MODE=Managed to MODE=Auto.

boyd98
6th March 2006, 07:47 PM
Try changing the MODE=Managed to MODE=Auto.


Something is not setup right cuz i just rebooted and its not pulling a signal at all anymore -


What i have changed- i have turned it off to when it boots so i have to manually activate ath0. Either way its not working now -

anyway

iwlist ath0 scan , shows my wireless access point although my link quality right now is 13, when i activate the card


iwconfig ath0 essid xb101 channel 10 key xxxxxxxxxx

ifconfig ath0 up


i get no connection. Any thoughts - let me know where i can provide more data, i really need to get this set up.


What is the deal with this signal


ath0 Scan completed :
Cell 01 - Address: xx:xx:xx:xx:xx
ESSID:"xb101"
Mode:Master
Frequency:2.457 GHz (Channel 10)
Quality=6/94 Signal level=-89 dBm Noise level=-95 dBm
Encryption key:on
Bit Rate:1 Mb/s
Bit Rate:2 Mb/s
Bit Rate:5 Mb/s
Bit Rate:6 Mb/s
Bit Rate:9 Mb/s
Bit Rate:11 Mb/s
Bit Rate:12 Mb/s
Bit Rate:18 Mb/s
Bit Rate:24 Mb/s
Bit Rate:36 Mb/s
Bit Rate:48 Mb/s
Bit Rate:54 Mb/s
Extra:bcn_int=100




Thx again
Boyd

boyd98
6th March 2006, 07:48 PM
Something is not setup right cuz i just rebooted and its not pulling a signal at all anymore -


Looking at my config do you have anythoughts


TIA,

Boyd


if its turned off on boot, whats is the best order to start this guy up??

Riggs
8th March 2006, 03:38 PM
Here's my situation. I just installed a clean copy of Fedora Core 5 Test 3. I followed the HOW-TO article, added the repo, did the upgrade of the kernal, ran "yum install madwifi" command, and here is what I have:

[root@localhost james]# rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms
[root@localhost james]# yum install madwifi
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
atrpms-sta: ################################# 2/3http://apt.atrpms.net/fedora/4.92/en/i386/at-stable/repodata/repomd.xml: [Errno 4] IOError: HTTP Error 404: Date: Wed, 08 Mar 2006 14:23:49 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 327
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms-stable
failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
Can anyone point me in the right direction?

boyd98
9th March 2006, 06:09 PM
Here's my situation. I just installed a clean copy of Fedora Core 5 Test 3. I followed the HOW-TO article, added the repo, did the upgrade of the kernal, ran "yum install madwifi" command, and here is what I have:

[root@localhost james]# rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms
[root@localhost james]# yum install madwifi
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
atrpms-sta: ################################# 2/3http://apt.atrpms.net/fedora/4.92/en/i386/at-stable/repodata/repomd.xml: [Errno 4] IOError: HTTP Error 404: Date: Wed, 08 Mar 2006 14:23:49 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 327
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms-stable
failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
Can anyone point me in the right direction?

first try running: yum clean all, then try again

if that fails post your atrpms.repo file

icantux
21st March 2006, 09:58 PM
Help!

Go the same error as him, tried # yum clean all , then again... got the same error:


# yum install madwifi
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core [1/4]
core 100% |=========================| 1.1 kB 00:00
updates [2/4]
updates 100% |=========================| 951 B 00:00
atrpms-stable [3/4]
http://apt.atrpms.net/fedora/5/en/i386/at-stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Tue, 21 Mar 2006 20:54:14 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 324
Connection: close
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms-stable
failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms-stable: [Errno 256] No more mirrors to try.


Here's my atrpms.repo (as found in: /etc/yum.repos.d/atrpms.repo)
**EDIT** don't use this one - it's old repo info - look post below



[atrpms-stable]
name=ATrpms for Fedora Core $releasever stable
baseurl=http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable
enabled=1
gpgcheck=1


Forgot to mention: this is on a fresh install of FC5 (just pulled it in today).
Cheers!

icantux
21st March 2006, 11:34 PM
Ah .... I see... there was a problem with the repo info given throughout these posts!!! It seems something at ATrpms has changed and no one here has bothered posting the new info.

Here is the new repo info that should reside in /etc/yum.repos.d/atrpms.repo (at least for FC5)!!


[atrpms]
name=Fedora Core $releasever - $basearch - ATrpms
baseurl=http://dl.atrpms.net/fc$releasever-$basearch/atrpms/stable
enabled=1
gpgcheck=1


Hope this helps whoever checks this thread.. :)

Cheers!

xathrasmurphy
24th March 2006, 06:33 PM
Hope this helps whoever checks this thread.. :)

Cheers!

Thanks. And I read every post to get there. :)


Mine you, I haven't test it yet. :p

Grrrlie
24th March 2006, 08:51 PM
I followed this thread, and (finaly) got my D-Link (DWL-G520) installed. I have been at this process for almost 2 weeks total. This time around, has been just since the FC5 came out. My problem is that the card sees my network (2wire 1701HG) and a Linksys (must be the neighbors) but won't connect to my 2wire. I am very new to Linux and would love any help anyone can give me. I do have this system hard wired into the 2wire and it works fine, but the 50 foot of cat5 running from up stairs to down is a masive issue.
Thanks in advance!

xathrasmurphy
24th March 2006, 09:59 PM
Is there anyone who can connect to a secure network with madwifi drivers?

For unsecure networks it works very well, but not for secure networks...

I have the same problem. Actually I have lots of problems and unless someone tells me NOW how to solve this one ...... I'm going to tell you about them. :eek:

icantux
25th March 2006, 02:10 AM
I have the same problem. Actually I have lots of problems and unless someone tells me NOW how to solve this one ...... I'm going to tell you about them. :eek:

Your first objective should be to check whether the card actually works. What steps have you taken so far to connect? Please try to connect first without encryption - and I would suggest you use the command line and not networkmanager or other wireless gui manager (those are only add-ons and don't really give you an indication that something works or not).

xathrasmurphy
25th March 2006, 09:09 AM
Thanks for that. Well this morning it's working. Perhaps it needed a reboot? Who knows? Thanks again everyone.

imdeemvp
25th March 2006, 09:38 AM
Ah .... I see... there was a problem with the repo info given throughout these posts!!! It seems something at ATrpms has changed and no one here has bothered posting the new info.

Here is the new repo info that should reside in /etc/yum.repos.d/atrpms.repo (at least for FC5)!!


[atrpms]
name=Fedora Core $releasever - $basearch - ATrpms
baseurl=http://dl.atrpms.net/fc$releasever-$basearch/atrpms/stable
enabled=1
gpgcheck=1


Hope this helps whoever checks this thread.. :)

Cheers!
Thank you for providing the correct info. I made the changes so users will not continue to encounter the error.

karlos_pr
25th March 2006, 07:32 PM
icantux can you help me with this:
Toshiba A75 S206

[root@localhost Downloads]# yum install madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0-0.9.6.0-20.rhfc5.at.i686.rpm
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core [1/3]
core 100% |=========================| 1.1 kB 00:00
extras [2/3]
extras 100% |=========================| 1.1 kB 00:00
updates [3/3]
updates 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
Parsing package install arguments
Examining madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0-0.9.6.0-20.rhfc5.at.i686.rpm: madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0 - 0.9.6.0-20.rhfc5.at.i686
Marking madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0-0.9.6.0-20.rhfc5.at.i686.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0.i686 0:0.9.6.0-20.rhfc5.at set to be updated
--> Running transaction check
--> Processing Dependency: /boot/vmlinuz-2.6.15-1.2054_FC5xen0 for package: madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0
Importing additional filelist information
--> Processing Dependency: madwifi-kmdl-2.6.15-1.2054_FC5xen0 = 0.9.6.0-20.rhfc5.at for package: madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for kernel-xen0 to pack into transaction set.
kernel-xen0-2.6.15-1.2054 100% |=========================| 261 kB 00:02
---> Package kernel-xen0.i686 0:2.6.15-1.2054_FC5 set to be installed
--> Running transaction check
--> Processing Dependency: xen for package: kernel-xen0
--> Processing Dependency: madwifi-kmdl-2.6.15-1.2054_FC5xen0 = 0.9.6.0-20.rhfc5.at for package: madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for xen to pack into transaction set.
xen-3.0.1-4.i386.rpm 100% |=========================| 77 kB 00:01
---> Package xen.i386 0:3.0.1-4 set to be updated
--> Running transaction check
--> Processing Dependency: madwifi-kmdl-2.6.15-1.2054_FC5xen0 = 0.9.6.0-20.rhfc5.at for package: madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0
--> Processing Dependency: bridge-utils for package: xen
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for bridge-utils to pack into transaction set.
bridge-utils-1.0.6-1.2.i3 100% |=========================| 4.8 kB 00:00
---> Package bridge-utils.i386 0:1.0.6-1.2 set to be updated
--> Running transaction check
--> Processing Dependency: madwifi-kmdl-2.6.15-1.2054_FC5xen0 = 0.9.6.0-20.rhfc5.at for package: madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0
--> Processing Dependency: libsysfs.so.1 for package: bridge-utils
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for sysfsutils to pack into transaction set.
sysfsutils-1.3.0-1.2.1.i3 100% |=========================| 6.3 kB 00:00
---> Package sysfsutils.i386 0:1.3.0-1.2.1 set to be updated
--> Running transaction check
--> Processing Dependency: madwifi-kmdl-2.6.15-1.2054_FC5xen0 = 0.9.6.0-20.rhfc5.at for package: madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0
--> Finished Dependency Resolution
Error: Missing Dependency: madwifi-kmdl-2.6.15-1.2054_FC5xen0 = 0.9.6.0-20.rhfc5.at is needed by package madwifi-hal-kmdl-2.6.15-1.2054_FC5xen0
[root@localhost Downloads]#

imdeemvp
26th March 2006, 12:49 AM
icantux can you help me with this:
Toshiba A75 S206
Just run:
yum install madwifi

karlos_pr
26th March 2006, 01:51 AM
Did not work
Nothing to do

cashel
28th March 2006, 01:39 PM
I have a DWL-G520 and followed your guide, but nothing happened. When I go to select the card under internet configuration, it isn't there. I have to go to other wireless where it still isn't listed, and there also is no option for ath0, just eth0-9. Here's my lspci:


00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:05.0 Multimedia audio controller: nVidia Corporation nForce Audio Processing Unit (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:0c.0 PCI bridge: nVidia Corporation nForce2 PCI Bridge (rev a3)
00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire (IEEE 1394) Controller (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
01:08.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)
01:09.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
01:0b.0 RAID bus controller: Silicon Image, Inc. SiI 3112 [SATALink/SATARaid] Serial ATA Controller (rev 01)
02:01.0 Ethernet controller: 3Com Corporation 3C920B-EMB Integrated Fast Ethernet Controller [Tornado] (rev 40)
03:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200] (rev a1)

cashel
2nd April 2006, 06:27 PM
I still cannot for the life of me get this working. I tried a lot of what raffe said and did:

adding alias ath0 ath_pci to the modprobe.conf
creating the ifcfg-ath0 file
adding acpi=off/pci=noacpi

none of this worked

People are mentioning that they are getting hardware detected notices, however I am not getting anything of that sort. Right now I have an inactive ath0 connetion listed under Network Config, but only because I edited it into the modprobe.conf. When I go to edit it, I get an error stating
ifcfg-ath0: line 8: was: command not found
ifcfg-ath0: line 8: was: command not found
ath_pci device ath0 does not seem to be present, delaying initialization..

Another thing, I seem to be running an SMP kernel (2.6.15-1.1833_FC4smp) which is for hyperthreading and whatnot, but I have an athlon XP 2200+. Should I be running this kernel? I have everything setup the way I want it save for this wireless issue and *really* do not want to have to reinstall everything at this point.

imdeemvp
3rd April 2006, 04:24 AM
Another thing, I seem to be running an SMP kernel (2.6.15-1.1833_FC4smp) which is for hyperthreading and whatnot, but I have an athlon XP 2200+. Should I be running this kernel? I have everything setup the way I want it save for this wireless issue and *really* do not want to have to reinstall everything at this point.
Reply With Quote I dont know why some people find themselve running smp kernels when there machine does not require it. It has never happen to me. Did you update your system and then tried to install atheros drivers OR was the kernel installed during the atheros installation?

cashel
3rd April 2006, 04:42 AM
I updated my system first thing after installing FC4 and then tried installing atheros drivers. However, I think I just got my card working by downloading a madwifi snapshot and manually installing it through make/make install. My card is detected now and I just have to configure it.

edit: I'm still having a little trouble. It recognized the hardware, but I had to configure it as an ethernet device, and it's listed as wifi0 not ath0. Also, it's failing when trying to get an IP, and I think it has something to do with the two ethernet ports on my motherboard (a7n8x dlx Rev.2). I had both eth0 and eth1 activated, but then deactivated eth0 in the bios. Now eth1 has become eth0 and whenever I try to deactivate it on Linux, I get an error saying
Device eth0 has different MAC address than expected, ignoring. Is it still trying to read the original eth0's MAC address or what? How can I fix this?

edit 2: I fixed the mac address issue, but my wifi card still isn't getting an IP address.

nyu
5th April 2006, 05:51 PM
Any comment!!!! :confused: Help me, thanks

[root@localhost ~]# yum install madwifi
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
atrpms [1/4]
atrpms 100% |=========================| 951 B 00:00
updates [2/4]
atrpms-stable [3/4]
extras [4/4]
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 152 kB 00:11
atrpms : ################################################## 755/755
Added 755 new packages, deleted 0 old in 4.40 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for madwifi to pack into transaction set.
madwifi-0.9.6.0-20.rhfc5. 100% |=========================| 4.0 kB 00:00
---> Package madwifi.i386 0:0.9.6.0-20.rhfc5.at set to be updated
--> Running transaction check
--> Processing Dependency: madwifi-kmdl-0.9.6.0-20.rhfc5.at for package: madwifi--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for madwifi-kmdl-2.6.16-1.2069_FC5 to pack into transaction set.
madwifi-kmdl-2.6.16-1.206 100% |=========================| 4.6 kB 00:00
---> Package madwifi-kmdl-2.6.16-1.2069_FC5.i686 0:0.9.6.0-20.rhfc5.at set to be updated
--> Running transaction check
--> Processing Dependency: /boot/vmlinuz-2.6.16-1.2069_FC5 for package: madwifi-kmdl-2.6.16-1.2069_FC5
Importing additional filelist information
filelists.xml.gz 100% |=========================| 875 kB 00:30
atrpms : ################################################## 755/755
Added 755 new packages, deleted 0 old in 15.19 seconds
--> Processing Dependency: madwifi-hal-kmdl-2.6.16-1.2069_FC5 = 0.9.6.0-20.rhfc5.at for package: madwifi-kmdl-2.6.16-1.2069_FC5
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for madwifi-hal-kmdl-2.6.16-1.2069_FC5 to pack into transaction set.
madwifi-hal-kmdl-2.6.16-1 100% |=========================| 3.9 kB 00:00
---> Package madwifi-hal-kmdl-2.6.16-1.2069_FC5.i686 0:0.9.6.0-20.rhfc5.at set to be updated
--> Running transaction check
--> Processing Dependency: /boot/vmlinuz-2.6.16-1.2069_FC5 for package: madwifi-hal-kmdl-2.6.16-1.2069_FC5
--> Processing Dependency: /boot/vmlinuz-2.6.16-1.2069_FC5 for package: madwifi-kmdl-2.6.16-1.2069_FC5
--> Finished Dependency Resolution
Error: Missing Dependency: /boot/vmlinuz-2.6.16-1.2069_FC5 is needed by package madwifi-kmdl-2.6.16-1.2069_FC5
Error: Missing Dependency: /boot/vmlinuz-2.6.16-1.2069_FC5 is needed by package madwifi-hal-kmdl-2.6.16-1.2069_FC5

imdeemvp
10th April 2006, 12:11 AM
Dont know if atrpms has the latest packages for the last kernel upgrade. They usally get behind a lot in updating packages.

Deep3y3s
18th April 2006, 05:02 PM
When I tried installing madwifi on FC4, I could not find the following directory.


/etc/yum.repos.d/atrpms.repo

I did find '/etc/yum.repos.d/fedora.repo' and added the the following lines.



[atrpms]
name=ATrpms for Fedora Core $releasever stable
baseurl=http://apt.atrpms.net/fedora/$releasever/en/$basearch/at-stable
enabled=1
gpgcheck=1

Should I just create the atrpms.repo folder and add the above information?


BTW, Madwifi did install with no hitches.

Jebba33
22nd April 2006, 10:17 PM
according to madwifi.org you should yum sharutils then use subversion, they have a nice tutorial here

http://madwifi.org/wiki/UserDocs/FirstTimeHowTo :)

doesnt mean this is the only way, but im such a noob it isnt funny and mine is working with my dlink dwl-g630 and my Orinoco gold.

scotta3234
24th April 2006, 04:05 AM
Hello,
First off I would like to sayI'm happily now using my wireless connection! A But... it wasn't with out the effort. I though i would share a little bit of information that could have saved me a very long time. After getting the madwifi drivers (which were downloaded from LIVNA repo, these seemed to not conflict with my yum as i had lots of trouble with the atrpm repos, thanks firewing1) i ran into some problems.
My atheros card was being displayed as eth1 and not as ath0. Instantly i knew something was wrong, as my card was detected in the "hardware" of the network configuration but not in the "devices" section. If you are having similar problems (such as those dvdz had earlier in this thread) i would suggest checking the following first as some of the previous information in this thread did not help.
1. Do not use network manager to set up your wireless (not sure if i could use it now but for setting it up use the network wizard under system/administration.
2. If network configuration/wizard can detect your hardware but it doesnt list it in devices do the following: DO NOT edit the network-ifcfg and change eth0 to ath0 as fedora will not start up because it just hangs at the boot when trying to activate ath0. DO follow this: http://www.fedoraforum.org/forum/showthread.php?t=30355&highlight=changing+eth1+ath0
(the last part about modprobe) The card should now be visable in the "device" section and you can follow the wizard to set up your wireless connection.

If this has been posted elsewhere i am sorry to the community managers but I felt as though people trying some of the earlier fixes in this post might run into the same problems i did, and this might save them some trouble.

imdeemvp
24th April 2006, 08:06 AM
When I tried installing madwifi on FC4, I could not find the following directory.



I did find '/etc/yum.repos.d/fedora.repo' and added the the following lines.



Should I just create the atrpms.repo folder and add the above information?


BTW, Madwifi did install with no hitches.
You have to create the repo entry: gedit /etc/yum.repos.d/atrpms.repo and a blank file will come up all you have to do is input or paste the info provided and then install using yum install madwifi.

Wolfshad
21st May 2006, 01:36 AM
I would like to know if this "How To" is good for Fedora core 5 ? Thanks for your help.

m9000
24th May 2006, 02:03 PM
I'm having trouble with this on FC4.

I've installed madwifi, and everything seems to work ok. The AP can be seen from a scan, but it doesn't seem to want to connect to it.

I have added the AP mac address, using iwconfig, but this has not made any difference. All I get from a ping is "destination host unreachable".

There is also another interface wifi0 which I'm not sure the purpose of? I gave it an IP, but it doesn't ping...

Sorry if I sound like a bit of a newbie...


[root@hendrix www]# iwconfig

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"default" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.437 GHz Access Point: 00:11:09:0C:51:7B
Bit Rate:0 kb/s Tx-Power:18 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:7A62-653F-5559-744E-3653-6C4A-66 Security mode:restricted
Power Management:off
Link Quality=0/94 Signal level=-95 dBm Noise level=-95 dBm
Rx invalid nwid:5618 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.




[root@hendrix www]# ifconfig
ath0 Link encap:Ethernet HWaddr 00:14:6C:2C:82:E9
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::214:6cff:fe2c:82e9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:C0:4F:A4:99:CD
inet addr:192.168.0.12 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:4fff:fea4:99cd/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:522178 errors:0 dropped:0 overruns:0 frame:0
TX packets:310194 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:617642320 (589.0 MiB) TX bytes:34571494 (32.9 MiB)
Interrupt:11 Base address:0xdc80

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3204 errors:0 dropped:0 overruns:0 frame:0
TX packets:3204 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3047736 (2.9 MiB) TX bytes:3047736 (2.9 MiB)

wifi0 Link encap:UNSPEC HWaddr 00-14-6C-2C-82-E9-F0-BC-00-00-00-00-00-00-00-00
inet addr:192.168.0.99 Bcast:192.168.0.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9390 errors:0 dropped:0 overruns:0 frame:3166
TX packets:4942 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:713626 (696.9 KiB) TX bytes:244537 (238.8 KiB)
Interrupt:10 Memory:dc940000-dc950000

Rob2687
3rd June 2006, 04:34 PM
Same problem as above...
wifi0 will transmit and recieve a bunch of packets while Network-Manager is trying to connect but it fails to connect. Nothing happens with ath0 though...

Adir Pinto
2nd July 2006, 11:14 PM
Hi There,

I´m very new Unix user and reading/following these messages I did:
yum install madwifi-kmdl-2.6.17-1.2139_FC5-0.9.1.24.rhfc5.at.i686.rpm -- > I got:
can not find a base url for repo:core :confused:
Think my error is inside atrpms.repo right? How should be real content for that? (kernel and FC5 details above on yum code) :(
Thanks in advance for any support !!! :)

wp.rauchholz
14th July 2006, 07:17 AM
I am having a strange problem there. I run FC5 under kernel kernel-2.6.17-1.2139_FC5 (on a "smp" box, but I guess there is no problem)

I followed somewhat the thread http://www.fedoraforum.org/forum/sh...hlight=dwl-g520

/sbin/lspci gives me
02:01.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

I have installed:
kmod-madwifi-0.9.0-1.2.6.17_1.2139_FC5 and kernel-2.6.17-1.2139_FC5

The card sees my AP
Cell 01 - Address: 00:80:5A:47:67:18
ESSID:"XXXXXXXX"
Mode:Master
Frequency:2.462 GHz (Channel XX)
Quality=38/94 Signal level=-57 dBm Noise level=-95 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100

But when trying to add the wirelss card it shows only up under the "Ethernet Connection" and NOT under the "Wireless Connection". So I cannot configure it! Any ideas?

pwalden
17th July 2006, 09:14 PM
I am seeing this too on my Atheros based card using MadWiFi driver.

I suspect the madwifi-ng driver is not setting the *correct bits* for the fedora configuration manager to recognize the car as a wireless, rather than ethernet card. A bug in MadWifi or Fedora, who knows?

So I found another thread that solved this the hard way by physically setting the configuration script. At least Iam now working.

http://forums.fedoraforum.org/showthread.php?t=112716

Note: I got the HWADDR from ifconfig -a
==========
A working configuration for madwifi requires:

1. In /etc/modprob.conf

alias wifi0 ath_pci
alias ath0 ath_pci
options ath_pci autocreate=sta

2. In /etc/sysconfig/networking/devices/ifcfg-ath0

IPV6INIT=no
ONBOOT=yes
USERCTL=yes
PEERDNS=yes
TYPE=Wireless
DEVICE=ath0
HWADDR=00:0f:b5:ee:e3:43 (replace with your hardware mac)
BOOTPROTO=dhcp
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ESSID=ap54g (replace with your access point id)
CHANNEL=1 (leave at 1 and it should pick up the correct channel for the above ap)
MODE=Managed
RATE=Auto

Obviously don't place my comments () in the files!

3. /etc/sysconfig/networking/devices/keys-ath0

KEY=your encryption key

Now you should be able to use either the gui or cli to manage the ath0 interface as fedora's scripts will parse these configuration files and call iwconfig for you.

pwalden
19th July 2006, 01:47 AM
There is a bug for this

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=187640

The fix is to merge the /etc/modprobe.d/madwifi contents into /etc/modprobe.conf

jakbo
20th July 2006, 04:46 AM
OK. I'm having a lot of trouble with this. I'm completely new to this. I've determined I have:
Atheros 5212 chipset
2.6.17-1.2157_FC5

I followed the first few instructions with no problems. I created the atrpms repo, as described in the instructions and then I went to gedit and did what the instructions say. Then I downloaded the drivers to my home directory. After that is when I ran into a wall. How do I unpack them and install them?

pwalden
20th July 2006, 05:26 AM
I used the livna binary depot (http://rpm.livna.org/configuration.html#Core5) with no trouble, except for the bug and work-around I reported in the previous post. Why not try that first.

install the kmod-madwifi-0.9.0-1.2.6.17_1.2157_FC5 package from livna using yum or yumex
merge the /etc/modprobe.d/madwifi contents into /etc/modprobe.conf
finish off with system-configuration-network wizard

freshmeat
4th August 2006, 03:48 PM
i need help, i have intallation of the madwifi. urgent!!! i've followed the steps that given:

# /sbin/lspci
....
08:0a.0 Ethernet controller: Atheros Communications, Inc. AR5006X 802.11abg NIC (rev 01)
...

# uname -r
2.6.17-1.2157_FC5

#yum install madwifi
http://apt.atrpms.net/fedora/5/en/i386/at-stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: Fri, 04 Aug 2006 14:47:04 GMT
Server: Apache/2.0.54 (Fedora)
Content-Length: 324
Content-Type: text/html; charset=iso-8859-1
Connection: Keep-Alive
Trying other mirror.
Cannot open/read repomd.xml file for repository: atrpms
failure: repodata/repomd.xml from atrpms: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from atrpms: [Errno 256] No more mirrors to try.

pwalden
5th August 2006, 04:09 AM
Sounds like the atrpms is down or misconfigured.

I used the livna (http://rpm.livna.org/configuration.html#Core5) depot with no trouble, except for the bug and work-around I reported in the previous post. Why not try that instead. install the kmod-madwifi-0.9.0-1.2.6.17_1.2157_FC5 package using yum or yumex

pradtv000
4th October 2010, 08:23 AM
[root@localhost ~]# yum install madwifi
http://apt.atrpms.net/fedora/8/en/i386/at-stable/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: atrpms. Please verify its path and try again
this is my problem