View Full Version : How to mount LVM volumes, help!

22nd July 2005, 06:30 PM
As I posted in another thread, I screwed up my main linux partition by messing with Volume groups. I can't boot now, but I'm using my computer with a Ubuntu Linux live CD, and I want to back up the data on my main linux partition.

This is my partition table:

Nombre Indicadores Tipo Tipo de S.F. [Etiqueta] Tamaño(MB)
hda1 Primaria Hidden HPFS/NTFS [] 13908.95
hda5 Lógica Linux ext3 13563.49
hda6 Lógica Linux ext3 [/boot] 106.93
Lógica Espacio libre 633.35
hda2 Inicio Primaria Linux LVM 11795.06

I want to extract the information from hda2, I can afford to lose everything else. But when I use pvscan, to recognize my volume groups, y get this message:

Couldn't find device with uuid 'fWExyO-sLNt-52mZ-oYb0-c2sU-TaoC-gFIvE6'.
PV /dev/hda2 VG VolGroup00 lvm2 [10.97 GB / 32.00 MB free]
PV unknown device VG VolGroup00 lvm2 [12.62 GB / 12.62 GB free]
Total: 2 [23.59 GB] / in use: 2 [23.59 GB] / in no VG: 0 [0 ]

I don't know how to mount these thing, i really don't know much about volume groups. Cand you give any advise?

Jeff Sadowski
22nd July 2005, 08:20 PM
Ok heres how to start if you boot with a disk that has lvm2 tools you can mount the logical volumes
I used slax-5.0.5 with lvm2 module I had to do the following commands

#load device module
modprobe dm-mod
#change the volumes that exist to active
vgchange -ay
#mount the logical partition
mkdir -p /mnt/VolGroup00/LogVol00
mount /dev/VolGroup00/LogVol00 /mnt/VolGroup00/LogVol00

then I could use it :-) hope this helps I love Logical Volume Management it takes a while to get use to but thats one reason I moved to Fedora from Slackware. I miss Slackware but am getting use to sysv init scripts. rpms really suck though and so many freeking dependencies. Its as if the builders of the applications made sure it needed as many dependancies as possable. Interlinking every package with every other package.

22nd July 2005, 10:27 PM
It seems that there's something else wrong, and I suspect that it is my boot partition (hda6):

root@ubuntu:/home/ubuntu # modprobe dm-mod
root@ubuntu:/home/ubuntu # vgchange -ay
Couldn't find device with uuid 'fWExyO-sLNt-52mZ-oYb0-c2sU-TaoC-gFIvE6'.
Couldn't find all physical volumes for volume group VolGroup00.
Unable to find volume group "VolGroup00"

Can I still mount my volume if theres one partition missing? I really need to get that data out somehow, it's very important stuff, but there's no hurry. I was thinking in maybe deleting my NTFS partition and doing a new Fedora Core 4 Install, to see if I could access that way.

Thanks for your advise! And yes, package dependencies can be a nightmare.

Jeff Sadowski
22nd July 2005, 10:47 PM
ouch ouch ouch that doesn't look good but maybe you accidendly changed the name of the volume group label or something maybe 'fWExyO-sLNt-52mZ-oYb0-c2sU-TaoC-gFIvE6' is what you named it to?
Maybe try renaming it to VolGroup00? Don't do anything you can't undo though. Maybe test volume groups on a seperate machine(or HD) if you have one and screw around with them. Try renaming them and things and see how that works try and reproduce the error if its just renaming the volume group and you name it back does this correct the error on a test machine. If you had multiple physical volumes you might be up the river without a paddle though. Volume Groups make upgradding easy because you can make a bunch of disks look like one. But if any one of those physical volumes is missing so might any files you had on it. I'm not sure but it could be if any one physical volume goes bad in a volume group you may loose the group. I havn't played with LVM as much in Linux as with HP Unix so I don't know all that much about it but it makes upgrading disks easier.

22nd July 2005, 11:02 PM
What happened was that I deleted a FAT32 partition that i had to share files between Windows XP and Fedora, and created a new ext3 partition that was supposed to be my /home partition.

But I didn't really know how to assing that partition to be home, and move everything there, so I entered every application in the Gnome menu that handled partitions, looking for something to do the task.

I came across the Volume Management System (or something like that). I saw the VolGroup00 volume, and other Unassigned partition. I assumed that the unassigned partition was my new ext3 one, and I moved it to VolGroup00, not really knowing what I was doing. Apparently, nothing happened, and I shut the machine off.

But when I tried to turn it on, I just got the grub command line. I first tought that it was just a grub problem. But after a while, and asking for advise, I realized it had something to do with the stupid Volume changes that I did.

I can still boot Windows, by typing the following in the grub command line:

rootnoverify (hd0,0)
chainloader +1

I have partition magic installed in my windows partition, and I used an option that allows you to boot from any other partition. I tried to boot from my Linux partition, but no I can't even star windows properly! It's a big mess... I need that info, most of all the pictures, being a photographer... This is the worst computer-related trouble I've gotten myself into in a long time.

And my computer is a laptop, so I can't really plug my hard disk into another machine (at least I don't know how).

I hope all this explanation should help other to see a solution :(

By the way... what's that uuid thing? And thanks for your time...