PDA

View Full Version : 2.6 kernel in FC1 doesn't boot; blank screen ...



Mishura
23rd February 2004, 09:57 AM
Today I tried installing the new 2.6.3 kernel in FC1 using these instructions http://fedoranews.org/jorge/howto/howto01.shtml verbatim.

However, when I boot using that kernel option in Grub, my screen goes blank, and my computer stops doing anything. I look at my hard-drive light and its not blinking, and I can't even hear the harddrive...

So, what exactly just happened here? I'm confused. Oh, and the system boots fine with the stock 2.4.22-nptl kernel.

The kernel name I tried installing is called "2.6.3-2.1.196".

Thanks in advance for any help.

fish
23rd February 2004, 11:47 AM
I've the exact same problem, I figured it might be my graphics card (SiS 630) but I've looked high and low on the internet and it seems other people can get it to work with the same card no troubles...

What card do you have Mishura? I've tried two different RPM packages and tried compiling myself, but to no avail :(

Oh, also I think the problem is something to do with when it starts the X-Server, as if I edit the parameter in grub from rhgb to 3, it will actually boot to the commandline....

feenixx
23rd February 2004, 06:03 PM
have you guys tried compiling vanilla kernele instead of arjanv's one?
fedora's 2.6.x kernel has almost every single debug option enable (which you won't
certainly need).. it wasn't stable under my system (and was slow as hell..)

boot in 2.4 kernel and copy 2.6's config file in somewhere safe. get kernel from
www.kernel.org and extract that in /usr/src

in kernel source dir execute
'make mrproper'
copy the config file you backed up earlier on to source dir named as '.config'
'make oldconfig && make 'xconfig'
.. and so on.

you can also make rpm out of compiled kernel using
'make rpm' rule.

Mishura
24th February 2004, 06:13 AM
My card is a GeForceFX 5200 (cheapy generic board, but good bang for the buck)

I'm going to try your suggestion Feenixx, and see if that works. I'll let you know on the results.

fish
26th February 2004, 12:26 PM
I've tried recompiling three times since my last post, twice with the source from the fedora kernel-source rpm, and another using the latest 2.6 kernel from kernel.org.
The first time I tried to disable DRM from the kernel, which didn't do anything different, the second time I also disabled the framebuffer, which again didn't do anything. I then tried this config with the source from kernel.org and exactly the same error.
When the xserver starts, the screen will go black, and I can push the capslock key to get a light, so it hasn't gone unresonsive, but I try getting to another virtual terminal and it stays black...
If i boot without rhgb (the graphical boot will cause it to do the 'crash'), and boot straight to runlevel 3, I can get a commandline and log in, so it's not like the kernel's completely screwed, but typing startx will cause this error...
If i press Ctl-Alt-Backspace the harddisk light will flash in the way it normally would if i did it whilst running the xserver, and Ctl-Alt-Delete will cause it to restart... so I think what's happening is that the xserver is running, but there's perhaps something stopping it displaying to the screen in some way?
Can anyone help at all, or suggest where I may ask for help? I'm not sure if I should post a bug or something at XFree86, the kernel people, or at Fedora... :s

feenixx
26th February 2004, 01:05 PM
this sounds exactly the problem I was facing awhile ago. you are using
Nvidia's own driver, and you compile module for it yourself?

if so, do this. modify XF86Config to use "nv" instead of "nvidia", this
will allow you to uninstall nvidia's drivers.

look this thread http://fedora.artoo.net/forum/viewtopic.php?t=288

at runlevel 3, pass --uninstall parameter to nvidia's installer and remove
files it says it can't remove manually. (but not ones that it failsto symlink)

reinstall driver and try again. this worked for me.

fish
26th February 2004, 02:22 PM
No, my card's an SiS630 so I'm pretty sure I shouldn't need to touch anything to do with NVidia with my setup, thanks for the input though :)

feenixx
26th February 2004, 04:42 PM
No, my card's an SiS630 so I'm pretty sure I shouldn't need to touch anything to do with NVidia with my setup, thanks for the input though :)

lol, sorry :)
somehow I thought reply came from Mishura..

fish
27th February 2004, 06:33 PM
Hehe, no problem! So if noone here can think of a solution, can you think where I should go to ask? I'm not sure whether it's an XFree86 bug, as the 2.6 kernel will boot providing it doesn't try to set up the XServer, but also the XFree86 does work under kernel 2.4, so it's not like either of them are broken individually... so do you reckon I should report it the kernel folks, Xfree folks, fedora people, or combinations of the above? Any input appreciated :)

vorte[x]
28th February 2004, 02:36 AM
Hi all,

I hate to be the party pooper, however you guys need to remember 2.6.3 is somewhat bleeding edge. Try older 2.6 kernels or even 2.4.

- V

fish
28th February 2004, 10:52 PM
I'm already using 2.4, it's just I keep hearing all this stuff about 2.6 being so great with all these added features and I'd like to try it out myself.... I'll try your suggestion of an older 2.6 kernel tomorrow if I get time :)

rsalles
12th March 2004, 05:01 PM
Well, one week working on it, and finally solved. Arjan didn't marked some "VERY" important entries in the .config file for avarage users (say, other video cards).
The main problem (for us) was Framme Buffer configuration for the correct video card (VESA if you have an generic/old one), and allowing it to the console.
How to fix:
this parameters:
# Console display driver options
# For generic graphic cards
CONFIG_FB_VGA16=yes
CONFIG_FB_VESA=yes
# For the console mode
CONFIG_FRAMEBUFFER_CONSOLE=yes
...

Let the CONFIG_LOGO options as Arjan's sets, this will make possible a nice color tux appear at boot time.

Without this you'll have a unusable framebuffer - a dark/blank screen - that doesn't render a pixel in console mode.

HTH,


RSalles

rsalles
12th March 2004, 05:06 PM
I forgot to mention:
Kernel is from Arjan's source rpm, version 2.6.3-2.1.196 and i can send to the forum members a .config file copy if you're in deep trouble to have it running.


RSalles