PDA

View Full Version : YUM problem...



erikj
22nd March 2004, 06:43 AM
Hey all,
This is my first post here so I'd first like to start off saying how great it is to find a large forum dedicated to this distro. I'm sure I can learn alot from ya'll and hopefully can contribute as I learn. Anways...I've had some problems with YUM. When I do 'yum check-update' it comes back with this...

Existing lock /var/run/yum.pid: another copy is running. Aborting.

Is it saying another copy of yum is running? How can that be? Also, I downloaded a new yum.conf file from http://fedora.artoo.net/faq/samples/yum.conf , where do I place it?
Thanks!
Erik

gonzalo76
22nd March 2004, 07:16 AM
Hi,

1. Do you know that you have to be root to run yum? Became root with the command "su", enter the su password and then type "yum check-update"

2. You have to place the new yum.conf to /etc/ directory. (/etc/yum.conf). Again, you have to be root to do this.

Good Luck !

mhelios
22nd March 2004, 07:17 AM
Welcome erikj. :)

The yum error is a known bug that occurs if you have two yum processes running at the same time as you easily realised.

The fix is upstream to FC's development, and you may want to upgrade (if you haven't already) to the latest yum package,

To fix this error, try deleting as root the /var/run/yum.pid file to remove the lock on the yum process.

The sample yum.conf should be placed in /etc/yum.conf

erikj
22nd March 2004, 07:23 AM
Thank you both. Yes, I was root when I tried to update. I'll try to delete the yum.pid file and see if that works. To upgrade yum...can I do 'yum upgrade yum'? Or will I have to download a RPM somewhere?
Thanks again.

mhelios
22nd March 2004, 08:10 AM
This should do it:


yum update yum

If you do have problem with that such as cyclic dependencies, use this to upgrade it:


up2date -u yum

NOTE: Both need root privileges to run.

erikj
22nd March 2004, 08:09 PM
Oh right.. yum update yum not upgrade :rolleyes:

Thanks, it seems to be working now!

foolish
22nd March 2004, 08:29 PM
Here's a nice intro to the basics of yum:
http://fedoranews.org/tchung/howto/2003-11-09-yum-intro.shtml

Jman
23rd March 2004, 11:56 PM
Yum may be running its daily update if you have that enabled.

Marked as resolved.
Remember the thread starter can mark resolved.

ntxploits
29th December 2007, 07:15 AM
the same problem happen to me..


[root@localhost ~]# yum check-update
Loading "installonlyn" plugin
Existing lock /var/run/yum.pid: another copy is running. Aborting.

i find the yum process and kill it


[root@localhost ~]# ps -ef | grep yum
root 2138 1 9 01:31 ? 00:01:27 /usr/bin/python /usr/sbin/yum-updatesd
root 3183 3080 1 01:47 pts/0 00:00:00 grep yum
[root@localhost ~]# kill 2138
[root@localhost ~]# ps -ef | grep yum
root 3185 3080 0 01:47 pts/0 00:00:00 grep yum

and then i run again yum check-update and it's working

marcrblevins
29th December 2007, 10:18 AM
You should not remove the pid file cause yum-updatesd was running. If you want to run yum check-update, you have to turn off yum-updatesd first.



su -
service yum-updatesd stop
yum check-update
service yum-updatesd start

linuxpcmancn
29th December 2007, 10:33 AM
You'd better shutdown the service "yum-updatesd",just "sudo chkconfig --level 35 yum-updatesd off"

ntxploits
29th December 2007, 12:37 PM
mm...what is the different between kill the process and stop the service

marcrblevins
30th December 2007, 10:01 AM
Using kill basically kills it ungracefully. Should learn to stop programs properly with services, etc.

The reason I said you should run 'services yum-updatesd stop' was because the yum-updatesd is a daemon and its uses the same PID file as when trying to use yum itself. The PID file is a semaphore file to prevent other program perform the same job.