Fedora Linux Support Community & Resources Center
  #61  
Old 15th May 2006, 09:58 PM
Firewing1 Offline
Registered User
 
Join Date: Dec 2004
Location: Canada
Age: 26
Posts: 9,224
I can't be certain but I think
http://prdownloads.sourceforge.net/i...ar.gz?download
That should work.
Code:
./configure;make;make install
sort of thing.
Firewing1
__________________
[+] My open source software and blog
[+] Some of my howtos: (for full list, click here)
Reply With Quote
  #62  
Old 29th May 2006, 07:02 PM
rahulgandhi Offline
Registered User
 
Join Date: Apr 2006
Posts: 58
Hi I need u r help immediately if possible. After all the research i have done for doing rsh and rlogin i made a file and here is the attachment how it looks like but i am still unable to rsh or rlogin:



RSH to remote system without a password

1.Configuring the Nodes :

To build a cluster, configuration of system files is changed as follows;
“/etc/hosts”: This system file should be edited on every node of cluster. It consists of IP addresses and names of workstations in a cluster.

enter the host name and their IP address in file hosts (path : /etc/hosts).
This file has the host to ip address mapping and change the permissions to 444
(command: chmod 444 hosts)

127.0.0.1localhost localhost.localdomain
192.168.0.3rdma1.rdma2domain
192.168.0.4rdma2.rdma2domain

2.Enter the trusted hosts in the .rhosts file (path: /$HOME/.rhosts)

“rhosts”: This file is created in each user’s home directory.
It is used during rhosts authentication. If the client host is found in this file, users can automatically login by using remote shell without supplying passwords.

The file on Rdma1looks like:

# Enter the trusted hostnames in the network.

rdma1.rdma2domain
rdma2.rdma2domain


Change the permission to 600
Command: chmod 600 .rhosts

3.Enable RSH and RLOGIN services in the “/etc/xinetd.d/rsh” and “/etc/xinetd.d/rlogin” files.
RSH
default: on description: The rshd server is the server for the rcmd(3) routine and, consequently, for the rsh(1) program. The server provides \ remote execution facilities with authentication based on \ privileged port numbers from trusted hosts.
service shell {
socket_type = stream wait = no user = root log_on_success += USERID log_on_failure += USERID server = /usr/sbin/in.rshd -h disable = no
}
RLOGIN
default: on description: rlogind is the server for the rlogin(1) program. The server \
provides a remote login facility with authentication based on \ privileged port numbers from trusted hosts.
service login {
socket_type = stream wait = no user = root log_on_success += USERID log_on_failure += USERID server = /usr/sbin/in.rlogind disable = no
}
(Note that I left the original descriptive text in these files untouched, so you can see that they are indicated to be enabled, when, in fact, they are disabled; i.e. the "disable = no" line reads "disable = yes" in their original form. See *NOTE below for more on this.)

4.Add RSH and RLOGIN to the “/etc/securetty”: It identifies secure terminals from where superuser is allowed to log in.
Simply, add rsh, rlogin and rexec at the end of file. After configuration, this file will look like this:
console
vc/1
vc/2
vc/3
tty1
tty2
tty3
tty4
rsh
rlogin

5.To allow RLOGIN without password, change the configuration in the “cd /etc/pam.d” (not vi) on the systems:
It consists of number of configuration files which effect logins of the various services.
Modify “rsh” & “rlogin” file. Arrange “rhosts” in the first line and “securetty” in the second line.
Finally, it looks like this,

auth required /lib/security/pam_rhosts_auth.so
auth required /lib/security/pam_securetty.so
auth required /lib/security/pam_nologin.so
auth required /lib/security/pam_env.so
auth required /lib/security/pam_stack.so service=system-auth
account required /lib/security/pam_stack.so service=system-auth
session required /lib/security/pam_stack.so service=system-auth

6.Testing the configuration:

Restart the network service using following command,
# service xinetd restart
#service network restart

How to change the hostname :

1: To check the present host name use command
# uname –n
Or
#hostname –a
2: To change the host name use the command
#hostname “newhostname”
and you need to change in the file “/etc/sysconfig/network”
it looks like :

NETWORKING=yes
HOSTNAME=rdma2.rdma2domain



----------------------------------------------------------------------------------------------------------------


kernel used is : 2.6.16-1.2111_FC5smp

Error messages i am getting on two systems used are like this:


for rlogin: connect to addresses --- port 543: Connection refused

for rsh: socket: protocol error or closed connection in circuit setup
pollrotocol failure in circuit setup

On another system:

for rlogin: connect to address port 543: No route to host

for rsh: connect to address port 544: No route to host.



So can u plz help me if i need to change any other settings or disable firewall which might be blocking this action or do i need to configure anything else.
Reply With Quote
  #63  
Old 29th May 2006, 07:03 PM
rahulgandhi Offline
Registered User
 
Join Date: Apr 2006
Posts: 58
plz help me immediately i need to get this done today. am i missing anything.
Reply With Quote
  #64  
Old 29th May 2006, 07:47 PM
rahulgandhi Offline
Registered User
 
Join Date: Apr 2006
Posts: 58
The above procedure was followed for FC4 and we upgraded it to FC5 now, so what changesd do i need to make for rsh and rlogin to work.
Reply With Quote
  #65  
Old 18th June 2007, 03:59 PM
sriven Offline
Registered User
 
Join Date: Jun 2007
Posts: 9
hi rahul

i want to know which version(build) of MS iscsi were u using?

thx
Reply With Quote
  #66  
Old 27th January 2008, 10:05 PM
jackpal Offline
Registered User
 
Join Date: Aug 2005
Posts: 16
Wow. Great stuff. This one helped me out alot. Thanks rahulgandhi !!!

This all worked great on Fedora8 connecting to a LeftHand Networks iSCSI target.

The one thing that got me was the authentication. To make it easy for the first time disable CHAP authentication on the LeftHand iSCSI target. Then in your /etc/iscsi/iscsid.conf make sure the authentication is commented out. It is by default but I mucked it up and enabled it after reading some other docs. If you try to authenticate when the target does not have any authentication turned on then it will fail with:

"iscsiadm: discovery login to 10.10.10.2 rejected: initiator error (02/02), non-retryable, giving up"
Reply With Quote
  #67  
Old 22nd September 2008, 10:03 AM
petehaaswws Offline
Registered User
 
Join Date: Sep 2008
Posts: 1
Thumbs up iSCSI: no records found

Hi rahulgandhi,

I had this issue with no records found and I fixed it.

Even when I had full debugging enabled on the Initiator end and I took CHAP authentication out the picture, I was still not able to diagnose the fault.
I found the solution to be the following:
On our Windows Storage Server acting as iSCSI target, I had to blow away the entire target including volume and recreate from scratch. After this I carried out the following:
iscsiadm -m discovery -t st -p 192.168.5.5
and then of course a restart of service:

/etc/init.d/iscsi restart
Logging out of session [sid: 8, target: iqn.1995-06.com.microsoft:storage-iqn.storage.spitfireuk.net-target, portal: 192.168.5.5,3260]
Logout of [sid: 8, target: iqn.1995-06.com.microsoft:storage-iqn.storage.spitfireuk.net-target, portal: 192.168.5.5,3260]: successful
Stopping iSCSI daemon: /etc/init.d/iscsi: line 33: 31388 Killed /etc/init.d/iscsid stop
iscsid dead but pid file exists
Turning off network shutdown. Starting iSCSI daemon: [ OK ]
[ OK ]
Setting up iSCSI targets: Logging in to [iface: default, target: iqn.1995-06.com.microsoft:storage-iqn.storage.spitfireuk.net-target, portal: 192.168.5.5,3260]
Login to [iface: default, target: iqn.1995-06.com.microsoft:storage-iqn.storage.spitfireuk.net-target, portal: 192.168.5.5,3260]: successful
[ OK ]

This problem origonally appeared when I needed to remove targets from the Initiator database, like so:
iscsiadm --mode node iqn.1995-06.com.microsoft:storage-mailboxes-target --portal 84.219.153.118:3260 --op=delete

I found I was not able to add any targets back into the database afterwards for that partictular iSCSI target.

I believe the Initiator may have a software bug which causes this.

Hope this helps.
Reply With Quote
Reply

Tags
core, fedora, upgrade

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade from Fedora Core 1 to Core 5 nava Installation, Upgrades and Live Media 4 21st June 2006 03:54 PM
upgrade via yum frmo fedora core 2 to fedora core 3 ccole Installation, Upgrades and Live Media 1 4th May 2005 05:21 AM
Upgrade from Fedora Core 1 to Core 2 jayeshrode Installation, Upgrades and Live Media 2 8th June 2004 05:30 PM


Current GMT-time: 19:24 (Monday, 21-08-2017)

TopSubscribe to XML RSS for all Threads in all ForumsFedoraForumDotOrg Archive
logo

All trademarks, and forum posts in this site are property of their respective owner(s).
FedoraForum.org is privately owned and is not directly sponsored by the Fedora Project or Red Hat, Inc.

Privacy Policy | Term of Use | Posting Guidelines | Archive | Contact Us | Founding Members

Powered by vBulletin® Copyright ©2000 - 2012, vBulletin Solutions, Inc.

FedoraForum is Powered by RedHat